none
Enabling Storage Spaces Direct - error code: 50

    질문

  • Hi all,

    I use Windows Server version 1803.

    I create nested S2D PoC on Windows Server 2016 Hyper-V.

    I can not "Enable-ClusterStorageSpacesDirect –CimSession <ClusterName>"

    Does anyone encounter the same error?

    2018년 5월 27일 일요일 오전 2:22

모든 응답

  • Hi,

    For now, I couldn't find more information about error code 50 related enabling S2D.

    Before you enable s2d, could you please run cluster validation tests?

    Anything wrong in the validation report?

    Please check if the hardware meet the requirements. All servers must be identical in hardware components, drivers, firmware, and configuration.

    Maybe also refer to the thread discussed before.

    https://social.technet.microsoft.com/Forums/lync/en-US/a18c94be-25b5-4241-ab74-47738da70d9a/enableclusters2d-failed-to-set-faultdomainawaressdefault-on-storage-subsystem?forum=winserverClustering

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018년 5월 28일 월요일 오전 7:12
    중재자
  • Hi, I have the same here. as all the "nodes" are Hyper-V-VM's they should meet the requirements.

    I've tested to build a S2D-Cluster with Server 2016 and all Patches -> Success

    I've Evicted, reinstalled with Server 2016 Version 1803 and added to the Cluster all nodes one by one -> Success

    I've updated the ClusterFunctionLevel to "10" on the Cluster

    ANY ...-ClusterS2D cmdlet is not working with the same error "50", tested with Get-ClusterS2D and Disable-ClusterS2D

    Looks like there where some structures changed but changes are missing in the powershell cmdlet's.

    It would be nice to try out the great new S2D features of Server 2016 Version 1803.

    Thanks a lot for fixing.

    Sven

    ### Update ###

    I've done the same again (create a 2016 Cluster with ClusterFunctionLevel 9; evict, reinstall 2016-1803, join each node one by one).

    As long as i don't upgrade the ClusterFunctionLevel to 10, I'm able to join an original 2016 node to the cluster and run Get-ClusterS2D on that Node.

    On all of the 2016-1803 nodes non of the ...-ClusterS2D cmdlets are working, all exit with this "error 50"

    Cheers, Sven

    • 편집됨 SvenRuben 2018년 6월 3일 일요일 오전 5:12
    2018년 5월 31일 목요일 오후 11:41
  • Hi,

    Can confirm this issue myself, and have run into the exact same situation.

    No s2d commandlets will run on a cluster created with build 1803 at this stage, with all available updates installed.

    Always get the same (following) result:

    Failed to run CIM method GetStorageSpacesDirect on the root/MSCLUSTER/MSCluster_StorageSpacesDirect CIM object.  The CIM method returned the following error code: 50

    To reproduce:

    Configure a 2 node cluster with build 1803, attempt to run s2d commandlets, like "get-clusters2d"

    Cheers

    Adrian

    2018년 6월 15일 금요일 오전 1:13
  • Just wanted to add in:
    We experience the same issue with a newly installed windows 1803 cluster.
    2018년 6월 20일 수요일 오후 3:23
  • We used our installation process for both Windows Server 2016 1607 and 1803 version and we have same troubles like you.
    All report cluster (Test-Cluster) pass successfully.

    2018년 6월 22일 금요일 오후 1:33