locked
Essentials Client connector broke again after win 10 2004 Feature Upgrade (already happened on 1903) RRS feed

  • 질문

  • Hello,

    Can anyone inform procedure to reconnect W10 clients to 2016 Essentials Server after the latest  Feature upgrade (2004) ?

    Again the problem resurfaces! It had already happened on Feature Upgrade to 1903.

    Thanks.

    2020년 6월 23일 화요일 오후 5:44

모든 응답

  • on each client:

    Uninstall connector

    reboot

    add skipdomainjoin reg dword:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\ClientDeployment]
    "SkipDomainJoin"=dword:00000001

    reinstall connector. 

    I've looked and looked for a way to automate, no joy.


    2020년 6월 23일 화요일 오후 9:13
  • Hi,

    Feature update or system upgrade may break connection/connector to WSE. It is recommended to re-connect client to WSE if such problem happens.

    Also, I will test on my VM, if same problem happens, I will post your feedback to product team.

    Thank you for your understanding. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020년 6월 24일 수요일 오전 3:47
  • Noted - I went from 1909 to 2004 on a WSE connected client and the connector did not break.
    2020년 6월 24일 수요일 오전 8:07
  • Hi,

    Thank you for your information, I had posted it to product team. Also, if you have an feedback/suggestion about Windows Server, you can post on Windows Server – General Feedback forum by yourself:
    https://windowsserver.uservoice.com/forums/295047-general-feedback

    Best Regards,
    Eve Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020년 6월 26일 금요일 오전 1:31
  • This actually is wrong - it broke in a different way than before. In the past, after a feature update the connector would go gray, not green, and the server Dashboard would show offline. In this case, the connector showed green (which is what fooled me), but could not connect for backup status, and the Dashboard showed offline. I had to reinstall as above.
    2020년 7월 1일 수요일 오전 4:42
  • Why does Microsoft  promote its products as more user friendly if an upgrade from Microsoft Breaks Basic but important Functionality "Backups" and they don't consider it a priority to solve it.

    The most recent updates have been a nightmare to users and administrators ! Most are cursing more than usual !!

    Also Posting General Feedback for an issue like this is not something I would propose to a client, but this is my way of doing things, not Microsoft's way apparently.

    Not Happy.

    Even IT support companies don't like to mess with it... they recommend rollback, but.. tried once on a client only .. and guess what ... didn´t go well.

    Microsoft lately is all Marketing, but no real deal!

    2020년 7월 15일 수요일 오후 7:57
  • This doesn't work for me.  I have two clients and the essentials connector broke after both upgraded to 2004.  I've followed this, but both cannot re-install the connector with the "server not available" error.  They have the server as their DNS setting, and have done plenty of research to no avail, so not sure where to go from here.  MS just basically destroyed our ability to do regular backups...
    2020년 7월 15일 수요일 오후 9:54
  • I have tried this just now. But when I try to reinstall the Connector, the server gets, found, the recognises that the client already exists and then it just sits there, eventually exiting with "Server not available: error.

    I had the same problem after the upgrade to 1903.

    Does anyone have any ideas?

    (The server is actually WS2012R2, client has just been upgraded to Win 10 2004 from 1909; another machine on 1909 backs up happily).



    • 편집됨 Wigster 2020년 7월 25일 토요일 오전 10:08
    2020년 7월 25일 토요일 오전 10:06
  • I have a couple of suggestions - one, did you add the skipdomainjoin reg key before reinstalling the connector?

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\ClientDeployment]
    "SkipDomainJoin"=dword:00000001

    and two - try connecting to the connect site by IP rather than name?

    http://192.168.1.10/connect instead of http://contoso-wse.domain.local/connect

    2020년 7월 25일 토요일 오전 11:37
  • Of course where I failed was in step 0: a spurious space was added in ClientDeployment in the Reg key.

    Now that I fixed that, it seems to work. Apologies for time wastage.

    2020년 7월 27일 월요일 오후 7:02
  • I just spent about 10 hours debugging a SATA problem that was resolved by removing power from the computer for a minute. I always think of this thing from Maurice Wilkes:

    Wilkes, Maurice - On Debugging

    "As soon as we started programming, we found to our surprise that it wasn’t as easy to get programs right as we had thought. Debugging had to be discovered. I can remember the exact instant when I realized that a large part of my life from then on was going to be spent in finding my own mistakes."

    Of note: I think the reconnection process is what breaks the RDP_MAPPING_<SID> remote access permissions groups. When the machines are initially connected the to WSE server, an AD security group called RDP_MAPPING_computerSID is added to the Remote Desktop Users group on each machine so we can control RDP access for each machine from the Dashboard rather than the local Users and Groups or System control panel. But this group is missing from machines that have been through this reconnection process I think. I have been manually adding them back.

    2020년 7월 27일 월요일 오후 8:22