none
MIM 2016 Miisactivate error on hot standby

    질문

  • I'm trying to set up a hot standby sync server for an existing MIM 2016 v4.4.1749.0 server. I ran through the installation steps without any issue, but when I tried to the miisactivate command with syntax like:

    miisactivate c:\temp\miiskeys.bin CONTOSO\service-mimsync *

    It popped up a usage error for MIIS key management utility, usage MIISKMU

    with arguments of:  /e filename [/u:username {password | *}] [/q].

    I tried rerunning miisactivate with the adjusted arguments, and that gives me an MIIS warm standby activation tool syntax error that tells me my first syntax attempt should be fine. So it looks like miisactivate calls a sub process and passes arguments in an incorrect way. Anyone run into this problem and have any work around suggestions?


    • 편집됨 Nathan Linley 2018년 6월 6일 수요일 오전 2:38 spelling
    2018년 6월 6일 수요일 오전 2:37

모든 응답

  • It's been a long time since I've used it - you may have to report that to MS.

    Again it's been a long time since I've done it - but re-running the setup in Repair mode used to be an alternative way to activate a standby.


    http://www.wapshere.com/missmiis

    2018년 6월 8일 금요일 오후 9:54
  • Thanks for the reply.  I'm asking our DSE to see if they are able to come up with any answers and share any solutions here.

    From procmon, I see the miisactivate process launching miiskmu with "/i keyfilepath {0E19E162-827E-4077-82D4-E6ABD531636E} /u:domain\username *".  The /i and the guid value aren't in the listed syntax for the command, so who knows which part it isn't liking.  The guid shows up as a string in the miiskmu.exe file, but I couldn't find it anywhere else.

    If I take that same command and remove the guid value, it runs and asks for a password this time, but then it throws an error saying the key set is not what it expects for the db. 

    2018년 6월 12일 화요일 오전 6:27
  • I was told by MS that this is a bug that started after MIM 2016 SP1 and will be addressed in an upcoming hotfix.

    ------ https://myitpath.blogspot.com

    2018년 6월 20일 수요일 오후 11:39