none
SharePoint workflows (2013) not running. RRS feed

  • 질문

  • We all of a sudden had our SharePoint 2013 workflows stop running. We can't figure out if there was an update. The only thing that we did on the day this started happening is we enabled the Windows Desktop Experience feature. We have tried turning it back off and they still do not work. SharePoint 2010 workflows to run manually. We have re-installed the workflow manager as well as all associated services. Any help would be appreciated.

    Thanks,

    David

    2019년 9월 16일 월요일 오후 10:21

모든 응답

  • Try registering the workflow service with the below command.

    Register-SPWorkflowService -SPSite https://site_name -WorkflowHostUri https://workflow.contoso.com:12290 -ScopeName SharePoint
    Thanks & Regards,


    sharath aluri

    2019년 9월 17일 화요일 오전 12:36
  • Hi Sharath, thanks for the reply, but we have already tried that. Any other suggestions?
    2019년 9월 17일 화요일 오후 3:16
  • Make Sure the workflow Services are running fine in the workflow Manager. Try running the below command and check the status.

    Get-SBFarmStatus

    Get-WFFarmStatus

    Thanks & Regards,

     

    sharath aluri

    2019년 9월 18일 수요일 오전 12:09
  • Hi Sharath, it appears to me that all is ok with the status. Do you see any services I may be missing or have any other suggestions?

    Thanks again for your help.

    ServiceName                                  ServiceStatus

    WorkflowServiceBackend                 Running

    WorkflowServiceFrontEnd                Running

    ServiceName                                  Status

    Service Bus Gateway                       Running

    Service Bus Message Broker             Running

    Service Bus Resource Prov...            Running

    Service Bus VSS                              Running

    FabricHostSvc                                 Running

    • 편집됨 DAB2629 2019년 9월 18일 수요일 오후 3:57
    2019년 9월 18일 수요일 오후 3:54
  • Nope that's it. try restarting the services and then give it a try.

    Thanks & Regards,


    sharath aluri

    2019년 9월 18일 수요일 오후 4:07
  • Hi,

    Any ULS logs showing errors?

    We had to go thru and do the app permissions for some workflows a few months ago. You might try this on one of the workflows.. https://www.c-sharpcorner.com/article/get-user-profile-properties-data-in-sharepoint-designer-2013-workflow/ 

     Just go thru steps in the section:  "Granting the App Permissions"

    After we did this, workflows were happy again.

    Another resource we used. https://docs.microsoft.com/en-us/sharepoint/dev/general-development/create-a-workflow-with-elevated-permissions-by-using-the-sharepoint-workflo

    Thanks,

    Monty


    • 편집됨 NiteWalker 2019년 10월 10일 목요일 오후 6:20
    2019년 10월 10일 목요일 오후 6:18