none
Windows 8에서 .Net Framework 4 또는 4.5 설치되어있을경우 .Net Framework 1.0 서비스 팩 설치 실패 RRS feed

  • 질문

  • Windows 8에서 .Net Framework 4 또는  4.5 설치되어있을경우  .Net Framework 1.0 서비스 팩 설치가 불가능합니다.

    2013년 4월 30일 화요일 오전 9:47
    중재자

답변

  • .Net Framework 4 또는 4.5 설치와 .Net Framwork 1.0 설치 사이에 알려진 호환성 문제가 있습니다.

    설치되어지는 .Net Framework 4 또는 4.5는  .Net Framwork 1.0 설치 불가능하게 registry key를
    설정되어집니다. 그렇기 때문에 만일 .Net Framework 1.0과 4 또는 4.5를 같은 컴퓨터에서 설치를 필요로한다면, 첫번째로 .Net
    Framework 1.0 설치 후 .Net Framework 4 또는 4.5를 설치해야합니다.

    I ran into a similar issue recently that I want to highlight as well because
    I didn’t find any official documentation about this behavior. 또한 .NET Framework
    1.0이 설치 되어있어도 .Net Framework 4 또는 4.5는 .Net Framework 1.0 service packs 도  설치
    불가능하게 설정하여 버립니다. 그럴 경우 아래와 진행합니다.

    1. .Net Framework 4 또는 4.5 삭제

    2. .Net Framework 1.0 service pack 설치

    3. .Net Framework 4 또느 ㄴ4.5 재설치

     

    이 이면에는, .NET Framework 1.0 설치는 Type 19 커스텀 액션으로 구현되어진 블록을 포함하고 있기 때문이다. 이 커스텀 액션은 초기
    설치와 복구되는 동안 작동하기 위해서 야기되어집니다. 이때 서비스 팩 설치도 복구와 동등하게 작업되어지면서 블록이 발생되기 때문입니다.

    [출처]

    http://blogs.msdn.com/b/astebner/archive/2013/04/24/10411452.aspx

    2013년 4월 30일 화요일 오전 9:48
    중재자