none
SQL Server 2008 R2 에서 프로세서 메모리가 2G이상 안 올라 갑니다. RRS feed

  • 질문

  • winserver 2008 r2 64비트 버전에 sqlserver 2008  메모리 16G 에서 프로세서 메모리가 2G(실제로는 1.7)이상 안올라 갑니다.

    sql server 에서는 최소서버 메모리 0, 최대 서버 메모리 13500MB로 되어 있습니다.

    해결 방법좀 알려 주세요. 감사합니다. 




    • 편집됨 양윤창 2015년 10월 19일 월요일 오전 12:47
    2015년 10월 16일 금요일 오전 7:16

모든 응답

  • Microsoft SQL Server 필요에 따라 메모리를 동적으로 확보하거나 해제합니다. 따라서 일반적으로 관리자는 SQL Server에 할당해야 하는 메모리의 양을 수동으로 지정할 필요가 없습니다.

    하지만 필요한 경우 관리자는 수동으로 SQL Server에 할당되는 메모리의 최대값(max server memory)를 변경할 수 있습니다.

    이에 대한 자세한 내용은 아래 포함되어 있는 웹 문서를 통해 확인하실 수 있습니다.

    서버 메모리 옵션
    https://msdn.microsoft.com/ko-kr/library/ms178067(v=sql.105).aspx

    2015년 10월 16일 금요일 오전 9:22
  • 안녕하세요.

    만약 32Bit로 설치한 경우라면, AWE 옵션을 설정해야 2GB 이상 메모리를 사용할 수 있습니다.

    아래 명령문으로 확인이 가능합니다.

    sp_configure 'awe enabled'

    만약 0이라면, 아래 방법으로 1로 설정하고 SQL Server를 재시작 해주면 됩니다.

    sp_configure 'awe enabled', 1

    reconfigure

     

    답변이 도움이 되었으면 좋겠습니다.

    Younggun Kim

    MCDBA, MCITP
    Consultant @ Database Division in SQLRoad
    http://www.sqlroad.com  http://www.sqlserver.co.kr
    ygkim@sqlroad.com

    • 답변으로 제안됨 Boram Yi 2015년 10월 27일 화요일 오전 9:05
    2015년 10월 18일 일요일 오후 12:13
  • 32비트라고 해도, 최대 서버메모리가 잡혀 있다는 이야기는

    LOCK IN MEMORY 및 AWE 가 활성화 되어 있을 것이구요

    그렇다면,최소가 0 이라서 그런거죠 

    현재 2GB 이상 사용하지 않는 다는의미죠 

    최소를 올리면 메모리 사용량이 더 올라갑니다.


    • 답변으로 제안됨 Boram Yi 2015년 10월 27일 화요일 오전 9:05
    2015년 10월 21일 수요일 오전 5:06
  • 혹시

    실행 > msconfig > 부팅 탭 > 고급 옵션 >  최대 메모리가 설정되어 있을수도 있습니다.

    확인 해보세요...

    • 답변으로 제안됨 Boram Yi 2015년 10월 27일 화요일 오전 9:05
    2015년 10월 21일 수요일 오전 5:12