none
Windows Installer 로깅을 설정하는 방법. 로그파일이 생성되지않는 증상 RRS feed

  • 질문

  • 안녕하세요. 

    ArcGIS Server 소프트웨어 설치시 services.msc에 정상적으로 등록되지 않는 장비가 있어

    Windows 로깅 기능을 사용하여 설치 과정에 대한 로그메세지를 보려합니다.

    아래 주소의 수동 문제해결 방법으로 진행하고 있습니다. (링크가 들어가지 않아 제외함)

      - microsoft support 페이지의 Windows Installer 로깅을 설정하는 방법

    현재 2개의 노트북에스트 중이며  둘다 Windows 10 Enterprise 64bit 입니다.

    A 노트북과 B 노트북으로 적겠습니다.
    A 노트북은 회사의 개인용 장비(문의자 본인용)이며

    AhnLab Policy Agent 4.6

    AhnLab V3 Internet Security 9.0

    보안 프로그램이 설치되어있습니다.

    B 노트북은 회사의 테스트 장비로 현재 보안프로그램이 설치되어있지 않습니다.

    A 노트북은  Dell 이고 B는 HP 이며 A가 더 최신모델입니다.

    A 노트북으로 오늘 오전에 레지스트리를 등록하고 테스트를 하는 과정에서 로그가 생성되지 않아

    V3의 실시간 보안들을 해제한 후 프로그램들을 설치,제거 시도 했었고

    11시 29분과 32분인 MSI xxxxx .LOG 파일 2개가 생겼었습니다.

    %temp% 폴더에 생성된 로그 파일은 문서폴더로 복사 후 삭제하였고 레지스트리는 삭제하였습니다.

    이미지 첨부불가로 삭제

    이후 B 노트북에서도 로그파일 생성을 시도하였으나 생성되지 않아 확인을 위하여

    A 노트북에서 다시 레지스트리를 생성 후 로그생성을 시도해봤으나 현재 생기지가 않고 있습니다.

    A 노트북에서 테스트한 내용

       레지스트리 생성 후 재부팅

       V3 와 AppCheck 감지 해제

       msi 설치 파일들로 설치와 삭제 진행

       %temp% 폴더와 Windows/temp 폴더에 MSI로 시작하는 파일 생성 여부 확인

       파일이 생성되지 않아 삭제하였던 오전의 MSI파일을 두개의 temp경로에 복사

       msi 설치 파일들로 설치와 삭제 진행

       로그 파일이 생성되거나 업데이트 되지 않음을 확인

    오전에 로그가 생성된 msi 설치파일

       ArcGIS Data Store 10.6.1

    오후에 테스트로 추가/제거한 msi 설치파일

       ArcGIS Data Store 10.6.1

       ArcGIS WebAdaptor - Java 10.6.1

       VertualBox 5.2.18

       ArcGIS Desktop 10.6.1

    ------------------------------------------------------------------------------------------------

    유선으로 문의 후 질문하기를 작성하며 추가로 테스트한 부분

    A 노트북

      ArcGIS 제품 설치 중 다른 ArcGIS 제품 설치를 실행하여  중복 실행으로 인한 설치 오류를 발생시킴

      3가지 제품으로 테스트를 하였고 설치 오류에 대한 3개의 로그 파일이 생성됨

      다시 정상적인 제품설치를 테스트 중이나 로그 파일이 생성되지 않음

      ArcGIS Data Store 10.6.1

      Portal for ArcGIS 10.6.1

    B 노트북 

      ArcGIS 제품 설치 중 다른 ArcGIS 제품 설치를 실행하여  중복 실행으로 인한 설치 오류를 발생시킴

      정상적으로 오류에대한 로그파일이 생성됨

    ------------------------------------------------------------------------------------------------

    현상 정리

      설치 중 오류메세지가 발생하였을 경우는 정상적으로 로그파일이 생성되는 듯 보임

      특정 SW 따라 로그생김에 차이가 있나 의심되어

      오전에 정상설치 되었으며 로그가 생성되었던 ArcGIS Data Store 10.6.1을 삭제 후 재설치 하였으나 로그가 생기지 않음.

      정상설치되었을 경우 로그가 안생기는 듯한 현상에 대하여 답변을 받고싶습니다.

    안녕하세요. 
    2018년 8월 27일 월요일 오전 2:19