none
Office 365 Install Using Config XML Defaults to German Language

    질문

  • I am installing O365 using the following XML configuration

    <Configuration>
        <Add OfficeClientEdition="32" Channel="Broad" >
            <Product ID="O365ProPlusRetail">
    			<Language ID="en-US" />
    			<Language ID="zh-CN" />
    			<Language ID="de-DE" />
    			<Language ID="ja-JP" />
    			<Language ID="ko-KR" />
                <ExcludeApp ID="Access"/>
                <ExcludeApp ID="Publisher"/>
            </Product>
        </Add>
        <Updates Enabled="TRUE" Channel="Broad"/>
        <Display Level="None" AcceptEULA="TRUE"/>
        <Logging Level="Standard" Path="C:\TEMP\"/>
        <Property Name="FORCEAPPSHUTDOWN" Value="TRUE"/>
        <Property Name="SharedComputerLicensing" Value="0"/>
        <Property Name="PinIconsToTaskbar" Value="FALSE"/>
    </Configuration>

    When the application gets installed - it seems to default to German for any messages that are displayed.
    This normally would not be an issue, as the actual application is in English; although in the case, that down the road management would like to switch update channels, there are messages displayed to the end user, but these messages are all in German.

    I am changing channels using the OfficeC2RClient.exe with the channel change (/ChangeSetting Channel=Broad) then "/update user" switch.

    Is there anything that is missing in the config? Is this a general bug?

    I am not looking for an alternate way of changing the channel.


    • 편집됨 Johnny_Litens 2018년 5월 29일 화요일 오후 6:50
    2018년 5월 29일 화요일 오후 6:37

모든 응답

  • Hi Johnny,

    >>although in the case, that down the road management would like to switch update channels, there are messages displayed to the end user, but these messages are all in German.

    Do you mean you want these messages to display in English? May I know whether this issue happen with all users or just specific users? You may first go to any of your Office application, File > Options > Language and verify whether the Display Language and Help Language are set correctly.

    We may also try running an Online Repair of your Office installation to see whether it helps. For your convenience:

    https://support.office.com/en-us/article/repair-an-office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b

    Besides, the messages you see should be notifications that notify you that Office is downloading updates, etc. These messages could be disabled via editing the "/update user" command. See the following blog article for more details:

    https://blogs.technet.microsoft.com/odsupport/2014/03/03/the-new-update-now-feature-for-office-2013-click-to-run-for-office365-and-its-associated-command-line-and-switches/

    Hope this helps.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    2018년 5월 30일 수요일 오전 8:30
    중재자
  • Yes, I want the messages to display in English.

    The issue happens with all users that get office installed using the above package.

    The display and help language are both set to English as default / OS display language as default (which is English)

    An office repair does not correct the issue, also, we can not rely on an office repair for such a vast user base.

    The user will still see a message to close the office products that they have open. I do not want to force close applications so that users can be as productive as possible. 

    2018년 5월 31일 목요일 오전 11:47
  • Johnny,

    Were you referring to the splash screens that appear when O365 is installed?  That they appear in German instead of English.

    If so, we are running into the same thing with the latest bootstrap (setup.exe).

    Our install.xml also has multiple languages being installed:

        <Product ID="O365ProPlusRetail">
          <Language ID="en-us" />
          <Language ID="fr-fr" />
          <Language ID="de-de" />
          <Language ID="it-it" />
          <Language ID="es-es" />
          <Language ID="pt-br" />
        </Product>

    One thing we tried was using an earlier version bootstrap (setup.exe) and the splash screen was back to English.

    One thing to note is that alphabetically sorted, de-de (German) would be at the top of the list of languages in both of our xml files.

    I ran an install using the new bootstrap and captured the log files.  I also did the same using the old bootstrap.

    Both installs were done using the same xml and version of O365.

    The new bootstrap displayed a German splash screen, while the old bootstrap displayed the English splash screen.

    The new bootstrap must be doing some "assuming" since the log file showed this entry:

    06/18/2018 13:40:53.238 SETUP (0x1944) 0x1948 Click-To-Run av6ya Medium Configuration::Load: Setting culture to: de-de

    The log file from the old bootstrap shows:

    06/18/2018 13:49:37.430 SETUP (0x1bb8) 0x1ba4 Click-To-Run av6ya Medium Configuration::Load: Setting culture to: en-us 32B10A18-6589-47FC-BC89-50FC4FF67A29

    Not sure at this point if I could/should be using the old bootstrap.

    As to why the new bootstrap wants to change the splash screen, I don't know yet.

    2018년 6월 18일 월요일 오후 6:32
  • Just an update...

    It looks like it was an issue with the bootstrap (setup.exe). 

    The version I was using that caused the issue was v16.0.9326.3600, dated 4/25/2018.

    I downloaded the latest Office deployment tool and it had a newer setup.exe.

    version 16.0.10306.33602, dated June 6, 2018.

    Installing using this newer setup.exe, the splash screen and messages are now in English for my multi-lang install.


    2018년 6월 18일 월요일 오후 7:30
  • I will give this a try and get back to you. Thank you very much for the update!
    2018년 6월 20일 수요일 오후 1:59
  • So, the new C2R client did not resolve my issue. I performed a clean install of office using the same C2R client that you had referred to. But... as soon as the command in the image below was run. Everything was still german.

    We are using the following switches to change update channels remotely. 

    /ChangeSetting updatesEnabled=True

    /ChangeSetting Channel=Broad

    /update user

    this issue only happens when the install is set to download from Microsoft during the install. If we host the install/version files locally and point the click to run <g class="gr_ gr_453 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="453" id="453">client</g> to install that specific version... the commands above always show in the correct language. We, although, wanted to move away from this so that we can always deploy the newest revision in the channel we select with each fresh install. 

    The contents of our install XML are in my first post. 

    2018년 6월 20일 수요일 오후 2:52