none
Appointment begin and end dates/time not saved

    질문

  • Hi,

    something totally strange happens in an exchange organisation. We copied all virtual servers to a test-lab to analyze that behaviour:

    It is a problem related to appointments and exchange and outlook 2016.

    When a user creates an appointment it all works fine

    When a user creates an appointment via email by clicking on that symbol "answer with appointment-request", it opens up a new appointment with the body of the email. The user chooses a date and time and sends that appointment-request to email-addresses inside or outside exchange-organisation. After doing so, the appointment disappears from calender.
    With the list-view of calender, we found that appointment without having start-date, end-date and no start-time, no end-time.

    Therefore it only shows up in list-view because the appointment has no dates. Though, in sent-items you can see the appointment has correct date/time and all receivers get correct date/time. Even acceptance are displayed correctly in the appointment.

    We solved the problem by opening up the appointment again that has no start/end-times, then have to correct the dates/times and send updates. Then it will be displayed correctly.

    This behaviour happens only in terminalserver 2012r2 and terminalserver 2016. All other client-computers do not have that problem. Unfortunately more than 50% of employees work within terminalserver.

    How can I determine this special problem?

    If needed, I can take pictures to all my interpretations.

    best,

    Roman

    2017년 2월 1일 수요일 오전 6:10

모든 응답

  • Received Email in inbox, from inside/outside exchange organization:


    After clicking Besprechung (appointment request)


    After sending the appointment to email-addresses the sent-box item shows the following:


    Lets look at the own calender, it shows up no manually edited text and no time/date

    Opening the calender-item shows up following:

    the specific date/time is the current date/time whenever you open the appointment.
    Making changes now will be saved and need to resend again to all emails. After doing so, appointment are shown up correctly and everything is fine.

    Hope the screenshots help more.

    2017년 2월 1일 수요일 오전 7:48
  • Hi Roman,

    What's your detailed Outlook 2016 version? Please make sure you are using the latest version Office 2016 on server computer.

    I followed your steps and tested with Outlook 2016 on Windows 10, there was no issue when I click Home tab, Meeting button in the Respond group.

    >>This behaviour happens only in terminalserver 2012r2 and terminalserver 2016. All other client-computers do not have that problem. Unfortunately more than 50% of employees work within terminalserver.

    Please confirm if other servers (Windows server 2012 R2 and Windows server 2016) which do not have RDS enabled encounter the same issue. If the issue only happens to Terminal Server, I suggest we can ask a question in Terminal Server forum for more help:

    https://social.technet.microsoft.com/Forums/windowsserver/en-us/home?forum=winserverts

    The engineers there would be convenient to do a test in Terminal server and do further troubleshooting on it. Thanks for your understanding :)


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017년 2월 2일 목요일 오전 9:47
    중재자
  • Hi,

    both servers are updated. Office2016 ist updated. Did all changes on system languages and date/time formats.

    Is there a possibility to see what's been sent to exchange from the user? I saw severeal calender-logging options and general tracking options on exchange 2013.

    We also have roaming profiles and I will test a user without activated roaming profiles. I also installed Office2013 and it worked. On an updated outlook2013 client from terminalserver it works. Though I would still like to know what the problem on outlook2016/exchange2013 is because we cant have that bug/problem in.

    Do you know, how I can track appointment queries on exchange for a user?
    On journal-mailbox all appointment-invitation are displayed correctly and dates/time are correct. Only in the own mailbox/calender it's not displayed and it still not saves date/time.

    Any help on tracking?

    2017년 2월 6일 월요일 오전 6:56
  • Hi Winnie,

    installed office2016 on a second server without having RDS installed.

    Tried the appointment-email-button and it also shows up no time/date when sending the appointment.

    Office2016 without having updates installed.

    So, it's not RDS, it's not office-updates. It's still some combination of server/office2016/exchange2013.

    I think without logging or specific calender-logging tracks, there is no way to find out the problem behind that.

    Would be very glad to get your help again.

    yours, Roman

    2017년 2월 6일 월요일 오전 7:17
  • Hi Roman,

    For the tracking logs such as Exchange Message Tracking logs, the start/end time information would not be tracked in the log. The message tacking logs would track the mails send and receive process from sender to the recipient, it just record the send time, event processing time during the message sending.

    There is no information of the start time and end time of the message content for meeting request in tracking log. Actual meeting date/time should be inside the meeting message under one of the message property which you could look by opening meeting in outlook or via MFCMapi if you want.

    About the Calendar logging feature in Outlook, please read:

    https://support.office.com/en-us/article/What-is-the-Enable-logging-troubleshooting-option-0fdc446d-d1d4-42c7-bd73-74ffd4034af5?ui=en-US&rs=en-IE&ad=IE&fromAR=1


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2017년 2월 13일 월요일 오전 2:27
    중재자
  • Hi Winnie,

    thanks for your reply. I know it's neither easy to answer with the correct solution nor do you have all information.

    So I am really trying to give it all to you and I am sure we get the point if we quesion enough. The MFCMapi might let me see something but the origin problem hasnt been solved then.

    Therefore, I put up a new user, new mailbox, tested it again on terminalserver and it worked.

    So it is not Outlook2016/Server/Exchange2013 at all but now including roaming profiles.

    The users that have these invitation-problems are all on roaming profiles, and I think there is the problem, because the new user has not been put up on roaming profiles at all.

    and it works.

    I am not the specialist on roaming profiles, but here is what I have on group policy for the users with roaming profiles, I guess there is the problem because of non-correct-set-settings:

    all other settings are set the same but I guess the problem is the AppData, which works without any errors on terminalserver. Even eventviewer does not report errors but informations that profiles loaded successfully etc etc.

    Is there anything I can change to make roaming profiles stop working on specific users?
    When I exclude users to the group-policy, they still get roaming profiles.

    Any ideas?

    2017년 2월 16일 목요일 오전 6:57
  • Hi Roman,

    Did you ever get to the bottom of this as we are seeing something similar?

    Thanks

    Alex

    2018년 6월 18일 월요일 오후 12:02