Lanmanserver fails to start on 2008 R2 Standard


  • I somehow accidently deleted SRVSVC.DLL and couldn't recover it so I just copied from another server running same OS and pasted it.  I receive Error 2 and states cannot find the file specified but I do see it listed in this path - C:\Windows\System32\srvsvc.dll

    I ran SFC /SCANNOW and the output is Windows Resource Protection found corrupt files but was unable to fix some of them. Details are in the CBS.Log

    The log contain tons of info but here is a short version of what I see.   Cannot repair member file “srvsvc.dll” *************TONS of INFO********** hash mismatch.

    According to Microsoft, If sfc discovers that a protected file has been overwritten, it retrieves the correct version of the file from the systemroot\system32\dllcache folder, and then replaces the incorrect file but this dllcache folder doesn't exist on this server.  I tried to re-register this DLL but it fails with an error stating entry-point DllregisterServer was not found.

    I ran above steps in ‘safe mode’ but no difference.  Please help as I don't have an option to reimage or rebuild.

    2014년 1월 31일 금요일 오전 4:37