none
O365 firstrun suppression policy settings do not suppress file formats chooser when installed on EU locale computers

    질문

  • I am not sure where to report this but I believe I have found a bug in the latest Office 365 product. I set up a machine running windows 7, and implemented Office 2010 and Office 2013 group policies, I scoped the policies to the correct user and machine. the particular policy I am interested in is the "default file format" found in the GPO under the save option for word, excel and powerpoint. under office 2010 this policy applies correctly and does not display the "choose a file format" dialog box when those programs start, this is the behaviour I am looking for. I then installed Office 2013 and implemented the exact same group policy, the default file format dialog box does not appear. however, when I install Office 365 (2013 edition) the dialog box does display. it appears that some other policies do apply correctly to the office 365 product but the default files format policy does not, office 365 is ignoring this policy setting.... hence why I believe this is a bug. according to the Microsoft technical literature the Office 365 product and Office 2013 share the same group policy settings, I can not find any admx files specifically for office 365, only for office 2013 so 365 should recognise and use this policy setting.

    Steve


    • 편집됨 Milkientia 2013년 3월 20일 수요일 오후 3:24 More appropriate Thread title
    2013년 2월 25일 월요일 오전 11:26

모든 응답

  • Hi Steve,

    I don't quite understand what is the "choose a file format" dialog box in your post.

    Also, I found both Office 2010 and Office 2013 (both MSI and Click-to-Run edition (installed via Office 365 Home Premium)) behave the same after implemented the "Default file format" policy.

    Could you post a screenshot that could help to distinguish the difference?

    .

    BTW, just in case, check if it is the following policy you are looking for:

    Microsoft Word 2013 | Miscellaneous | Disable the Office Start screen for Word


    Max Meng
    TechNet Community Support

    2013년 2월 26일 화요일 오전 7:36
    중재자
  • unfortunately my test environment for this has since been destroyed, so I cant get a real screenshot. however the dialog box I am talking about is when Word first opens it presents the user to choose either open xml or open document

    http://www.ghacks.net/wp-content/uploads/2010/07/default-file-types.jpg

    in word 2010 and 2013 there is a policy setting located in the GPO under user configuration > administrative templates > Microsoft Word 2010 (or 2013) > Word options > save > Default file format

    I am under the impression that setting this policy supresses the dialog box presented to user in the weblink I posted above, in office 365 however this dialog box does display, I don't want users be setting different formats, I want this to be hidden and controlled by policy, all users will use the same format and there is no support calls raised about "what does this box mean". how do I make this dialog box not display for users in click to run office 365?

    additionally, the policy setting for all office applications has the Disable the Office Start Screen policy enabled, I think this setting is used to control the "intro" stuff that was new to 2013, but does not control the default file format behaviour of Word, Excel and PowerPoint (those are the three applications which present the dialog box)

    Thanks

    Steve


    • 편집됨 Milkientia 2013년 2월 26일 화요일 오전 10:00
    2013년 2월 26일 화요일 오전 9:56
  • Hi Steve,

    I'm afraid this is not a bug. This display only appears in EU versions of Office 2010 and 2013 and is a legal constraint (just like the browser choice was).

    I think this is the reason why there is no gpo parameter to disable it.

    Anyway, you can tell Office it has already been displayed once and so it won't be displayed anymore for the user. The key is [HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\General] "ShownFileFmtPrompt"=dword:00000001


    • 편집됨 LillonelC 2013년 3월 14일 목요일 오후 3:20
    2013년 3월 14일 목요일 오후 3:20
  • but i believe there is a GPO setting to supress this dialog box, and it is not taking effect. it should be the setting found under user configuration > administrative templates > Microsoft Word 2010 (or 2013) > Word options > save > Default file format

    does this not supress the dialog box in Word 2010? we have a volume license edition of Office 2013 just like we have for 2010, I am not aware of Office 2010 or 2013 having a UK only version, and as for the browser choice this can also be declined in the business world (possibly even in the consumer world if you select not to install the update).

    I am just puzzled at why with Office 2010 this dialog box does not display, and with Office 2013, but it does not take effect with Office 365 ProPlus click to run when this is supposed to use the same policy settings as Office 2013.

    therefore I still suspect this is a bug until there is a valid reason why Office 2013 seems to supress this dialog box but office 365 proplus doesn't, even though both products use the same policy settings. I believe 365 is simply ignoring the setting, and I don't know why.

    thanks

    Steve

    2013년 3월 19일 화요일 오후 8:11
  • there was an earlier discussion about this very topic, for OFF2010, maybe last year some time. probably in the OFF2010/legacy forum now. I've never seen this dialog for OFF2010, nor for OFF2013 so far. I'm in Australia.

    from memory the consensus at the time, was that the default file format settings as exposed in OCT and ADMX templates, don't affect this "first run" dialog at all. and, that it only seemed to somehow affect Europe (maybe some locale detection in the FirstRun code within Office apps?)

    so i don't think it's that office is ignoring that setting, i think it's that the setting does not apply to the firstrun dialog. there are other OCT/ADMX settings to manage the firstrun "splash" screen dialogs, but from memory, they don't control this file formats dialog either.

    maybe the bug might be better described as "firstrun suppression policy settings do not suppress file formats chooser when installed on EU locale computers"?


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    2013년 3월 19일 화요일 오후 9:21
  • Hmmm its weird why the dialog box doesn't show up in 2013 professional, but it does with O365 which is supposed to be the same product but just delivered in a different way.

    I have yet to try the registry key edit suggested by LillonelC. Do you know of any other reg keys which may control this first run behaviour?

    2013년 3월 20일 수요일 오후 3:23
  • Steve, this is a stupid question but are you deploying O2013 "full" using OCT ? Because in that case you can disable the dialog box without any need of a GPO.

    I searched in the GPO excel file but cannot find anything related to documents format dialog box



    • 편집됨 LillonelC 2013년 3월 20일 수요일 오후 3:53 too fast reading !
    2013년 3월 20일 수요일 오후 3:34
  • from memory I think I tested both with and without using OCT, but even when I did use OCT I didn't modify any of those registry settings that you can change in the OCT, only created a profile for outlook and set the supress end user agreement. I will have to set up another test machine soon and give this another go.
    2013년 3월 20일 수요일 오후 7:03
  • Arg, there's a teaser here in the second "Note":
    http://technet.microsoft.com/en-us/library/dd723552(v=office.14).aspx

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    2013년 3월 21일 목요일 오전 7:53
  • Right, I am asked for default file types as soon as I create a new response file. Before having access to any parameter, there is a popup window asking for type selection (or "keep current settings", which I think does nothing).

    There is also a note saying you can use GPO to change the settings for all users.

    In Don's link, the description for "Default file format" GPO parameter is :

    Allows you to determine the default file format for saving files in Word. This includes the OpenDocument text (.odt), and Open XML file formats. This policy setting is often set in combination with the ''Save As Open XML in Compatibility Mode'' policy setting.

    But the default configuration is "Word saves new files in the Office Open XML format (*.docx)".

    As I understand it, by default the file type parameter is set to Open XML (but the dialog box is displayed !), and users can change it to Open Document (seriously, who does that ??), and at that moment the dialog box disapears.

    But I'm not sure that changing this setting with a gpo automatically hides the dialog box (even if it SHOULD, we agree about that).

    The easy test I will try to make today is to install a full Office 2013 without any response file, apply gpo, and check the result.

    2013년 3월 21일 목요일 오전 8:39
  • thanks for both of you looking into this,

    Don the link you provided in that note specifically says about the OCT on a European computer, but what's really bizzare is I have no issues with OCT and the 2013 MSI it works as I would expect (not showing that dialog box), but when I download the O365 package and install it using the click to run deployment tool.... even though the XML file states the language as en-US (I tried en-GB but it doesn't look like there is a language specifically for us in the UK), the dialog box still shows up... now if this was the other way round affecting OCT and MSI then my question would probably be answered by what is written on note 2...

    go figure!!! geeez this is insanely over complicated Microsoft, as if we don't have enough to do! as I think I mentioned in my earlier post, our users are really not that clever when it comes to computers, they see a dialog box like this and my phone is going to ring when I don't want it to because they simply don't understand it. I know it's not a "show stopper" to rolling out O365 but it is a bit of an irritation, and as Don knows with a previous thread I am looking at the hot-desking environment which means this dialog could show up more than once for some users. Don, I assume your O365 users don't get this dialog prompt then in your 100 seat trial?

    Your help is really appreciated guys, thank you very much.

    2013년 3월 21일 목요일 오전 11:15
  • Hi Steve,

    I just noticed an interesting thing. I manually installed a full Office 2013 ProPlus french edition on a freshly deployed Windows 8 with no GPO applied. To be precise it's a en-us Office from VL portal with a french language pack added.

    At first start I saw the product updates dialog box and the first run, but no file format dialog box.

    Anyway, I'm currently in the process of deploying 400 clients with O365, we are in the very first steps of the deployment but as of now, the ShownFileFmtPrompt regkey has made the job.

    My only remaining problem is the AcceptEULA="TRUE" not working.


    • 편집됨 LillonelC 2013년 3월 21일 목요일 오후 1:28
    2013년 3월 21일 목요일 오후 1:22
  • Yep that EULA setting should work, you probably have the full line in your XML since it's included in the click to run deployment tool, but it should be (this is what I use)

    <Display Level="None" AcceptEULA="TRUE" />

    Again, going from memory I am pretty sure this setting worked for me when I deployed O365 in config mode but ill keep an eye on that one next time round I deploy, isn't it such a strange world where things behave differently using the same settings haha.

    Cheers for the reg key, ill test this out when I spin up my O365 lab again but if you are saying it works then I'm sure it will be fine. how did you deploy this reg key? do you use Group Policy or Group Policy Preference, or script or something else...? I need to a way to ensure this key gets set for definite to the client.

    you two guys have such larger deployments than I do, and I know this is slightly off topic for this thread but when I posted this on my other thread http://social.technet.microsoft.com/Forums/en-US/officesetupdeploy/thread/b2111b9c-a7d0-4c90-8a7f-892fba22f54e I didn't get a satisfactory answer to the question of "how do i remove access to a specific office component in O365" but surely you guys don't want everyone in your rollouts using products like Access, Publisher and InfoPath... how do you handle this?

    Cheers,

    Steve

    2013년 3월 21일 목요일 오후 3:05
  • Yes I have the full line in config.xml, as you said it's the default one and I didn't change it. Actually it used to work with previous releases but since the last one (15.0.4454.1504) it's no more taken into account. But that's not very annoying as there is no choice to be made by final user.

    I deployed the key through GP Preference, with a create action and "run in logged-on user's security context". None of the pilots reported issue about that for the moment (and as of yours, my users aren't really confident with computers so I think this kind of dialog box would have be reported to me).

    Concerning product selection, we asked the same question as we are not interested in deploying Access. Unfortunately there are only 4 products ID available and the one we have to use is O365ProPlusRetail. Our MCS consultant said there is no way to be more precise. For the moment we are deploying all ProPlus apps...

    2013년 3월 21일 목요일 오후 3:37
  • ok, then to (possibly) help you, this is what I did in my initial testing to help prevent the running of some of those apps... up to you if you chose to implement this but it did seem to work for me in my test environment

    Create a GPO which uses User GPP and Computer start up scripts. The GPP will remove the shortcuts and the start up scripts will install an ACT  Database with AppHelp messages. These AppHelp messages will disallow the application to run passing it off as a "compatibility" issue, and that's assuming the user can get to the exe file after the shortcut has gone.

    Create a GPP Folder Options – File Type which re-associates the extensions for the blocked app with another application or removes the extension.

    http://technet.microsoft.com/en-us/library/hh825139.aspx

    http://technet.microsoft.com/en-us/library/cc749586(v=ws.10).aspx

    http://technet.microsoft.com/en-us/library/cc749169(v=ws.10).aspx

    any or all of those steps could form a solution as far as i can tell. I know this appears a pretty botch job but its the best I can think of, you could use app locker policies but personally I have never been a fan of implementing such restrictions (perhaps it comes from the days where software restriction and hash rules and such seemed a pain in the wassit).

    I don't mean to appear greedy when asking for help, but you have an even bigger rollout than Don has at the moment with O365, we both have a joint scenario which I wonder if you had come across and know the answer to, even though I've marked this as answered it is the best we have at the moment but not 100% conclusive, would you have anything to add to it? the thread is located at http://social.technet.microsoft.com/Forums/en-US/officesetupdeploy/thread/6a3b4fd6-1ad3-40a7-8b9e-e9cf815e115b

    Many thanks

    Steve


    • 편집됨 Milkientia 2013년 3월 21일 목요일 오후 4:24
    2013년 3월 21일 목요일 오후 4:17
  • Thanks for the GPO solution, I didn't think about using GPO for blocking apps.. Most of all, deleting shortcuts may be a good enough solution for preventing users to launch some of the apps. On the other side, I'm not really fan of passing applications as compatibily issues or removing file extensions.

    Concerning the other question, I'm not as familiar as Don about O365 activation, so I won't reply on the other thread. What I can tell you in a few words, and from my experience, is :

    - Installation account doesn't try to activate the product. We are using SCCM to deploy O365 and setup runs as "system" on the target machines. None of our users are local admins.

    - We are deploying O365 into stores, which are equiped with 1 to 5 computers, and only 1 AD account per store. Activation has to be made once per computer, providing the AD account credential. We use ADFS but that's not my part and I don't really know how it technicaly works. Basically it's a 3 steps login :

    1 - End user gives his login @domain.com and password

    2 - MS server joins our ADFS server with provided credentials

    3 - Our server validates the credentials and returns to MS saying it's ok, the guy works for me

    If I correctly understood your concern, your computers are used by several users and you would like to know if they have to activate at each time ? In my opinion, once the computer is activated by the first user it doesn't have to re-activate for the following ones. But I won't ask you to trust my opinion, as I personnally don't.

    We are currently experiencing issues with our Tenant, but this should be solved in a few days, and I'll so be able to activate computers anymore. What I can do if you're interested, is deploying 0365 to a new computer and try to connect with 2 accounts. I can follow activations status on microsoftonline portal.

    One last thing, I remember having asked our MS consultant about what happens if you try to activate more than 5 devices. In my memory he said that the first one is deactivated. But once again, my memory isn't to be trusted all the time.

    2013년 3월 21일 목요일 오후 5:46
  • hmmm so maybe it wouldn't be so much of a problem if the product has already been activated by someone else, as long as that "someone" else isn't the person who has already activated it on 5 other devices, I'm not sure how likely that would be to occur in a real world scenario, I guess it's quite hard to figure it out until we know how the machines are used. maybe quite likely if our "training" scenario all uses a shared AD account for more than 5 stations. I will be starting the trial with Office 365 next week (sign up for 30 days) and I am assuming that 30 days will behave identically to the real paid for thing so ill be spinning up several machines to give this a test.

    thanks for your input, ill try not to clutter this thread with this topic any further (people tell me off) :)

    Steve

    2013년 3월 22일 금요일 오전 9:56
  • I've been having the same issue on my C2R Office 2013 installation.

    It doesn't matter what you set the default file formats as via GPO, the user will still get shown the File Choice Format box when they have the local regional settings set to an EU country 

    Default Files Types Screenshot

    The fix is to create a Preference in your Office 2013 Group Policy object under

    User Configuration > Preferences > Windows Settings > Registry

    Properties
    Action: Update
    Hive: HKEY_CURRENT_USER
    Key path: Software\Microsoft\Office\15.0\Common\General
    Value name: ShownFileFmtPrompt
    Value type: REG_DWORD
    Value data: 0x1 (1)


    Thom McKiernan (UK) @thommck | thommck.wordpress.com | MCSA | MCTS

    2014년 3월 10일 월요일 오전 10:28
  • This does not seem to work for both Office 2013 and 2016. I have tested it multiple times and it still doesn't work.
    2016년 2월 1일 월요일 오후 4:49
  • Solution found through Microsoft! Change the path to: Properties Action: Update Hive: HKEY_CURRENT_USER Key path: Software\Policies\Microsoft\Office\15.0\Common\General Value name: ShownFileFmtPrompt Value type: REG_DWORD Value data: 0x1 (1)
    • 답변으로 제안됨 DonPick 2016년 3월 30일 수요일 오후 8:00
    2016년 2월 5일 금요일 오후 8:18
  • I think I have found the solution. Office 365 ignore the value ShownFileFmtPrompt if this one is placed inside key HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\General. But at startup, it looks for the same value at HKEY_CURRENT_USER\Software\Policies\Microsoft\office\16.0\common\general and it use it to enable or to disable the ballot screen.

    Because this part of the registry is for Group Policies only, you can solve your problem by adding this option into a GPO. But the key is not declared in ADMX file. So You must first add the key in the Office2016.admx file. Here are the steps :

    • First, Save your OFFICE2016.ADMX and ADML files. Safety first.
    • Modify Office2016.ADMX and add this new section after the policy section "L_DisableOfficeFirstrun"

      <policy name="L_DisableOOXMLBallot" class="User" displayName="$(string.L_DisableOOXMLBallot)" explainText="$(string.L_DisableOOXMLBallotExplain)" key="software\policies\microsoft\office\16.0\common\general" valueName="ShownFileFmtPrompt">
            <parentCategory ref="L_FirstRun" />
            <supportedOn ref="windows:SUPPORTED_Windows7" />
            <enabledValue>
              <decimal value="1" />
            </enabledValue>
            <disabledValue>
              <decimal value="0" />
            </disabledValue>
          </policy>
    • Modify your Office2016.adml in en-us directory and add this after the "L_DisableOfficeFirstrunExplain" string definition (you can change the text if you not like, it's just for show in GPMC).

      <string id="L_DisableOOXMLBallot">Disable File Format Ballot Screen on first run in Europe</string>
       <string id="L_DisableOOXMLBallotExplain">This policy setting controls whether users see the File Format Ballot Screen the first time they run a Microsoft Office 2016 application in Europe. 

      If you enable this policy setting, the File Format Ballot Screen does not display the first time users run an Office 2016 application. 

      If you disable or do not configure this policy setting, the File Format Ballot Screen displays the first time users run a Microsoft Office 2016 application, which allows them to opt select Office Open XML file format or Open Document file format.</string>
    • If you use some other languages, modify the adml files corresponding to your language.
    • Open the GPMC
    • Go to User / Policy / Admin. Templates / Microsoft Office 2016 / Privacy / First Run
    • Activate the new option "Disable File Format Ballot Screen on first run in Europe"
    • Refresh your group policy on computers and start Word, or Excel for the first time. The ballot screen is not shown.

    I have tested that on the new Office 2016 Clic To Run release and it worked fine. I hope this will help those who still need this for Office 2016 deployments.

    Arnaud.

    • 답변으로 제안됨 DonPick 2016년 3월 30일 수요일 오후 8:00
    2016년 3월 30일 수요일 오후 6:24
  • Arnaud's answer works!
    • 편집됨 paulrimmer 2016년 6월 1일 수요일 오전 9:50 reference post
    2016년 6월 1일 수요일 오전 9:50
  • Great! Thank you.
    2018년 6월 18일 월요일 오후 1:45