I replaced my MDT 2010 server with a new one, but deployment is still looking for the old server!


  • I have been using MDT for a couple of years to image new machines, but recently I replaced it with a new server running 2008 R2 so I could use the new version of MDT and take advantage of its nice new features. I created a new 2008 R2 VM and got MDT/WAIK all installed and configured and it will PXE boot and image a new machine just fine...until it gets to the end of the imaging process!  After it finishes with the Windows install and reboots, I can login and everything looks good on the new PC, but then I will get the dreaded message "A connection to the deployment server can not be made.  The deployment will not proceed"

    Here is the kicker, in this error message, it refers to the name of the OLD server!!!  When I setup my new MDT server, I did it all from scratch, so I don't know how it somehow got the name of my old MDT server.  If I boot up my old server and plug it in to the network, and then restart my target machine, it will then see my old server and finish the deployment (there really isn't anything left, it just gives me the message saying that the deployment was successful).

    So, I need to figure out where its getting this address for the old server, otherwise I have to keep the old MDT server plugged in just for the very end of the imaging process.

    2012년 3월 29일 목요일 오후 2:50

모든 응답

  • Do you do any customization in any of the scripts that make up MDT?

    Respectfully, Carlos MCTS, MCITP

    2012년 3월 29일 목요일 오후 4:52
  • How are you PXE booting?  Is it with WDS?  If it is have you update your WDS boot images with the new ones created by your new MDT server?
    2012년 3월 29일 목요일 오후 10:36
  • Do you have a database where the deployroot has an entry (all the way down in details)?
    2012년 3월 29일 목요일 오후 10:40
  • Do you have deployroot property defined in CS.ini or BootStrap.ini? What is the server name there?

    Also, when you right click your deployment share and click on the general tab, what is the UNC path and Local Path? Are they correct?

    One other simple way to crack the old server name is to type old server name using findstr command which will list the files in the deployment share which have that name. So try this:-

    Note the name of the old server (exact name and case) when you get the error. Now open CMD and take the prompt to your deployment share.
    So, you should be in something like


    Now type the following. This will list out the files which have that name in them. It could be boot.wim, settings.xml etc.

    findstr /l /m /s MyOldServerName *.*

    Note: Make sure that MyOldServerName is exact to what you see in the error (Case Sensitive)

    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    • 답변으로 제안됨 Md.Waseem 2012년 4월 2일 월요일 오후 9:07
    2012년 3월 30일 금요일 오전 8:53
  • the 'deployroot' property is defined in bootstrap.ini, but it has the correct new server name.

    When I look at the properties of the deployment share, it shows the UNC path correctly.

    When I tried using the 'findstr' command, it didn't find anything, just a bunch of lines that said they were too long.  I have tried using the Windows search to locate the old server name but have not had any success.

    I am doing PXE boot right from the WDS server, but its with all new images, I didn't copy any from the old server (which is why I'm so befuddled on where its getting the old server name from).

    I'm not doing any customization of scripts, when I setup the new imaging task sequence, I am just doing it plain vanilla, no post install stuff.

    I appreciate everyone's input, if anyone has ideas I'm all ears :)

    2012년 4월 2일 월요일 오후 6:39
  • Can you check the contents of the bdd.log in the C:\MININT\SMSOSD\OSDLOGS folder (of the client that fails the install) and search for the old server name.

    These logfiles are much easier to read when using trace32/64.

    Kind regards,


    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    2012년 4월 2일 월요일 오후 10:12
  • The deploymentshare information is there in the boot wim. It is called litetouchPE_x64.wim or LiteTouchPE_x86.wim

    This is under the \DeploymentShare\Boot. Can you delete these files or all files under the \boot folder.

    Once done, right click on the deployment share and "update the deployment share" and try the deployment again.

    Regards, Vik Singh "If this thread answered your question, please click on "Mark as Answer"

    2012년 4월 3일 화요일 오전 8:46
  • Hi Vik--ok, I followed your guidelines, I deleted all the boot WIMs, then had it regenerate them.  I have imaged a new machine, the imaging went fine, but know its back to trying to find the old server.  I am going to turn the old MDT server back on, and try and see if there is a file name or something that can give me a clue about what is gong on.
    2012년 4월 10일 화요일 오후 1:44
  • I just re-imaged a machine, this time with my old MDT server online, and the deployment finished successfully, the file it runs is the wizard.hta

    I may have to do a total rebuild of a new MDT server (again!) to see if I can get rid of this problem, so I don't have to keep this old box around and online just so the image will finish :)

    2012년 4월 10일 화요일 오후 2:56

    did you ever get to an answer?

    I had a similar issue But mine was with machines that already had been imaged once and if I did not clean the disk completely ( diskpart select volume clean) then it kept finding reference to old deployment share

    Once I cleaned disk it found new one fine

    Use MDT 2012 to push OS and apps to client, then I changed the deployment share name now unless I do a diskpart clean it keeps looking for old deployment share name


    I want to run litetouch etc to do hard links USMT etc


    I image centrally then send these units out


     I need the easiest way to allow them to find the right deployment share based on the bootstarp.ini settings I have for IP


    • 편집됨 BDC1 2012년 8월 7일 화요일 오후 7:01
    2012년 8월 7일 화요일 오후 5:17
  • Had the same issue before, turned out that the MININT folder was still on the clients. Deleted and re-deployed and all went fine.


    • 답변으로 제안됨 Pat Cummins 2013년 1월 28일 월요일 오후 10:11
    2012년 8월 8일 수요일 오전 8:08
  • Your old server may be authorised for DCHP. Please authorise new one.
    2012년 8월 9일 목요일 오전 11:53
  • When I have encountered these sort of problems I have also found it to be left over files on the client,  especially multiple builds over a VM etc.

    I usually just boot into PE and do a:

    (this will delete everything on the first HDD in the machine)

    • Diskpart
    • Select disk 0
    • clean

    and then try again.

    We only ever do bare metal builds so no issues for me.

    2013년 1월 28일 월요일 오후 10:23