none
SharePoint 2010 to SharePoint 2013 upgrade

    질문

  • I have migrated content from a SharePoint 2010 environment and onto SharePoint 2013. The new environment is up and running with all the content of the old environment including all the branding.

    Running the “Test-SPContentDatabase” commands has revealed the following:

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [9e8686b8-348d-4745-9769-e585017cb7a0], Url = [/])
                      whose id is already associated with a different database (Id
                      = [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [a1c2a170-b7fd-4f58-9c45-e12e8bd679c1], Url = [/my])
                      whose id is already associated with a different database (Id
                      = [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [2d379eed-22c6-42e0-a559-e5d0724fd84c], Url =
                      [/personal/sp_caap]) whose id is already associated with a
                      different database (Id =
                      [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [a83eb910-536b-4b1c-a39f-9d35efbceedf], Url =
                      [/personal/sp_install]) whose id is already associated with
                      a different database (Id =
                      [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [3dfc6141-b9c5-4485-9950-ff8d450c1e51], Url =
                      [/personal/sxmarcel]) whose id is already associated with a
                      different database (Id =
                      [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :



    When running the “stsadm -o enumallwebs” command the sites highlighted in yellow above all have an “InSiteMap” value = “True”, which means they are not orphaned.

    Is the above a false error perhaps any suggestion on this?....
    2013년 3월 15일 금요일 오후 3:24

모든 응답

  • Hi,

    1. Can you browse to all these sites that reported as an orphan in browser?

    2. Is the number of sites after the upgrade match with the number of sites on 2010?

    3. Does it still throw warning if you detach and reattach the content database and run the command again?

    Let us know

    James


    Please mark as Answered if it helped you
    James Tsai | SharePoint Consultant | MCPD,MCTS | www.jamestsai.net

    2013년 3월 15일 금요일 오후 8:18
  • Hi James,

    Yes I can browse to the site just fine. The number of sites is exactly the same as those in 2010

    No errors or warning are thrown when I detach / attach the content db. I am thinking that actually there is no orphans but not too sure why they are reported as orphans when I run the "Test-SPContentDatabase" command. I have now deleted most of the sites mentioned above as these are no longer needed so I am now only left with the root site collection [/]. So now when I run the Test-SPContentDatabase I only get on error:

    Category        : SiteOrphan
    Error           : True
    UpgradeBlocking : False
    Message         : Database [SP13_Intranet_ContentDB_Migrated] contains a site
                      (Id = [9e8686b8-348d-4745-9769-e585017cb7a0], Url = [/])
                      whose id is already associated with a different database (Id
                      = [a94bdcd2-3fff-4fda-89c6-8190bfc495f4], name =
                      [SP13_Intranet_ContentDB_Migrated]) in the site map.
                      Consider deleting one of these sites which have conflicting
                      ids.
    Remedy          : The orphaned sites could cause upgrade failures. Try detach
                      and reattach the database which contains the orphaned sites.
                      Restart upgrade if necessary.
    Locations       :

    This is very strange, not too sure but I think there are more than one reference to this site in the ContenDB have no idea how this could have happened.

    The farm itself is working fine and all the content is present as expected so I am just wondering whether this can be ignored.

    2013년 3월 18일 월요일 오전 11:24
  • Hi,

    has this issue been solved or your question answered.

    I have the same issue on all my SP2013 farms. These farms have not been migrated but installed using AutoSPInstaller. Some of the farms run for quite while now and even got some Cumulative Updates without problems.

    Still Test-SPContentDatabase continues to report Site Orphans!

    I consider this as a false alarm. Is there someone who can confirm this?  

    Thomas

    2016년 12월 20일 화요일 오전 10:30
  • Hi,

    Is there any update on this perchance? I'm experiencing the same thing, albeit on 2010 and not part of an upgrade (atm)

    I also think this is probably a false positive but it doesn't explain why its being thrown....

    Thanks

    Jason

    2018년 5월 18일 금요일 오전 10:32