none
Lync online meeting URL is not opening through the Lync client instead it is opening through Lync Web App RRS feed

  • Question

  • I have verified the meeting URL and it doesn't have ?sl=1 at the end of it.  We have checked IE as the default browser and reset the IE, still the issue is not resolving, when the user clicks on the meeting URL in outlook its opening in IE through Lync Web App instead of Lync client.
    Friday, June 21, 2013 1:09 PM

Answers

  • Hi,

    If the issue only happen for a specific workstation, please also remove Lync client, profile and registry key of lync and reinstall it to test the issue.


    Kent Huang
    TechNet Community Support

    • Proposed as answer by Kent-Huang Wednesday, June 26, 2013 2:08 AM
    • Marked as answer by Kent-Huang Thursday, June 27, 2013 7:28 AM
    Monday, June 24, 2013 7:50 AM

All replies

  • Have you tried a reinstall of the Lync Client
    Friday, June 21, 2013 10:31 PM
  • Please check your Default programs Settings, which application is setup for Lync online meetings

    regards Holger Technical Specialist UC

    Sunday, June 23, 2013 8:06 AM
  • Yes, did 3 times
    Sunday, June 23, 2013 3:54 PM
  • How do I check that? In meeting options in outlook its not showing anything like that.
    Sunday, June 23, 2013 3:58 PM
  • Hi,

    If the issue only happen for a specific workstation, please also remove Lync client, profile and registry key of lync and reinstall it to test the issue.


    Kent Huang
    TechNet Community Support

    • Proposed as answer by Kent-Huang Wednesday, June 26, 2013 2:08 AM
    • Marked as answer by Kent-Huang Thursday, June 27, 2013 7:28 AM
    Monday, June 24, 2013 7:50 AM
  • Hi,

    We are having this same problem.  WE have already uninstalled and reinstalled IE 9, Reset settings and cleared all cookies and temp files.  Uninstalled Lync.  Removed the Lync settings from the registry and from the user's profile, Rebooted, Reinstalled Lync.  Still no go.

    When the user clicks on a meeting link, the browser opens up and takes him right to the Lync Web App.  Whatever ActiveX control is supposed to detect if Lync is running and pass the command to Lync client is not working. I see 2 controls "Lync Browser Helper" and "Lync add-on"  Both are enabled.

    The user is running on Win 7 64-bit and running the 32-bit version of IE9 and Lync 2010 that has been fully updated with Windows Update. 

    Here's the kicker...  If I configure a test account on the same computer and log in with that new profile; configure Outlook and Lync with one of our testing accounts, Lync joins the meetings just fine.

    So, obviously I can't just blow away the user's profile because he is joined to the domain and remote... What can be done to fix the issue?


    <Signature>

    Tuesday, November 26, 2013 8:26 PM
  • I also found the same thing for one user. I have reimaged her system to fix this. 

    Thursday, November 28, 2013 3:54 AM
  • It is a shame that the only answer I have seen on the net for this issue is to reimage the computer.  That is 1-2 hours of IT technician labor and then a few weeks of end-user frustration as all their settings and preferences got reset back to corporate defaults.

    The problem is somewhere in the user's profile.  That much is certain.  Because on the same computer that experiences this issue, if I create a new user and log in with that account, set up Outlook and Lync, it works just fine.


    <Signature>

    Monday, December 2, 2013 2:05 PM
  • Hello

    Try and check that Internet explorer is your default browser, if your online meeting opens the link in "OTHER" browsers it will send you to the web app.

    Internet explorer redirects you to the Lync app. 

    Monday, December 9, 2013 2:42 PM
  • We already checked all the default program settings for all related programs.  Outlook, Lync, and Internet Explorer.  Lync was completely removed and all registry settings and configuration files were manually removed.  Internext Explorer we did a Reset Web Settings and reset advanced settings.  Deleted the Outlook profile and all configuration files from the user profile and re-setup Outlook.  Reinstalled Lync.  Still no good.

    The ActiveX control in Internet Explorer that intercepts the Meeting URL and redirects it to the Lync client is simply NOT doing its job on this user's profile.

    As I stated earlier, if we create a new user account on the computer and set up Lync and Outlook using the same user's credentials; it works on the clean user profile.

    But there has to be a much less drastic measure to fix this issue than to delete and replace the user's profile with a fresh one.


    <Signature>

    Monday, December 9, 2013 2:54 PM
  • The Lync Browser Helper add-in is not configured for Google Chrome when the Lync client is installed. Chrome does not  interact with other programs. So when you attempt to join a meeting with the Join Meeting link, it loads an aspx which attempts to search for the client outside of the browser. Since the aspx runs into this roadblock it fails the search and falls back to the webapp.

    Resolution-

    1. Use IE as default browser
    2. Install the IE Tab extension for Chrome and make IE tab exception for https://meet.*
    3. Install npMeetingJoinPluginOC.dll for lync.
    4. Install Firefox and uninstall if not required. npMeetingJoinPluginOC.dll file only comes with Firefox, though Chrome can use the same add-in.
    Monday, December 16, 2013 1:27 PM
  • I was having this exact problem on Windows phone 8.1. When I went to a meeting request and clicked on the URL, it kept loading the Lync Web App instead of launching Lync 2013 on my phone. It turns out my Internet Explorer settings on my phone were set to "desktop version" instead of "mobile version". This was causing the Microsoft link handler to redirect me to the web app instead of the mobile app. Changing this Setting in IE on the phone fixed everything.
    Friday, June 20, 2014 6:50 PM
  • Please try this article and correct your Registry.

    http://masteringlync.com/2014/02/10/quick-tip-lync-web-app-launches-instead-of-lync-client/

    Let me know how that works out for you.

    Thanks,

    Na.Kumba Creer

    Thursday, September 25, 2014 9:28 PM
  • Sorry to necro an old thread but if this is occurring I suggest checking that the "lync meeting addin" is enabled in outlook.

        • In Outlook, click the File tab, click Options, and then click Add-Ins.
        • Take one of the following actions:
          • If the add-in is in the Inactive Application Add-ins list, follow these steps:
            1. In the Manage drop-down list at the bottom of the dialog box, click COM Add-ins, and then click Go.
            2. Click to select the check box next to the add-in, and then click OK.

              The New Online Meeting button should now be available in Calendar View, and the Online Meeting button should be available when you create a new calendar item.
          • If the add-in is in the Disabled Application add-ins list, follow these steps:
            1. In the Manage drop-down list at the bottom of the dialog box, click Disabled Items, and then click Go.
            2. Select the add-in, and then click Enable.
      • Restart Outlook, and then verify that the add-in is displayed in the Add-ins dialog box.

        The New Online Meeting button should now be available in Calendar View, and the Online Meeting button should now be available when you create a new calendar item.
    • In Event Viewer, view the Application log to see whether an error was logged for Outlook, for Lync 2010 or Lync 2013, the Online Meeting Add-in for Lync 2010 or the Lync Meeting Add-in for Office 2013.

    Once this has been done, if the addin was indeed disabled, try joining a meeting again. It should open within the desktop client.

    Thursday, February 26, 2015 9:22 AM
  • I came across this thread trying to find the answer to the same problem, but figured it out myself. Try disabling Active X filtering in Internet Explorer - that worked for me
    • Proposed as answer by The Bold Rambo Wednesday, May 27, 2015 1:19 PM
    Wednesday, May 27, 2015 1:19 PM
  • I had the same problem. The Lync Server seems to think that the workstation does not have the Lync Client App or Lync Attendant installed.

    See: how-to-join-a-lync-meeting-without-using-a-browser.

    Copy/paste this link:

    https://social.technet.microsoft.com/Forums/ie/en-US/5e902603-6660-4541-bcdf-c57599d53269/how-to-join-a-lync-meeting-without-using-a-browser?forum=ocsclients&prof=required

    When joining a meeting, if the Lync Web App is being launched and you want to change it to the Lync Client App - modify the "join meeting" link by placing a "?sl" suffix on your meeting link. Clicking on the link should launch the client app. After the Client App is launched successfully, any subsequent requests to join meeting via a https://meeting... will launch the Lync Client App.

    • Proposed as answer by Ron Chin Sunday, January 7, 2018 8:32 PM
    Sunday, January 7, 2018 8:32 PM