none
Lync 2010: DHCP Option 119 and common area phones RRS feed

  • Question

  • Hello

    We have a Lync 2010 Deployment with Enterprise Voice. All our Servers are Windows 2008 R2 sp1. We also use common area phones (aastra 6725ip) with the latest update from July 2011 (CU3). I'm little bit confused because the aastra still needs Netbios to find the domain controller, because the dhcp option 119 does not work.

    DNS Domain: intern.local / netbios domain:intern / sip-domain: bison-its.ch
    DHCP Option 119: local;intern.local

    After booting the aastra device gets the dhcp option 119. (I have checked this with a Microsoft network Monitor 3.4 session to capture the nework traffic.). After a while the aastra starts some dns queries to find the domain controller for the following SRV records

    ldap._tcp.dc._msdcs.intern
    ldap._tcp.dc._msdcs.intern.intern.local

    This does not work, because the right srv record would be: ldap._tcp.dc._msdcs.intern.local, but the device never tries this. At the end the device start a nbtns query to find the "Domain master browser" and gets the correct ip. Why does the dhcp option 119 not work and do we still need wins?

    Is there a bug in the software of the aastra device: http://www.leedesmond.com/weblog/?p=745

    it should be this way: http://blogs.technet.com/b/jenstr/archive/2008/12/08/when-do-you-need-to-use-dhcp-option-119-with-ocpe-powered-devices.aspx

    best regards

    Bueschu


    Bueschu
    Tuesday, August 16, 2011 6:16 AM

All replies

  • Bueschu,

    I don't believe DHCP option 119 is used by the phones and would most likely explain what you are seeing.  For Lync device the only options we require are options 43 and 120.

    http://technet.microsoft.com/en-us/library/gg412881.aspx

    the article above explains all necessary requirements for deployment phone devices.

    thanks

    Mike Hefner

    Friday, August 19, 2011 8:31 PM
    Moderator
  • I don't think so

    http://technet.microsoft.com/en-us/library/gg398275.aspx

     

    Best Regards - Bueschu

     


    Bueschu
    Monday, August 22, 2011 5:29 AM
  • Bueschu,

    good find, because in the document I pointed out, it doesn't seem to require or even mention option 119.  But your link shows how to setup it for devices.  Also this link doens't mention option 119 for setting up DHCP for devices.

    http://technet.microsoft.com/en-us/library/gg398088.aspx

    Which makes me wonder why its listed in one place but not in 2 other places.  Let me do some research and see what i can find about devices using option 119.

    I'll post me findings asap.

    thanks

    Mike

     

    Thursday, August 25, 2011 10:40 PM
    Moderator
  • Bueschu,

    so it appears that option 119 should work.  I could find no bugs or issues regarding option 119 not working.  In fact I found more examples of people not using option 119 who then added option 119 to resolve their connection issues.

    do you have anything specified for option 15?

    If not can you try put "local" in there since even your trace points out that the phone never even searched for "local" only searched for "intern.local"  Even though it shouldn't matter have you tried changing the search order in option 119?

    Finally I would touch base with the phone manufacture just to make sure there isn't a known issue.

    let me know the results of the test above.

    thanks

    Mike Hefner

    Thursday, August 25, 2011 11:17 PM
    Moderator
  • Hello Mike

    Thank's for your answer

    The setting for the dhcp option 15 is intern.local and I have tried to change the order for option 119  - unfortunately no success. I can't change the setting for option 15 to local, because this settings are valid for the PC-LAN.

    The support team from aastra told me that this is definitely a microsoft issue.

    Best regards

    Bueschu

     

     

     


    Bueschu
    Friday, August 26, 2011 4:30 AM
  • DHCP 119 is used by both Communicator Phone Edition and Lync Phone Edition clients and NetBIOs is not a requirement, but is typically seen used a s a fall-back when option 119 is incorrectly configured (or not configured at all).

    I've documented this in detail in this blog article: http://blog.schertz.name/2010/12/configuring-lync-server-for-phone-edition-devices


    Jeff Schertz, Microsoft Solutions Architect - Polycom | Lync MVP
    Friday, August 26, 2011 11:55 AM
    Moderator
  • Bueschu,

    what version is the software on your phone?  Its should be 4.0.4577.0250

    If not please update it and test.  If it is then please enable logging on the phone and send me the logs.  You can email me at cts-mhefner@live.com and I'll review them. 

    thanks

    Mike Hefner

    Friday, August 26, 2011 4:52 PM
    Moderator
  • Actually .296 is the latest release (Cumulative Update 3) and I'm finding it to be better than .250 CU2 was in some scenarios.
    Jeff Schertz, Microsoft Solutions Architect - Polycom | Lync MVP
    Friday, August 26, 2011 5:09 PM
    Moderator
  • Yes, the SW Version ist 296 and I will send Mike the Log-File. I appreciate your help.

    Best Regards

    Bueschu


    Bueschu
    Tuesday, August 30, 2011 4:40 AM
  • Hi, I have several phones (Polycom CX600)  that will not sign inn after they are upgraded to 296. Downgrade them to 250 and they sign in perfectly.

     

    Atle

    Tuesday, August 30, 2011 11:26 AM
  • I have not heard any reports of that yet.  Can you call Polycom support and open a ticket with them on this issue?  Have you also upgraded the Lync server to CU3 as well?
    Jeff Schertz, Microsoft Solutions Architect - Polycom | Lync MVP
    Tuesday, August 30, 2011 12:48 PM
    Moderator
  • Bueschu,

    sorry for the long delay in replying but I have reviewed the logs you sent and unfortunately the logs do not show any reason why it is skipping or not even trying to do a ldap search based on DHCP option 119 that you have specificied.  I cannot reproduce this issue since I don't have access to any Aastra phone devices.

    My recommendation is to open a case with Aastra and have them reproduce the issue contact Microsoft Support.  As this problem doesn't not happen with other phones.  I have searched our bug database and there are no reports about this issue.

    thanks

    Mike 

    Thursday, September 8, 2011 5:13 PM
    Moderator
  • Mike

    Thanks for your support. I have already contacted aastra. The support team from aastra told me that this is definitely a microsoft issue.

    Best Regards

    bueschu


    Bueschu
    Friday, September 9, 2011 5:53 AM
  • My test with an Polycom Cx600 showed the same problem

     


    Bueschu
    Thursday, September 15, 2011 7:11 AM