none
Information Management Policy (Retention) - not working

    Question

  • Hi,

    I have a problem with a retention policy that does not fire on a custom list. The policy must look at a field "Date in" to only keep the items of the last 4 Months. I have set up a retention policy with Date in + 4 months as trigger but the policy does nothing. 

    To test it I had done the same before (on the same list) on our acceptance environment and there everything worked. I also applied the policy to another list in the same site and there no problems as well. So only on that one custom list the policy does not fire for some reason. 

    Additional information: the list holds more than 15 000 items (after the policy this should be reduced to 2500 items). I have restarted the timer jobs (information management policy first and then Expiration policy) multiple times without success.

    Has somebody experienced a problem like this before or any idea to find the cause?

    Thanks!


    Ward

    Wednesday, February 26, 2014 8:56 AM

Answers

  • Hi,

    According to your post, my understanding is that the retention policy not worked.

    Did you activate the Library and Folder Based Retention feature?

    You can go to Top level site settings->Under Site Collection Administration->Site Collection policies->Activate "Library and Folder Based Retention".

    "Information management policy" and "Expiration policy" are the 2 timer jobs which are responsible for retention policy.

    By default both will work "Weekly" change it to "Daily" in Central Admin -> Monitoring ->Review job definitions-> Find "Information management policy" and "Expiration policy".

    What’s more, you can went to the Timer Job Definition for the Expiration Policy and selected Run Now to force the timer job to run, then check whether it works.

    http://sharepointony.info/blog/Lists/Posts/Post.aspx?ID=7

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by Lindali Friday, March 7, 2014 11:08 AM
    Thursday, February 27, 2014 10:00 AM

All replies

  • Hi,

    According to your post, my understanding is that the retention policy not worked.

    Did you activate the Library and Folder Based Retention feature?

    You can go to Top level site settings->Under Site Collection Administration->Site Collection policies->Activate "Library and Folder Based Retention".

    "Information management policy" and "Expiration policy" are the 2 timer jobs which are responsible for retention policy.

    By default both will work "Weekly" change it to "Daily" in Central Admin -> Monitoring ->Review job definitions-> Find "Information management policy" and "Expiration policy".

    What’s more, you can went to the Timer Job Definition for the Expiration Policy and selected Run Now to force the timer job to run, then check whether it works.

    http://sharepointony.info/blog/Lists/Posts/Post.aspx?ID=7

    Thanks & Regards,

    Jason

    Jason Guo
    TechNet Community Support

    • Marked as answer by Lindali Friday, March 7, 2014 11:08 AM
    Thursday, February 27, 2014 10:00 AM
  • the Library and Folder Based Retention setting should only be required if that's what you're trying to run the rules on.   It shouldn't be necessary for individual item-based retention
    Monday, October 24, 2016 4:08 PM