none
Client Can't Sign In - Nothing Left To Troubleshoot RRS feed

  • Question

  • For the past week I've tried everything I can think of to get one user's Lync/S4B client connected. It just says connecting and eventually times out. Up until last week, his Lync/S4B has worked fine for years. Fixes so far:

    1. Deleted sign-in info on lync desktop client.
    2. Deleted lync cache (sip_emailaddress) under %LOCALAPPDATA%\Microsoft\Office\15.0\Lync
    3. Deleted the RSA key under %USERPROFILE%\AppData\Roaming\Microsoft\Crypto\RSA
    4. Checked the Certmgr.msc if there are existing certificate comming from Communications Server. No certificates found.
    5. Deleted the files under %USERPROFILE%\AppData\Local\Microsoft\Office\15.0\Lync\Tracing but retain the folders.
    6. Performed ipconfig /flushdns
    7. Restarted the computer.
    8. Uninstall/reinstall Lync/S4B
    9. Removed/re-added user in Lync Control Panel.

    The user can ping the server just fine. I attempted to sign in on his client but I received the same issue he gets.

    Edit: How can I manually get that cert if it is not being issue? Every other person in my organization has one and is connected to Lync/S4B fine.
    Thursday, September 3, 2015 3:56 PM

All replies

  • Hey,

    Couple of things I would also try:

    1) Make sure the clock is synchronized and with the right timezone, sometime Kerberos skew can cause issues

    2) within the Lync/S4B client when you right click the icon you have an options called sign-in logs - what's mentioned in there?

    3) Does the problem happens internally / Externally or both?

    4) When you tried to log in, did you prompt to enter a password or it didn't even get to this part?

    5) While trying to log in, run the following from CMD: NETSTAT - n 1 | find "SYN" that will tell you if there are any TCP ports being blocked for some reason.

    Thursday, September 3, 2015 9:01 PM
  • So having no certificate (area 4) isn't an issue? I haven't found anybody else in our organization that is missing one.

    1. Clock is synced.

    2. No logs listed.

    3. I'll have him try that.

    4. He's deleted his sign-in info and reentered but it eventually just times out/never signs in.

    5. I'll have him try that.

    Thanks for your help!

    Thursday, September 3, 2015 10:07 PM

  • Any hints in Windows Event Viewer and Skype/Lync logs? Check if any local Windows Firewall rules and/or anti-virus applications are inadvertently blocking successful connections. You may want to consider deleting and creating a new Windows profile for the affected user to see if it helps.

    By the way, can other Lync-enabled users login successfully on the same (domain joined?) machine with the reported issue?

    Thanks / rgds,


    TechNet/MSDN Forum Moderator - http://www.leedesmond.com

    Thursday, September 3, 2015 10:07 PM
  • Nothing helpful at all in both the system and application event logs. If you right click on the lync icon and go to sign-in logs, "no sign-in data available". If I delete his sign in info and try to sign in under me, it just times out (same as his). The weird thing is that when I delete his sign in info, it never asks for my password when I hit connect.

    I haven't ben able to attempt signing into a different user profile, then signing in to Lync yet.

    Wednesday, September 9, 2015 2:24 PM
  • Is problem same if on external network?

    Does client have Internal Root CA installed on his computer?

    Run - MMC - add certificate - local computer - Trusted Root Certificate Authority

    Check if Root CA is there.

    Have you configured IM in OWA? If so does IM in OWA work for that user?

    On S4B client, enable tracing. Then check tracing log with Snooper to see if there are any hints of error.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Friday, September 18, 2015 7:46 AM