none
On Premise Lync / Office 365 EWS not being populated RRS feed

  • Question

  • Hello,

    We use office 365 for exchange and Lync On Premise for IM etc. Also Voice capabilities.

    But we cannot get Lync clients to populate the EWS infor.

    Lync Configuration:

    EWS Information:   EWS Status OK

    EWS Internal URL:   Nothing Populated

    EWS Internal URL:   Nothing Populated

    I have set the Autodiscover.Domain.com  CNAME  to point to autodiscover.outlook.com

    I can access this and get all the configs i nedd i.e. the EWS url

    Is there something else im missing here?

    Monday, January 23, 2012 3:12 PM

Answers

  • Hello,

    The above didn't work so i put it back to the default DNS settings.

    After looking into it further it started to work when we edited the user AD settings and added the correct email address.

    This then started to work correctly. I think it kind of makes sense as the SIP address is different to the Email address, in terms of functionality.

    Chris

    Friday, January 27, 2012 2:03 PM

All replies

  • Hi,

    1, Please create A Record autodiscover.domain.com and point to Exchange CAS server IP address.

    2, Create SRV record _autodiscover._tcp.domain.com and point to autodiscover.domain.com.

    3, Run ipconfig /flushdns in PC client and restart Lync client. You will find the EWS URL.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, January 25, 2012 7:49 AM
    Moderator
  • also ... make sure that you are aware that your domain is probably mydomain.com ... therefore you SRV record will be _autodiscover.tcp.domain.com and you'll be pointing to something.mail.microsoftsoft.something.com ... and your users will probably get a certificate warning pop up.  (it's because the domain name of your SRV record is not the same as the domain name of the target).  This is a security thing that microsoft does as a protection again dns hijacking and other bad stuff.  Research this issue if what I stated was your case (probably is.)
    • Edited by Greg Seeber Wednesday, January 25, 2012 7:40 PM fg
    Wednesday, January 25, 2012 7:39 PM
  • i have created the above CNAME autodiscover.domain.com   to autodiscover.outlook.com

    i have also created a SRV record  _AUTODISCOVER._TCP.DOMAIN.COM   this points to autodiscover.outlook.com

    Flushed dns restarted Lync client still no joy. There is no sign of it even looking. 

    Wednesday, January 25, 2012 8:09 PM
  • So, do this - just a tip ... in your toolbar icons on the right corner ... CTRL + RIGHT CLICK on your Outlook icon and click on "Test Email Autoconfiguration."  K?  So, put your login information for Outlook in there and click TEST.  Now, look through that and see where you see EWS.  Ensure that THIS FQDN is where your SRV record is pointing to.  Usually, it's a wierd long crazy Microsoft FQDN.  Let me know.
    Wednesday, January 25, 2012 8:15 PM
  •  Iwill try this tomorrow when i return to work .

    I will post the results. 

    Cheers

    Wednesday, January 25, 2012 8:17 PM
  • did it work?
    Friday, January 27, 2012 1:54 PM
  • Hello,

    The above didn't work so i put it back to the default DNS settings.

    After looking into it further it started to work when we edited the user AD settings and added the correct email address.

    This then started to work correctly. I think it kind of makes sense as the SIP address is different to the Email address, in terms of functionality.

    Chris

    Friday, January 27, 2012 2:03 PM
  • Funny. You had EWS the whole time - never was the issue.  It was that AD was screwed up.  Oh well.

    We were all trying to get your EWS connectivity to work .... 

    • Edited by Greg Seeber Friday, January 27, 2012 2:07 PM 4
    Friday, January 27, 2012 2:06 PM