Lync Client Presence not updating from Outlook Calendar


  • We had it working and since the April updates it seems to have stopped. This is on all Lync clients, not just one or two.

    I have tried the May Cumalitive update and that has made no difference.

    Our issue seems similar to this KB article as all our users do have capitals in their smtp addresses but having already installed the update I am not sure what to do next and I'm very puzzled as to why it would stop working when all looked so good.

    We have made no changes to policies so I'm confident that isn't the problem (unless the updates somehow messed with them). No changes to the windows firewall either on the clients so I'm guessing that isn't it either.

    Autodiscover works fine and I set up some Exchange Activesync devices today so I'm pretty sure that part is working.

    Any tips on what to try next would be much appreciated.

    Thursday, May 26, 2011 4:52 PM


All replies

  • The Lync client CU2 update seems to have caused this to happen in certain environments.  I believe Microsoft PSS is aware of the issue and working on a fix at this time.  For now the only fix it to revert to RTM or CU1.
    Mike Stacy |
    Friday, May 27, 2011 4:29 AM
  • Thanks for getting back to me. Wish MS would update the KB article to reflect the true state of affairs.

    Any rumours of a time frame for a fix?

    Thanks again.

    Friday, May 27, 2011 9:30 AM
  • Nothing concrete but it should be soon.  I'm not sure if they'll release something in the normal CU schedule, which is about once a quarter, or a separate update like they did the other day.
    Mike Stacy |
    Friday, May 27, 2011 2:49 PM
  • Anyone notice that while the presence doesn't update from outlook calendar.  If you sign out and sign back into Lync during a meeting the presence will change to reflect "In a meeting" or "busy".  Pretty useless but just something I noticed.
    Friday, May 27, 2011 5:20 PM
  • I am seeing this in my org too. Presence info was working, then at some point it stopped and it doesn't update when a meeting is on the calendar. I've applied all server and client updates I could find but no joy. We also have some custom presence info that isn't changing when we update the .xml file. If i open the URL to the presence file, it doesn't show the changes.
    Thursday, June 16, 2011 4:05 AM
  • I logged a call with MS and the latest info I have is that they do have a fix that will be released as part of CU3 due July/August as this has impacted a fair few people. If I get any more news I'll post it here.

    Thursday, June 16, 2011 8:25 AM
  • Hi,

    We have the same issue, but the users email address it only lower case letters

    We have the following versions

    Outlook 2010

    Lync client 2010 4.0.7577.280

    Lync 4.0.7577.0


    Thanks for reply



    Friday, June 17, 2011 9:04 AM
  • Hi all,

    We're having the same problem, tried the Lync client versions from 4.0.7577.0 and higher.

    Outlook calendar meetings will update the Lync status, but only after a long time, appointments with status out-of-office or busy do not trigger any update of the Lync status.

    Autodiscover and EWS appear to be correct.

    Thanks for any updates,



    Wednesday, June 22, 2011 12:25 PM
  • Hi all,


    Jumping on the bandwagon here.

    We are seeing the same behavior on both Lync clients (any version) and OCS R2 clients against Ex2007 calendars and Ex2010 calendars. Users on ex2007 seem to have their Free/Busy status update in the Lync client after 5 - 10 minutes, but Ex2010 users never update.

    Our Lync Server's are at RTM version right now.



    Thursday, June 23, 2011 4:23 PM
  • Hello,


    I'm throwing my name into this as well.  We started seeing the issue about 6/9.  On 6/10 I opened a case with MS support and it's still open.  Shortly before we started seeing the issue we applied CU2 to both the back-end and clients.


    In troubleshooting with MS we have tried the client at various patch levels, no effect.  We have not gone down the route of backing CU2 off of the back-end servers.


    Another interesting note is that in the client ETL logs we can see it pull down presence information from Exchange it just won't update the client.  Call inforamtion from the Lync servers updates correctly.  So when I'm in call the client will update to "in a call" almost immediately. 





    Tuesday, June 28, 2011 5:37 PM
  • Hi,

    Could you please provide a KB number for this new issue as this is a major problem for us and I would like to keep up to date on it.



    Monday, July 04, 2011 11:48 PM
  • I may have come up with a workaround fix for this issue.  I have tested it on 4 affected users and so far it seems to be working:


    Using ADSIEdit, modify "mail", msRTCSIP-PrimaryUserAddress" and "ProxyAddress" attributes so they are all in lower case


    On the affected client machine:

    1.  Shutdown the Lync Client

    2.  Browse to C:\Documents and Settings\<USERID>\Local Settings\Application Data\Microsoft\Communicator

    3.  Rename any folder that starts with "sip_", just put "._old" at the end

    4.  Launch the Lync client


    It has taken up to 24 hours for the presence information to start to display correctly but after that it seems to work fine.


    Not a great fix for a large scale implementation, but it can at least be used on the users who are making the most noise about the issue.


    • Proposed as answer by ogradyc Monday, December 19, 2011 5:15 PM
    Wednesday, July 06, 2011 2:22 PM
  • Hi Mattw72,

    i am having currently exactly the same problem, but your proposed workaround did unfortunatelly not work for me.
    But it was worth a try.

    We will wait for the Windows update then.

    Tuesday, July 12, 2011 11:25 AM
  • Does anyone have any information on a fix from Microsoft? We have started to see this issue also. Thanks.

    Thursday, July 14, 2011 1:04 PM
  • We are also experiencing this issue 1500+ users some of whom are frustrated that meetings/out of office presence is not being published.
    Thursday, July 21, 2011 1:53 PM
  • We are starting to see the same issue all of a sudden.  I rolled my client back to RTM but that made no difference.  We are rolling out the May (.280) update to all our clients very soon and already have CU2 applied on the servers.  I guess we will be rolling out yet another update for this fix.  Not cool...

    Correction: it later started working after removing the update.  Nice.  There have been too many botched updates for both Communicator/Lync and Exchange lately...

    Tuesday, July 26, 2011 6:24 PM
  • Tuesday, July 26, 2011 7:39 PM
  • It is still very early of course but we applied CU3 to a workstation that was having the problem (we removed the May update first and that cleared it up as well) and it appears the presence issue is gone.  I guess we'll see what else CU3 breaks though...

    Wednesday, July 27, 2011 8:23 PM
  • Hi MacGeever,

    Just out of interest, have you also applied the CU3 update to the servers as well or just the client? I was wondering if you have to do all at the same time or if we can get away with just doing the affected clients for now.

    Thursday, July 28, 2011 5:52 AM
  • No, we just have CU2 on the servers for now.
    Thursday, July 28, 2011 1:52 PM
  • This worked for me. 


    In Windows 7 the Directory was:



    Worked instantly for me, as I had a meeting on my calendar at the time of fixing it. 

    Monday, December 19, 2011 5:17 PM
  • I'm having similar issue but I got slightly different flavor :-)

    We recently upgraded back-end to Lync 2013 (Exchange still 2010 obviously) and everything worked just great.

    Then we upgraded few Lync clients to Office 2013 that includes Lync 2013 on the client side, and then issue started but only for Lync 2013 users.

    Behavior is very interesting though. If Lync user locks computer with Lync 2013 client running and goes to meeting, his status will remain "Away" instead of "In a meeting" which is obviously the problem.

    If during the meeting he unlock computer (e.g. to test) then status changes to Available (i.e. green) while he still on the meeting, so obviously it does not work.

    Now if user close (exit) Lync client and restart it, status will change upon opening Lync to "In a meeting", which is kind of cool but not that cool because it supposed to happen automatically.

    The new problem is that when the meeting is over, status stays "In a meeting" which is completely ridiculous of course. The only way to change status from "In a meeting" back to normal is to restart Lync client (exit and start).

    I got 4 people total with Lync 2013 and they all 4 have exactly the same issue, but again only with the "In a meeting" status. "In a call" for example works like a charm, but we know that this is handled by Lync, Exchange not involved.

    It looks like a total disaster bug in Lync 2013, that looks like not reading or refreshing Calendar information properly, but it does read it on start only.

    Any ideas?

    Wednesday, December 12, 2012 5:54 PM
  • Seeing the same issues, any word on resolution?

    Robert "Ben" Stewart BS, GIS, MCITP, MCSE, MCSA: Messaging

    Monday, January 07, 2013 10:11 PM
  • Downgrade to Lync 2010 on the client side :-)

    Well, so far I can confirm that: if you have Lync 2010, then it works rock solid. If you have Lync 2013, it does not work. But only one thing does not work: update Lync status from Exchange (e.g. in a meeting). The rest is working but this is clear why - the rest is controlled by Lync, not Exchange.

    My guess is that it's time to switch to Exchange 2013, and everything will be working there just fine. Microsoft probably won't have time for fix issue in old product like Exchange 2010 :-)

    Anyway, yes, would be nice to see here some reply from Microsoft. Microsoft, help!

    Tuesday, January 08, 2013 1:23 AM
  • This is a known issue, and being considered for an update in the next 2013 client release

    Symptom: 2013 RTM client not updating presence based on calendar availability


    Primary SMTP address contains capital letters.

    Friday, January 11, 2013 6:44 PM
  • Temporary fix would be to update the primary SMTP address so that it is all lower case.

    Then let the address book update in the night, verify if the LS Address book updates with all lower case version of the email address (i.e. matches the case with SIP address).
    Monday, January 14, 2013 11:07 PM
  • Well, I tried several things:

    1. Make sure that both SMTP and SIP address cases match. This is the case. Status not getting updated

    2. Changed ALL possible addresses (SMTP, SIP, UC) to lower case. All changed. Status still not updating

    Kind of giving up on this. Oh well, what else we can try? Wait for fix in Rollup one, and not to deploy 2013 for now.


    Tuesday, January 15, 2013 3:11 PM
  • Very first thing which we have to look into after login to Lync client. Check the MAPI status on lync configuration information (press control key > right click on lync tray icon> click on configuration). This status must be ok.

    Secondly, the email address (SMTP address ) and sip address must be same. There must not be any outlook intigration error message on Lync client status.


    ~Answers provided are coming from personal experience, and come with no warranty of success. I as everybody else do make mistakes~ BR...~UKS~

    Friday, May 31, 2013 3:30 PM
  • The problem still exist with Exchange 2013 CU3 and Lync 2013 Nov2013 CU.
    The presence is not updating until you close (exit) Lync and open it.

    Does anyone has a solution from MS?


    Tuesday, December 03, 2013 10:08 AM
  • in my case, both SMTP and SIP are the same, in lower case. However, when I checked the Config Information on the user's PC I noticed that MAPIstatus is OK and EWS Information status is 'not deployed'. Then I comapred this with my MS Lync, which display EWS Info as 'EWS Status Ok', through a Citrix Xenapp session. Also I check what version that user have installed on PC, it is ver. 4.0.7577.4445 and the version on my Citrix Xenapp is Ver. 4.0.7577.4384

    Also the EWS External URL is empty on the user's PC.

    I have no ideai how to change this. Any expert to help me???

    I am trying to find the same version that I have for my Xenapp to be installed on my user's machine for test. I do not know how to get it from Microsoft website.

    Well, what to do next?

    Thursday, May 28, 2015 9:24 AM