none
The user's password must be changed before signing in - Windows 10 1809 Unattended installation RRS feed

  • Question

  • Dear all

    We are trying to apply a windows 10 1809 image using unattended file where it creates an local account and auto-logon.

    With the similar unattended file we were able to achieve on windows 10 1709, but on 1809 we are getting an prompt to reset password. "The user's password must be changed before signing in"

    I either key in the new password or give cancel and then my remaining installation progresses. 

    Unattended file attached. The error i get during oobe also is attached. Any help at the ealiest will be much helpful and much appreciated .

    Thanks in advance

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user Administrator /active:yes</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <CopyProfile>true</CopyProfile>
                <RegisteredOwner>CompanyX</RegisteredOwner>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-us</InputLocale>
                <SystemLocale>en-us</SystemLocale>
                <UILanguage>en-us</UILanguage>
                <UILanguageFallback>en-us</UILanguageFallback>
                <UserLocale>en-us</UserLocale>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <FirstLogonCommands>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>Schtasks.exe /create /TN "renametask" /TR "c:\Automate\test.bat" /SC ONLOGON /RU SYSTEM</CommandLine>
                        <Order>1</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>Schtasks.exe /run /TN "renametask"</CommandLine>
                        <Order>2</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>Schtasks.exe /delete /TN "renametask" /F</CommandLine>
                        <Order>3</Order>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                </FirstLogonCommands>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <ProtectYourPC>1</ProtectYourPC>
                </OOBE>
                <RegisteredOrganization>CompanyX</RegisteredOrganization>
                <RegisteredOwner>CompanyX</RegisteredOwner>
                <TimeZone>India Standard Time</TimeZone>
                <UserAccounts>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>**encrypted text*</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>Account1</Description>
                            <DisplayName>Account1</DisplayName>
                            <Group>administrators</Group>
                            <Name>Account1</Name>
                        </LocalAccount>
                    </LocalAccounts>
                    <AdministratorPassword>
                        <Value>**encrypted text*</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
                <AutoLogon>
                    <Enabled>true</Enabled>
                    <LogonCount>1</LogonCount>
                    <Domain></Domain>
                    <Username>Account1</Username>
                    <Password>
                        <Value>**encrypted text*</Value>
                        <PlainText>false</PlainText>
                    </Password>
                </AutoLogon>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-us</InputLocale>
                <SystemLocale>en-us</SystemLocale>
                <UILanguage>en-us</UILanguage>
                <UILanguageFallback>en-us</UILanguageFallback>
                <UserLocale>en-us</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:e:/os/sources/install.wim#Windows 10 Enterprise" xmlns:cpi="urn:schemas-microsoft-com:cpi"></cpi:offlineImage>
    </unattend>
    


    Sunday, August 11, 2019 2:56 PM

Answers

  • Hi All

    I was able to get the deployment going thru by just changing the order of instructions given to the unattend file.

    Just the <AdministratorPassword> block was moved ahead of <LocalAccounts> under both <UserAccounts> and <AutoLogon>. 

    <UserAccounts>
    	<AdministratorPassword>
                        <Value>somevalue</Value>
                        <PlainText>false</PlainText>
             </AdministratorPassword>
             <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>someothervalue</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Description>Account1</Description>
                            <DisplayName>Account1</DisplayName>
                            <Group>administrators</Group>
                            <Name>Account1</Name>
                        </LocalAccount>
               </LocalAccounts>
    </UserAccounts>


    Aravinth Mathan

    Tuesday, August 20, 2019 2:36 PM

All replies