Skype for Business Screen sharing issue RRS feed

  • General discussion

  • Hi Team,

    I am working on a specific Skype Diagnostic ID - 52163, Issue with Desktop sharing on Skype for business client. The error is observed in both conferences and Peer to peer sessions.

    There is intermittent desktop sharing failures observed by random users across our deployment. We are current running with Skype for Business on premise environment.

    Below is what i observed from the logs, complete list of candidates are exchanged , no abnormalities here. And the session end with the below diag ID

    52163; reason=Appsharing session disconnected due to failures in RDP stack";UserType="Callee";MediaType="application-sharing";NetworkErr="no error";ErrTime="0";RTPSeq="0";SeqDelta="0";RTPTime="0";RTCPTime="3671339649452";TransptRecvErr="0x0";RecvErrTime="0";TransptSendErr="0x80004005";SendErrTime="3671339642972";InterfacesStall="0x0";InterfacesConnCheck="0x0";MrDnsE="APA.LyncAV.accenture.com";MrResE="0";MrDnsI="APA.LyncInt.accenture.com";MrResI="1";MrDnsCacheReadAttempt="0";ICEWarn="0x0";ICEWarnEx="0x0";LocalSite="x.x.x.x:34406";LocalMR="x.x.x.x:57911";RemoteSite="x.x.x.x:62508";RemoteMR="x.x.x.x:57637";PortRange="39040:39059";LocalMRTCPPort="57911";RemoteMRTCPPort="57637";LocalLocation="2";RemoteLocation="2";FederationType="0";NetworkName="svc.accenture.c";Interfaces="0x4";BaseInterface="0x4";BaseAddress="";Protocol="1";LocalInterface="0x4";LocalAddrType="0";LocalAddress="x.x.x.x:39051";RemoteAddress="x.x.x.x:62508";RemoteAddrType="0";IceRole="1";RtpRtcpMux="1_FirstHopRTTInMs=0";MediaDllVersion="5.0.8687.149";MrDnsE="APA.LyncAV.accenture.com";MrResE="0";MrDnsI="APA.LyncInt.accenture.com";MrResI="1";MrDnsCacheReadAttempt="0";LyncAppSharingDebug="SharerChannel:0x8000ffff; Memory Usage: totalUsedVirtual=1846_ availableVirtual=200;StartupTime: 2016-05-03T02:08:33.195Z;""

    The screen share fails with the message "An error occurred during the presentation" at the caller end.

    And as and when the user restarts the Skype client or reboots the machine, the issue i fixed, the user will be able to initiate desktop share without any issue. 

    Already checked the local network and the required port connectivities, I have a feeling it is something on the local machine which is causing the issue. But not sure in which direction to continue.


    Wednesday, May 4, 2016 10:19 AM

All replies

  • Please check which subnet issue computer are at. Then check your edge server if the subnet is defined there.

    Route print and confirm its ok.

    P2P it should only use port 443, but in conferencing (3 or more) it will use high ports.

    Does the issue occure when user is n external network as well?

    Check your Lync deployment and which IP and port is defined for your AV service.

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, May 4, 2016 3:52 PM
  • The issue is observed with both internal and external users, also both in peer to peer and conference sessions.

    The issue is also observed between 2 internal users as well, where the edge servers do not come in to picture.

    Checked the routes on the edge, the right routes are already in place.

    The User will be able to start his screen sharing without any issue once the Skype for business client is restarted even a system restart also helps.

    Thursday, May 5, 2016 8:14 AM
  • yesstrange issue, please check SFB client version and see if reinstall helps.

    No mather internal or external, SFB clients will always connect to Edge server for Ice negotiation.

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Thursday, May 5, 2016 2:23 PM
  • Hello Paulson,

    Yes its a wired issue and fixing intermittent issues are very difficult.

    Lets isolate the issue first.

    1. does this happens with multiple users or single user.

    2. if it happening with multiple users whats the recent change ?

    3. if its with single user most probably with Network card drivers or system updates on within the system - solution is restore to best config and see if this works.

    4. if its with multiple users verify if there is any recent security update causing this issue. at this point I am pretending there is no server issue.

    5. check with your security and network team any recent change in config.

    I have solved many client related issues specially with single user scenarios caused due to recent security windows updates or Network drivers.

    Let me know if this helps.

    Regards, Raju

    Monday, June 20, 2016 11:37 AM
  • Did you ever find out what was causing your 52163's? I'm starting to see a small swell of them in our environment and I have a few users complaining of the exact symptoms you're seeing. Very random, intermittent connection to the sharing services. Reboot typically fixes it. So frustrating to chase down.

    Pat Mc-

    Wednesday, July 27, 2016 5:41 PM
  • Also seeing this issue here. Very hard to trouble shoot. 
    Wednesday, January 18, 2017 4:15 AM
  • Hi,

    this is old discussion and maybe case is solved already.

    But do you use VbSS in your Skype for Business conferencing policy?

    If not, it would be worth to try at this point to enable it.



    "Certified" OCS specialist

    Friday, March 27, 2020 11:47 AM