none
Unable to login to Mobile Skype for business clients, but able to login to mobile lync 2010 client. RRS feed

  • Question

  • Hello Team,

    we have installed s4b server 2015 standard, 1 fe and 1 edge server.  

    issue: we can able to login to mobility lync client 2010, but unable to skype for business 2013 and 2015 mobile clients. 

    error: stuck on signing in 

    please help me out.

    Thanks in advance.

    vinay

    Tuesday, November 29, 2016 6:45 AM

All replies

  • Hi RS Team,

    Are the mobile client on the internal network or connecting externally directly on the internet ?

    The 2013 and SfB client must connect to the FE server via the reverse proxy as the traffic needs to use port 4443 to hit the external web sites of the front end server. The Lync 2010 client connects differently and can connect to the internal website.

    Have you deployed the reverse proxy role ?

    Thanks,

    Martin


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". Thank you. This forum post is based upon my personal experience and does not reflect the opinion or view of my employer.

    Tuesday, November 29, 2016 9:25 AM
  • Hello Martin,

    The issue with both networks, internal and external (internet) as well.

    Yes. we do have reverse proxy in place. 

    yes, earlier I was facing issue with skype web app meeting with Internet before deploying Reverse Proxy once we deploy Reverse proxy skype web app meeting is working fine.

    any additional configuration need to done for mobility?

    Thanks in advance.

    vinay


    • Edited by RS Team Tuesday, November 29, 2016 9:33 AM
    Tuesday, November 29, 2016 9:32 AM
  • Hi Vinay, 

    Agree with Martin, also please look into this forum discussion which explains better on the Lyncdiscover requirements. Also would suggest to run  the remote connectivity analyzer Tool that can help to isolate connectivity issues.

    https://www.microsoft.com/en-in/download/details.aspx?id=36535


    Linus || Please mark posts as answers/helpful if it answers your question.

    Tuesday, November 29, 2016 9:51 AM
  • Hello Akampa,

    Below are the result from Lync analyzer from external network.

    Thanks in advance

    vinay

    Tuesday, November 29, 2016 10:02 AM
  • Hi Vinay,

    In external dns you should have lyncdiscover.domain.com with public ip of your reverse proxy. this shouldnt be in internal dns.

    In internal dns you should have lyncdiscoverinternal.domain.com this should point to your front end server internal ip address.

    In internal dns you will need your external web services FQDN with the public ip address of your reverse proxy.

    In your reverse proxy you will need rules to publish this and ensure it pass traffic to the front end server on port 4443, you will also need a SAN on your reverse proxy certificate for lyncdiscover.domain.com unless your using a wildcard certificate.

    You can test lyncdiscover also using a browser https://lyncdiscover.domain.com and it should ask you to download a file, open in notepad and it should display the autodiscover service url.

    Thanks,

    Martin


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". Thank you. This forum post is based upon my personal experience and does not reflect the opinion or view of my employer.

    Tuesday, November 29, 2016 10:22 AM
  • Hello Martin,

    Thank you for your reply.

    Yes, we have pointed lyncdiscover.domain.com to our Reverse proxy Public IP.

    yes, lyncdiscoverinternal.domain.com  pointing to FE server IP.

    yes, that external web services FQDN with public IP have beed added into internal DNS.

    yes, we have configured reverse proxy such way that all user request to the FE server on 4443.

    when I test using https://lyncdiscover.domain.com below is the result.

    {"_links":{"self":{"href":"https://skypeweb.domain.com/Autodiscover/AutodiscoverService.svc/root?originalDomain=Domain.com"},"user":{"href":"https://skypeweb.Domain.com/Autodiscover/AutodiscoverService.svc/root/oauth/user?originalDomain=Domain.com"},"xframe":{"href":"https://skypeweb.Domain.com/Autodiscover/XFrame/XFrame.html"}}}

    Thanks in advance

    vinay

    Tuesday, November 29, 2016 10:45 AM
  • The return xmll looks good skypeweb.domain.com should be your external web services url? , What about the certificate that you have assigned in the Reverseproxy and also the san entries

    Linus || Please mark posts as answers/helpful if it answers your question.

    Tuesday, November 29, 2016 11:19 AM
  • Hi RS,

    Could you grab a log from the mobile client as well, this may give some information to whats going on ?

    As Akampa mentions please could you confirm your public certificates on the reverse proxy.

    Thanks,

    Martin


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". Thank you. This forum post is based upon my personal experience and does not reflect the opinion or view of my employer.

    Tuesday, November 29, 2016 11:26 AM
  • yes skypeweb.doamin.com is a external web service url.

    we have assigned public CA with san entries of DNS Name=Skypeweb.Domain.com
    DNS Name=Dialin.Domain.com
    DNS Name=Lyncdiscover.Domain.com
    DNS Name=Meet.Domain.com

    thanks

    vinay

    Tuesday, November 29, 2016 12:01 PM
  • Hi vinay,

    Welcome to our forum.     

    Did you use the different mobile phone to have a check?
    Did you create a new test account to have a test?

    As above suggestion, check certificate on reverse proxy server. As your post, it has been include autodiscover SN item, then re-generate certificate on reverse proxy server, and also re-generate certificate on Skype for business FE using SFB server 2015 deployment wizard.

    Whether there are any modifies after you deploy SFB server, you also check Client Version Policy on SFB control pane.

    If there are any questions or issues, please be free to let me know.   


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 30, 2016 6:15 AM
    Moderator