none
WSUS fails to download Win 7 and Server 2008 R2 updates RRS feed

  • Question

  • WSUS was working fine for about 4 months when all of a sudden it began failing to download Win 7 and Server 2008 R2 updates.

    Its interesting you see the update download to the folder but then it deletes itself.

    The error message reads:

    Content file download failed. Reason: file cert verification failure. Source File: /msdownload/update/v3-19990518/cabpool/windows7-kb842773-v2-x64-enu_1d3d2bc417bf9d881206ed238ad6a4a9c189cfb3.exe Destination file: c:\WSUS\WsusContent\B3\1d3d2bc417bf9d881206ed238ad6a4a9c189cfb3.exe

    Event ID 364

    Task category 2

    This issue only occurs for Win 7 x64 and Server 2008 R2 updates

    We have tried the following:

    -restarted the wsus and bits services

    -restarted the server

    -Uninstalled and reinstalled WSUS on the same server several times

    -Installed the database on both the c:\ and a shared drive

    -Stood up a brand new server and installed WSUS and IIS

    -disabled anti-virus/local HIPS

    -Network Service and system have full access to c:\WSUS\WsusContent

    Any suggestions would be most helpful

    Monday, March 19, 2012 3:52 PM

All replies

  • Hi,

    Pls try to run the rootsupd.exe on your server and some are fixed after patching this.

    If not,Pls try to decline kb842773 and mannually delete file located in c:\WSUS\WsusContent\B3\1d3d2bc417bf9d881206ed238ad6a4a9c189cfb3.exe. Run the WSUSUTIL RESET to see whether it works.


    Best regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Tuesday, March 20, 2012 6:47 AM
    Moderator
  • We tried that and it didn't work. After looking at the certificates we noticed some microsoft certs were missing. We added them back, but that didn't help.
    Friday, March 23, 2012 1:44 PM