locked
Exchange 2016 mailbox cannot access Exchange 2010 Public Folder after mailbox move, but new profile is ok!? RRS feed

  • Question

  • I'm in middle of Exchange 2010 to 2016 migration. The co-existence infrastructure is set up. Mail flow , DAG and all that is working just fine. Only thing not working is Public Folder for a migrated user unless build new Outlook profile.
    I followed all the steps in creating Public Folder Proxy mailbox following this article to the T (https://technet.microsoft.com/en-us/library/dn690134%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396)

    Symptom:
    After I migrate a mailbox from Exchange 2010 to 2016, that mailbox is unable to access legacy public folder with error message "Cannot expand the public folder.  Your profile is not configured (o=/First Organization/ou=Exchange Administrative group....blah blah blah Exchange server name)"
    As a note:  When Outlook first launches I get this dialogue box showing the Exchange 2010 PF server and Exchange 2016 mailbox, I just press ok.  Also when I have connection settings open I see it connect to the Exchange 2010 PF server for split second then disappear....???

    Here's the catch:
    If I create a brand new Outlook profile for the same migrated user - Public folders show up nicely! ...Picture below shows connections settings after new profile set up.  Seems like it goes through E2016 to get to E2010 ....but whatever, it works!  Just why not after a mailbox migration????  Profile...? hmm

    I have checked and done the following for troubleshooting:
    authentication permission for Outlook Anywhere on Exchange 2010 public folder - NTLM (/RPC virtual directory) - tried after setting this, doesn't work
    Full access granted to authenticated users on the PF Proxy mailbox on Exchange 2010 - tried after setting this, doesn't work
    Removed cached mode and try again - doesn't work

    I think this has something to do with Profile but not sure what or where to check.  I am not going to create new profiles for each mailbox after I migrate.  Public Folder is heavily used in this environment and need to get this to work seamlessly

    Help!

    -C-



    • Edited by Charlie1313 Wednesday, August 24, 2016 2:09 AM
    Wednesday, August 24, 2016 1:48 AM

All replies

  • Please have a look at this earlier thread i.e. Exchange coexistence 2010/2016 - Public Folder not accessible when I move user mailbox on Exchange 2016

    Also check the below links might helps you:

    https://support.microsoft.com/en-in/kb/2834139

    https://support.microsoft.com/en-us/kb/2839517

    As a workaround, after all the mailboxes were migrated, move the public folders to Exchange 2016. Users are able to access the public folders from Exchange 2016 directly.

    You may get help from this article - Public Folder migration to Exchange Server 2016.

    Hope this helps!


    Migrate mailboxes, Public Folders, Outlook profiles and rules and GAL etc. to-and-fro Exchange Servers and Office 365 with LepideMigrator for Exchange

    Wednesday, August 24, 2016 5:42 AM
  • Hi,

    What's the version of outlook and operation system on that machine?

    Please try this on other version of outlook for users in the same situation.

    And try repairing the Exchange email account instead of re-creating account profile to see this problem.


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    • Edited by Lynn-Li Wednesday, August 24, 2016 9:07 AM
    Wednesday, August 24, 2016 9:06 AM
  • Thanks for the link to https://social.technet.microsoft.com/Forums/en-US/c3101423-2098-4aec-94e2-9dccce19f6f9/exchange-coexistence-20102016-public-folder-not-accessible-when-i-move-user-mailbox-on-exchange?forum=Exch2016SD

    Unfortunately that didn't help, I don't have anything in the credential manager

    As for the workaround, I can't do that because there is a co-existence phase, will take some time to migrate everyone.  During the migration time, Public Folder needs to be available at all times.

    It's not that the public folder proxy between 2016 and 2010 is not working... it works... so the infrastructure, permissions...etc is all correct.  It just doesn't work for an Outlook profile that was just migrated to 2016 from 2010.  I really feel this has something to do with the profile and not the infrastructure.


    -C-

    Wednesday, August 24, 2016 3:06 PM
  • So far its Windows 7 and Outlook 2010 SP2.  I am going to try with Outlook 2013 today

    -C-

    Wednesday, August 24, 2016 3:06 PM
  • Did you ever Resolve this issue. I'm having the same thing happen to my users in a migration to Exchange 2016 from Exchange 2010 in a coexisting environment.

    Thanks

    Patrick

    Tuesday, January 31, 2017 7:54 PM
  • Yes I did, I installed all the latest updates to the Outlook client and it resolved the issue!

    -C-

    Wednesday, February 1, 2017 3:08 PM
  • Use the Get-RpcClientAccess cmdlet to view the service is running on Exchange 2016. 
    Wednesday, February 1, 2017 6:52 PM
  • I have Exchange 2016 CU4 and Exchange 2010 SP3 CU14

    I have the same issue only in Outlook 2016. I  installed newest update https://support.microsoft.com/en-us/help/3141453/january-3,-2017,-update-for-outlook-2016-kb3141453 but public folder not working.

    In Outlook 2013 Sp1 everything works fine.

    I have this case in the customer's environment and my lab.

    Best regards

    Tomek

    Friday, February 3, 2017 11:38 AM
  • In my case I disabled MAPI over HTTP

    Set-OrganizationConfig -MapiHttpEnabled $false

    and iisreset on both exchange 2016

    and Public Folders works :-)

    Thursday, February 9, 2017 3:46 PM
  • Same problem here. Set up a public folder proxy mailbox, access with Outlook 2013 works fine, Outlook 2016 shows  "Public folders of ..." but when you try to access them it say "Cannot expand the folder. Networking error".
    Saturday, April 1, 2017 10:01 PM