none
Office 365 Hybrid Configuration wizard stuck Adding Federated Domain RRS feed

  • Question

  • Hi, 

    I'm running the latest hybrid configuration wizard and it's stuck at Adding Federated Domain. It said found matching TXT record first but is now just sitting. 

    What should I do from here? 

    Thanks

    Thursday, August 18, 2016 10:45 AM

Answers

All replies

  • I cancelled the wizard and ran again and it went through fine 
    • Marked as answer by Johnha1981 Thursday, August 18, 2016 2:39 PM
    Thursday, August 18, 2016 11:00 AM
  • Good to see you are unblocked. And thanks for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, August 19, 2016 7:52 AM
    Moderator
  • I have canceled and restarted the wizard three times and it still stops at adding federated domain step. It did find the text record no problem. We let it run overnight at this step. Not sure what to do next.
    Tuesday, October 11, 2016 12:30 PM
  • I’m experiencing the same problem as stjohn56. Both in my production and lab environment. Restarting does not help. Removing all other TXT values does not help either.

    • Proposed as answer by stjohn56 Thursday, October 13, 2016 1:01 PM
    Tuesday, October 11, 2016 3:36 PM
  • We are in the same boat.

    We've just setup a new Exchange 2016 (CU3) server, and stuck at Adding Federated domain... 

    I went and did remove-federationtrust, re-ran the wizard (which prompted to re-setup the trust) . On running it gave us a new TXT key to add to DNS, so we did that... same result again. Left it to run for 12+ hours and nothing, just sits there forever.

    Anyone know if there are any issues with O365 at the moment? I'm going to log a case with them now and will report back what happens, if anything.


    Wednesday, October 12, 2016 2:40 AM
  • So now I'm exposing the exchange in the lab environment with an external IP just to rule out FW and such. Same issue in both prod and lab.

    This is the error I get: 

    An error occurred while attempting to provision Exchange to the Partner STS.  Detailed Information "An error occurred accessing Windows Live. Detailed information: "The underlying connection was closed: An unexpected error occurred on a receive.".".

    We'll continue troubleshooting this but I'm starting to think that there's a problem with Microsoft. Specifically when "windows live" is included in the error message. 

    Wednesday, October 12, 2016 7:26 AM
  • I just had a phone call from MS, I'm told there is a known issue that the backend team is working on. 

    Waiting on an estimated resolution date, but at this stage nothing meaningful...

    I'll post back when I hear from them next.

    Wednesday, October 12, 2016 8:18 AM
  • I'm having the same thing.  Also, as a side note, originally I tried with no CU installed (2016 RTM) and had the same thing.  So I dont think its specific to CU3

    Aaron Clegg

    Wednesday, October 12, 2016 8:53 AM
  • Same on 2010 SP3 CU14 and 15...
    Wednesday, October 12, 2016 9:18 AM
  • I am also facing same issue in the environment having Exchange 2013 CU13 installed.

    Parveen

    Wednesday, October 12, 2016 9:22 AM
  • Same issue over here : I am also facing same issue in the environment having Exchange 2013 CU12 installed.


    Wizard stall forever on "Adding Federated Domain ...."

    Wednesday, October 12, 2016 10:02 AM
  • I did another client Hybrid 2013 on last Friday, so this is a new issue this week.

    Aaron Clegg

    Wednesday, October 12, 2016 11:33 AM
  • Facing the same issue here (Netherlands). HCW stuck on "Adding Federation Trust..." / Exchange 2010 SP3 RU 14
    Wednesday, October 12, 2016 12:34 PM
  • Same problem here currently in Detroit Michigan, USA.
    Wednesday, October 12, 2016 12:52 PM
  • Same issue here (netherlands), Exchange 2013 with CU14 (just installed).
    Found TXT records but hangs on 'Adding Federated Domain...'
    Wednesday, October 12, 2016 12:52 PM
  • Same issue here (netherlands), Exchange 2013 with CU14 (just installed).
    Found TXT records but hangs on 'Adding Federated Domain...'

    Just to confirm, this is exactly what I am experiencing.
    Wednesday, October 12, 2016 12:55 PM
  • Also just got confirmation that they know about the issue and that the back-end team is investigating. 

    Wednesday, October 12, 2016 2:26 PM
  • Also just got confirmation that they know about the issue and that the back-end team is investigating. 


    Thanks for the information Daniel.
    Wednesday, October 12, 2016 4:04 PM
  • Is there any updates for this?
    Wednesday, October 12, 2016 8:31 PM
  • I've successfully set up a new federation this morning (manually - trying via the HCW at the moment, waiting for DNS) - I was having the same issue last night (and the last couple days), but seems to be working this morning!
    Wednesday, October 12, 2016 10:48 PM
  • Same here - HCW is now going past the adding federated domain stage

    Aaron Clegg

    Wednesday, October 12, 2016 11:49 PM
  • I haven't heard back from MS about the backend team working on this any further, but my HCW finished successfully today as well.

    Give it another go and hopefully it works for everyone else as well!

    Thursday, October 13, 2016 4:21 AM
  • Yes It has started working and able to complete HCW today morning

    Parveen

    Thursday, October 13, 2016 4:22 AM
  • It worked for me this morning. Microsoft must have fixed the issue.

    stjohn56

    • Proposed as answer by stjohn56 Thursday, October 13, 2016 1:01 PM
    Thursday, October 13, 2016 1:01 PM
  • Not working for me today, anyone else having the issue back?
    Sunday, October 16, 2016 2:30 PM
  • after 1 day of tentatives, it finally worked, not sure why :)
    Sunday, October 16, 2016 4:23 PM
  • Same Issue. Using Exchange 2016 RTM

    -Moin MD

    Tuesday, October 18, 2016 7:56 AM
  • Same issue for me, running the latest hybrid against 2013 CU11.....

    Patrick Genova

    Thursday, October 27, 2016 4:48 PM
  • I'm having the exact same issue with Exchange 2013 CU13. HCW just sits at Adding Federated Domain... status. I've cancelled and started over but still gets stuck here.
    Tuesday, November 15, 2016 7:12 PM
  • I changed the data and time format of the exchange server to the same UMT of O365.

    I canceled the wizard and ran it again. 



    Wednesday, January 4, 2017 2:21 PM
  • It seems like this issue is quite common and no official solution is provided yet.

    Here is what I've done, I'm sure it'll work for you, too.

    Download Microsoft Office Sign-In assistant and install.

    https://www.microsoft.com/en-us/download/details.aspx?id=41950

    Change the time zone to UTC

    Location to the United States, re-run HCW. and thank me next.

    • Proposed as answer by DHV655 Tuesday, June 27, 2017 7:34 PM
    Sunday, June 11, 2017 10:46 PM
  • This worked for me-- thank you Metahad Bolat.

    How stupid to have to change the timezone

    Omar


    ODroubi

    Tuesday, July 25, 2017 9:32 PM
  • Can confirm that this worked for me. I was having the same issue and followed Metehan Bolat's advice and it worked. Thanks Metehan.

    Brian Baldock | MCTS | MS | MCP

    Please note: This post is provided as is with no guarantee.

    Test, then test again.

    Thursday, September 21, 2017 6:08 PM
  • It seems like this issue is quite common and no official solution is provided yet.

    Here is what I've done, I'm sure it'll work for you, too.

    Download Microsoft Office Sign-In assistant and install.

    https://www.microsoft.com/en-us/download/details.aspx?id=41950

    Change the time zone to UTC

    Location to the United States, re-run HCW. and thank me next.

    Dear Metehan,

    I am getting same issue. CAn you please guide me where to change UTC zone. I have confirmed i am have canada UTC -8 onpermises. do i have to match this with office 365. I am using global admin which is not user mailbox on office365/


    Friday, October 6, 2017 7:25 PM
  • Same problem here :-(

    Already changed the time zone on the DC, Exchange server 2016 and Office 365 Tenant to UTC 0, however the issue persist.

    I heard that the are lots of people facing the same problem. The issue must be related with the O365 tenant... not sure :-(


    • Edited by MauricioRC Monday, October 9, 2017 10:38 PM
    Monday, October 9, 2017 10:37 PM
  • Same problem here :-(

    Already changed the time zone on the DC, Exchange server 2016 and Office 365 Tenant to UTC 0, however the issue persist.

    I heard that the are lots of people facing the same problem. The issue must be related with the O365 tenant... not sure :-(


    Are you running Exchange 2016 with cu7. If yes, are you able to run the command in Exchange shell on permies  Set-FederatedOrganizationIdentifier. if you get a response with An unexpected error has occurred and a Watson dump is being generated: Object reference not set to an instance. Then it is bug already checking my moderator. For further detail check below link

    https://social.technet.microsoft.com/Forums/en-US/3ac7cfe6-6c97-4f68-84b9-d498aafd4ea1/exchange-2016-cu6?forum=Exch2016Adm

    propose as answer for Bug posting. 

    Tuesday, October 10, 2017 5:34 AM
  • Same problem here on CU7.  I cannot complete the wizard even after multiple attempts.


    Thursday, October 12, 2017 7:16 PM
  • Hi,

    I have the same problem on 2016 server with exchange 2016 cu7.

    The support give a "SystemConfigurationTasks.Overrides.ini" file to put in c:\Program Files\Microsoft\Exchange Server\V15\Config. 

    Here is the content of the file, in case you want to recreate it:

    [SystemConfigurationTasks.settings.ini:FederationTrustFromCache]
    Enabled=False

    <u5:p></u5:p>

    • Proposed as answer by DCW77 Wednesday, October 18, 2017 11:29 AM
    Friday, October 13, 2017 1:28 PM
  • Awesome mate! This resolved it for me. Credit to you AloneInTheDark
    Wednesday, October 18, 2017 11:29 AM
  • This little INI file from AloneInTheDark saved my day. So that solved the issue on EX2016 CU7. 
    Tuesday, October 24, 2017 4:31 PM
  • Second the above.

    Made the ini file on the Exchange 2016 server then re-ran wizard and it worked great.

    Friday, October 27, 2017 8:56 AM
  • Triple the above! The ini file also worked for me. Tried the UTC and sign-on assistant options that worked for a previous version of Exchange 2016 but this time I had to do the ini file to get it working. Thanks AloneInTheDark.


    Brian Baldock | MCSA | MS | MCP Please note: This post is provided as is with no guarantee. Test, then test again

    Wednesday, November 8, 2017 2:21 AM
  • Worked with the .ini file workaround, but I did download the Sign-in assistant and changed the time for UTC before so I don't know if it's a combination of the 3 or just the .ini file.

    Setup: Exchange 2010 on-prem, introduced one Exchange 2016 CU7, full Hybrid setup.

    Wednesday, November 15, 2017 2:19 PM
  • That "config" directory doesn't exist in Exchange 2010.  Anyone know if it's possible to utilize this fix on an 2010 platform?  Would love to find a solution to getting this wizard to work correctly.  Been working with MS for days on it, and being escalated, probably just to find this same solution!
    Friday, November 17, 2017 11:14 PM
  • Same question here...

    How can this workaround be applied in Exchange 2010?

    ...an update would be welcome!!


    Guilherme Duarte

    Saturday, November 18, 2017 7:15 PM
  • Any more ideas if this doesn't work?

    Monday, November 20, 2017 3:41 PM
  • add another exchange box with old version. This will do a trick. 
    Thursday, November 23, 2017 5:49 PM
  • The ini file worked for me too. Also using 2016 cu7. Thanks.
    Friday, December 8, 2017 10:22 AM
  • Thank you. It worked for me as well.
    Friday, December 8, 2017 11:20 AM
  • Thanks for the fix!!

    Worked like a charm.  I never vote on these, but you saved me a lot of time, so I had to do it!!!

    Friday, December 22, 2017 6:24 PM
  • Micrsoft has fixed the issue in CU8. Cheers. 

    Friday, January 5, 2018 6:00 AM
  • No, they have not. I see the same issue in CU8.

    Vishal Bajpai MCP,MCSA,MCTS,CCNA,CCNP

    Thursday, January 11, 2018 3:54 PM
  • Found the solution here:

    https://medium.com/@hamza.hassoun/unable-to-configure-hybrid-with-exchange-2016-cu7-850a659a1780

    You have to create a .ini configuration file on Exchange Server to make it work.

    Worked like a charm.

    Wednesday, February 7, 2018 12:42 PM
  • It is still broken in exchange 2016 CU 10

    - they have not fixed this

    What happens in this case, the federation record is found, but the verify domain wizard fails and  set the status to "adding federated Domain".  the federated record is present, but for some reason this still fails.  The wizard locks on "adding federated domain"


    Matt Katzer, KAMIND IT | www.getoffice365now.com | www.kamind.net email: mkatzer@kamind.com

    Monday, December 17, 2018 4:36 AM
  • I am running exchange 2016 CU11 and experiencing the same issue, MS advised I remove all TXT records and leave the verification one but still no luck. I have tried the ini file fix and that doesnt work with CU11, also downloaded online sign in assistant and changed time to UTC but still no luck. I am out of options.

    Help anyone?

    Wednesday, February 6, 2019 9:24 AM
  • I'm in the same boat. Exchange 2016 CU10, have gone through multiple escalations in the help desk and tried everything in this thread with no luck. Seems like support is kind of stuck on this one (been working with them since mid January) - if I can get escalated to someone who knows what the issue is I'll post back here.
    Friday, February 8, 2019 5:11 PM
  • We were facing the same issue but the problem was caused by a proxy.

    The solution was to disable the IE proxy settings for the Local System; that is due to the fact, that the HCW runs as "Local System"

    To fix this you have to download a tool like PsExec which can run Internet Explorer under the context of “Local System”. Once you are running IE under the local system user simply disable the setting and save changes. Run the following cmd-let:

    psexec.exe -i -s -d “C:\Program Files\Internet Explorer\iexplore.exe” in CMD with administrative priviliges.

    Credits to https://thomasverwer.com/2015/06/19/hybrid-configuration-wizard-exceptionthe-remote-server-returned-an-error-407-proxy-authentication-required/

    Thursday, March 7, 2019 10:27 AM
  • Cheers AloneIntheDarK,

    This fixed it for me, note that this is still an issue on Exchange server 2013 CU21.

    Cheers,

    Tony


    This is the stickiest situation since Sticky the stick insect got stuck on a sticky bun.

    Tuesday, May 14, 2019 10:21 AM
  • Hello,

    it work for me with Exch 2016 CU7,

    thank you very much


    El Khiyati

    Monday, July 1, 2019 1:27 PM