none
S4B Server Configuration Client for iOS Application RRS feed

  • Question

  • Dear All,

    The S4B is working great when running in Windows, but can’t connect on iOS App. Internal & External Discovery Address already set on iOS App. Please note, it’s only on iOS App.
    Check image below:

    Config

    error

    Regards,
    Alu Ozy

    Wednesday, September 25, 2019 1:02 PM

All replies

  • Hi Alu Ozy,

    Does this problem happen recently? What do you do before  this issue appearing ?

    Do you sign in Skype for Business client with the same account to other devices?

    Does anyone else have the same issue?

    You could try to uninstall and reinstall the client. Make sure that you have updated to the latest version.

    If it doesn’t work, please navigate to General > Reset > Reset Network Settings for your Iphone. And try again.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, September 26, 2019 2:59 AM
    Moderator
  • Hi Sharon,

    This problem happen only on iOS Client. After installing, i setup the Internal & External Discovery Address like on Windows PC.

    And yes, using same account, also all account is worked on Windows PC.

    Why there is difference on iOS and Windows setup?

    On iOS Client there is HTTPS Internal & External Discovery Address setup like above image, but on Windows PC is not. I've tried setup into HTTP on iOS Client but still no luck.

    Below is setup from Windows PC:

    Any idea to fix this?

    Regards,
    Alu Ozy

    Thursday, September 26, 2019 11:11 AM
  • Hi Alu,

    Actually SFB mobile client manual configuration is different from desktop client, it shoule be like this:

    For external: "https://<ExtPoolFQDN>/Autodiscover/autodiscoverservice.svc/Root" 

    For internal:  "https://<IntPoolFQDN>/AutoDiscover/autodiscoverservice.svc/Root"

    Please refer to this article (also apply for SFB2015):

    https://docs.microsoft.com/en-us/lyncserver/lync-server-2013-defining-your-mobility-requirements?redirectedfrom=MSDN

    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, September 27, 2019 10:16 AM
    Moderator
  • Hi Shaw,

    I already setup on iOS Client, but still can't connect.

    https://s4b.contoso.com/AutoDiscover/autodiscoverservice.svc/Root - Internal
    https://s4b.contoso.com/Autodiscover/autodiscoverservice.svc/Root - External

    I've tried to Get-CsMcxConfiguration and here is the result:

    The ExposedWebURL default is External, should i to change into Internal?

    Regards,
    Alu Ozy

    Friday, September 27, 2019 10:53 AM
  • Any update?

    Regards,
    Alu Ozy

    Sunday, September 29, 2019 7:39 PM
  • Hi Alu,

    Did you deploy mobility in your environment?

    Lync Mobile clients are considered external users, users using a Lync Mobile client always connect through the corporate’s reverse proxy in the network perimeter to the UCWA service in the Lync external web site (listening to 8080/4443), even when users are connected to the corporate’s WiFi network. As below:


    Please refer to this article about mobility.

    https://docs.microsoft.com/en-us/skypeforbusiness/plan-your-deployment/mobility

    You should modify the external web service FQDN to be different from the internal Pool FQDN, and deploy a RP server to publish this external web site.

    Here is a reference about IIS ARR:

    https://techcommunity.microsoft.com/t5/Skype-for-Business-Blog/Using-IIS-ARR-as-a-Reverse-Proxy-for-Lync-Server-2013/ba-p/620912


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, September 30, 2019 3:08 AM
    Moderator
  • Hi Alu,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, October 4, 2019 5:21 AM
    Moderator
  • Hi Shaw,

    Before deploying mobility to environment, i want to make sure.

    How-to check the configuration for mobility is already deployed?

    Regards,
    Alu Ozy

    Tuesday, October 8, 2019 10:03 AM
  • Hi Alu Ozy,

    What is your IOS version? Recently, several user respond that they can’t sign in Skype for Business client after update to IOS 13.

    Once you've deployed Skype for Business Server Mobility Service and Skype for Business Server Autodiscover Service, you can run Test-CsUcwaConference to test the ability of two users to create, join and communicate in a conference. You will need two users (real or test) and their full credentials to do this testing.

    For more details, please refer to Deploy and Configure Mobility for Skype for Business Server.


    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, October 11, 2019 3:07 AM
    Moderator
  • Hi Sharon,

    My current iOS version is 13.1.3, and also can't signed in issue show up on Android.

    I got the result from command Test-CsUcwaConference:

    Regards,
    Alu Ozy

    • Edited by Alu Ozy Thursday, October 17, 2019 8:33 AM
    Thursday, October 17, 2019 8:32 AM
  • Hi Alu Ozy,
    According to the error message, it seems that you don’t enable test user in Skype for Business server.
    Please check it in Skype for Business Control Panel.

    Best Regards,
    Sharon Zhao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    8 hours 2 minutes ago
    Moderator