none
Not able to disable Lync 2013 autostart. RRS feed

  • Question

  • I ran into a strange problem with Lync 2013 in a customer environment. The Lync client automatic startup on login cannot be disabled, and I think I have checked all the possible reasons already..

    Deleting the HKCU\Software\Microsoft\Windows\Run\Lync registry key disables the autostart temporarily, and so does removing the autostart checkmark in Lync client options. However, on next restart of the Lync client it adds the registry key again. The registry key is added immediately when the Lync client is started, not sure if it happens when the client starts or when it signs in.

    All the usual suspects are of course ruled out already: There are no group policies that would touch the registry key, only Lync-related group policy setting is disabling the first run wizard of the client. As far as I know, the Lync server-side client policies shouldn't affect autostart behaviour either? And by the way, they should be in their default settings.

    Software version is Lync 2013 with February 2013 cumulative updates installed (and possibly with some newer updates, but at least Feb2013 CU level) and the workstation operating system is Windows 7.

    Any ideas? And yes, there are reasons to disable the autostart, related to 3rd party VOIP software which has to be started before Lync to reserve HID devices only to that program with HID device sharing disabled. Of course also ways to make Lync client totally ignore HID devices (handsets) would be welcome. :)

    Thursday, May 30, 2013 8:26 AM

All replies

  • Those have been tested already.. :(

    Like I said, all the usual suspects should be ruled out already. AutoRunWhenLogonToWindows does not seem to even exist in Lync 2013, or at least it doesn't do anything. In Lync 2010 that should work.

    When changing Lync options by removing the "Automatically start Lync when I log on to Windows" checkmark the client only seems to delete the HKCU\Software\Microsoft\Windows\Run\Lync registry key, according to Process Monitor.

    My own client in different domain does not have any problems disabling the autostart, it stays disabled when done either by deleting the registry key or unselecting the option. So do all the other Lync clients I have seen, except these ones in this one particular environment. :)

    By the way, roaming profiles are in use. Not sure if that would affect anything, probably not.

    Thursday, May 30, 2013 8:45 AM
  • Have you checked Group Policies or SCCM deployment packages? I've seen autostart registry settings being pushed with the Lync client deployment.
    Thursday, May 30, 2013 2:20 PM
  • Group policies are checked, like said. Only group policy setting which applies to Lync (also verified with gpresult) is the one that disables first-run wizard.

    The clients are deployed from SCCM 2007 R2, but the deployment is ran just once for a computer so it shouldn't affect this behavior in any way.

    The Run\Lync registry key is always recreated exactly at the time when the Lync client is starting and signing in.

    Thursday, May 30, 2013 2:24 PM
  • Have you tried disabling Lync in msconfig under startup? 
    Thursday, May 30, 2013 3:06 PM
  • I think yes. Have to confirm that, though.
    Thursday, May 30, 2013 3:17 PM
  • Hi,

    If the issue persists, please try the following registry key or reinstall Lync 2013 client to test it.

    HKCU:\Software\Microsoft\Office\15.0\Lync\AutoRunWhenLogonToWindows

    You can try to change the value of key to 0.


    Kent Huang
    TechNet Community Support

    Friday, May 31, 2013 2:21 AM
  • AutoRunWhenLogonToWindows was tested already, no change. I think the client doesn't even read that key.
    Friday, May 31, 2013 7:58 AM
  • Any update?
    Monday, June 17, 2013 1:48 PM
  • What about putting this one to 0?

    HKCU:\Software\Microsoft\Office\15.0\Lync\AutoOpenMainWindowWhenStartup

    Friday, March 21, 2014 2:47 PM
  • Umm.. How about reading the registry key name? :)

    That controls if the main Lync window pops up when the client starts, or if it starts minimized to the task bar. Has nothing to do with the client autostart.

    Friday, March 21, 2014 2:49 PM
  • Afraid I ain't got nothing to help you stnz, but just wanted to chime in to thank DavePintor for highlighting that registry key since it's exactly what I'm looking for today!
    Thursday, June 5, 2014 10:01 AM
  • Hi all,

    I know this is quite an old thread but there may be people who may have run into this issue with Skype for Business 2015/2016.

    Even I struggled with this issue of not being able to disable the auto-launching of Skype for Business on logon from within the installer itself. However I have managed to achieve what I wanted by using group policy preferences. Just add a registry key delete item entry to the group policy preference pointing to 'HKCU\Software\Microsoft\Windows\CurrentVersion\Run' for the key 'lync'. Whenever the policy gets refreshed either during logon or during GP refresh interval, it will remove the entry no matter how many times the users set the auto-llaunch through the GUI. Only downside is that if some users do need this auto-launch behaviour during start up then it will not let them to. But we were asked to disable auto-launch because Skype for Business launching before the user opens Outlook in many cases used to lock the outlook address book file causing Outlook to fail during launch. It was not a consistent issue but we had to make a call so as to have standard behaviour.

    Monday, November 30, 2015 9:24 AM
  • Hello Stnz,

    Please follow the below steps.

    open lync 2013->file->tools->Options->Personal.

    In My Account please untick Automatically start Lync when I log  on to Windows.


    Thanks, dashrath Chate 


    • Proposed as answer by Dashrath Chate Monday, November 30, 2015 9:33 AM
    • Unproposed as answer by stnz Monday, November 30, 2015 10:18 AM
    • Proposed as answer by Dashrath Chate Saturday, August 6, 2016 9:36 AM
    • Edited by Dashrath Chate Monday, April 23, 2018 9:07 AM
    Monday, November 30, 2015 9:32 AM
  • Dashrath,

    Configuring it from within Skype/Lync GUI is not the issue. The challenge was how to configure it in an automated fashion across the estate.

    Monday, November 30, 2015 9:40 AM