none
Can't enable Drive/Printer-Redirection RRS feed

  • Question

  • Hi there,

    I've setup 2008 R2 with Remote Desktop Services and want to enable Drive-Redirection so Users which use Remote-Apps can use their local drives. Unfortunately I cannot remove the mark at "RDP-Tcp Properties" > "Client Settings" and Drive, Printer etc is greyed out and clicking on the checkbox doesn't work. I found no Policy which may be responsible for this...

    Where do I have to enable Drive-Redirection?!

    Best Regards
    Miranda

    Monday, November 26, 2012 3:30 PM

Answers

  • Hi Miranda,

    There is a group policy that has disabled the redirections.  If you want to change the redirection options in RDP-Tcp properties you must first set the relevant GP settings to Not Configured.

    To determine which group policy object you need to edit you may run the following two commands from a command prompt:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    -TP

    Monday, November 26, 2012 4:49 PM
    Moderator

All replies

  • Hi Miranda,

    There is a group policy that has disabled the redirections.  If you want to change the redirection options in RDP-Tcp properties you must first set the relevant GP settings to Not Configured.

    To determine which group policy object you need to edit you may run the following two commands from a command prompt:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    -TP

    Monday, November 26, 2012 4:49 PM
    Moderator
  • they're all set to "not configured"...

    • Proposed as answer by mreilly6 Tuesday, November 27, 2012 9:22 PM
    • Unproposed as answer by mreilly6 Tuesday, November 27, 2012 9:23 PM
    • Proposed as answer by cbuxton1984 Friday, November 22, 2019 12:02 PM
    • Unproposed as answer by cbuxton1984 Friday, November 22, 2019 12:02 PM
    Tuesday, November 27, 2012 7:06 AM
  • Hi Miranda,

    To determine which group policy object you need to edit you may run the following two commands from an administrator command prompt:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    Please post the contents of your gpresult.txt file.  It will tell you which GPO needs to be edited (obviously it is not the local policy, since you checked that).

    Thanks.

    -TP

    Tuesday, November 27, 2012 9:08 AM
    Moderator
  • Hi Miranda,

    Tp is right on. Just created the same Domain level gpo myself the other week. Open command prompt and perform an RSOP.msc. Look under computer configuration, administrative templates, windows components, remote desktop services, device and resource redirection I bet you will find a domain level gpo like me that is enabled for do not allow drive redirection.

    Tuesday, November 27, 2012 9:39 PM
  • Hi Miranda,

    As TP noted above,you need to find out which GPO has been applied to use the device and resource redirection on the RDSH.If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

    Regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Thursday, November 29, 2012 9:19 AM
    Moderator
  • Had the same problem and just stumbled across this.

    NLA also needed to be enabled otherwise Drive redirect would always be disabled regardless of the above setting.

    Friday, November 22, 2019 12:03 PM