none
Give me updates for other microsoft updates is greyed out.

    Question

  • I have a single windows Server 2016 that has been upgraded from Server 2012 R2 I have noticed that I am unable to enable Microsoft update.

    We have no group policies changing the settings and currently we don not utilise SCCM or WSUS so it should be default. Has anyone experienced this at all or even better has a resolution?


    MCP, MCTS, MCITP, MCITPVA, MCSA 2012, MCSE Private Cloud, MCSE Server Infrastructure

    Monday, December 19, 2016 12:41 PM

Answers

  • Hi Sigdarkside,

    1. Please check if this computer is included in any GPO OU, maybe there is a legacy setting for the original server 2012R2;

    2. Please check registry key HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate, if there s sub key "AU", then, delete the "AU" (remember to backup the registry key before deleting), then, check if you can select "Give me other updates for Microsoft Update".

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Sigdarkside Tuesday, December 20, 2016 9:26 AM
    Tuesday, December 20, 2016 8:28 AM
    Moderator

All replies

  • Hi Sigdarkside,

    i had the same issue as well, in my case it was group policy (i still didn't find which). try moving the server to "computers" group or to an OU without a group policy, restart the server and it should be available.

    hope this helps,

    Sean

    Monday, December 19, 2016 1:16 PM
  • Hello Sean, 

    This was tried with a different OU however I did move it to the computers one as a just in case but again the option is still greyed out. 

    Chris


    MCP, MCTS, MCITP, MCITPVA, MCSA 2012, MCSE Private Cloud, MCSE Server Infrastructure

    Monday, December 19, 2016 1:57 PM
  • Hi Sigdarkside,

    1. Please check if this computer is included in any GPO OU, maybe there is a legacy setting for the original server 2012R2;

    2. Please check registry key HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate, if there s sub key "AU", then, delete the "AU" (remember to backup the registry key before deleting), then, check if you can select "Give me other updates for Microsoft Update".

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Sigdarkside Tuesday, December 20, 2016 9:26 AM
    Tuesday, December 20, 2016 8:28 AM
    Moderator
  • Hello Anne,

    Thank you that did indeed work.

    It seems to only effect in place upgrades from Server 2012R2

    Regards

    Chris


    MCP, MCTS, MCITP, MCITPVA, MCSA 2012, MCSE Private Cloud, MCSE Server Infrastructure

    Tuesday, December 20, 2016 9:35 AM
  • NoAutoRebootWithLoggedOnUsers is the only AU branch key (0). Why would this apply to a Workgroup pro version?

    Michael


    • Edited by M Leary Thursday, September 13, 2018 3:15 AM spell check
    Thursday, September 13, 2018 3:15 AM