none
Regedit key to turn off dial tone RRS feed

  • Question

  • I have a client that uses the Jabra9300 with Lync.

    She has all her sounds come out of that device. When she want to hear something off the internet she hears dial tone from Lync. When she then closes lync she hears nothing. I am looking to turn of the dialtone that lync provides to the headset.

    Monday, March 21, 2011 9:29 PM

Answers

  • When the device is “Optimized for Lync” and it is high-end, such as Bluetooth, it is meant primarily for Lync i.e. telephone usage. The idea is to be activated only during a phone/conference call and shutdown after completion. How long the battery would last if the user uses it as regular headphones all day?

    Unless this is your CEO, don’t bother J

    There is, however, a workaround. Make sure you set this device as “Default Playback Device” in Windows. In this case, the user will be able to use it as would use speakers for example, and when answer call (or make one), Windows sound will be suppressed until the conversation is disconnected.

     

    Drago


    http://ocsdude.blogspot.com
    Thursday, March 24, 2011 9:43 PM

All replies

  • Dear Michy,

    Please try this way:

    In your Lync client click "tools">"options">"ringtones and sounds">change your work number ringtone as "None".

    Then click ok to save and try again.

    Hope it could help you.

    Best Regards!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 22, 2011 5:53 AM
    Moderator
  • Jidan, I am taliking about dial tone not Ring tone
    Tuesday, March 22, 2011 6:50 PM
  • Sorry for misunderstanding you.

    You said the dial tone will come out. What I want to know is at that time did you dail with Lync or just listening something else?

    Regards!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, March 23, 2011 6:11 AM
    Moderator
  • The employee would be listening to something else, using her headset. Once you pick up the headset, It opens Lync and you get dial tone. If you close Lync all sound goes away.
    Wednesday, March 23, 2011 10:27 PM
  • Micky

    You are mixing simple USB device (USB sound card, USB headset) and device “Optimized for Microsoft Lync”. While the first group does not interact with Lync client until the number is dialed and ring back tone is generated, the second is designed as sole Lync Device if desktop client is present. In this case the built in integration takes precedence.

     

    Drago


    http://ocsdude.blogspot.com
    Wednesday, March 23, 2011 11:00 PM
  • Hi Drago,

    I just want to verify what you are saying:

    because the device is not optomized (approved) for Lync it will not work properly?

    The device works fine for Lync, you can pick up calls using only the headset device.

    The problem happens only when the employees wants to listen to some other Sounds like Music or Video. When the employee pushs the button to hear it open Lync and they hear dialtone. This was the case with OCSR2 also. Although in OCSr2 you could diable this via a regedit. Is there something like that avaialble for Lync?

    Micky

    Thursday, March 24, 2011 9:18 PM
  • When the device is “Optimized for Lync” and it is high-end, such as Bluetooth, it is meant primarily for Lync i.e. telephone usage. The idea is to be activated only during a phone/conference call and shutdown after completion. How long the battery would last if the user uses it as regular headphones all day?

    Unless this is your CEO, don’t bother J

    There is, however, a workaround. Make sure you set this device as “Default Playback Device” in Windows. In this case, the user will be able to use it as would use speakers for example, and when answer call (or make one), Windows sound will be suppressed until the conversation is disconnected.

     

    Drago


    http://ocsdude.blogspot.com
    Thursday, March 24, 2011 9:43 PM
  • I ran into the same problem today, but the other solutions here did not help.  For some reason Lync is going out of it's way to generate this tone.  I found the best way to deal with this problem is to do the following:

    1. Open Sound under Control Panel, and Select the "Sound" tab.

    2. Scroll down until your find "Dial Tone" under Lync and change the associated sound to "None".

     

    • Proposed as answer by s.m.c Wednesday, November 2, 2011 6:12 PM
    Wednesday, November 2, 2011 6:11 PM
  • This does not work.  Although it suppresses the dial tone, Linc still tries to create a call.  Once the timer expires, it shuts off the headset's feature to look for a computer generate sound (video etc.).  To be clear, I am using a headset with dual inputs, one from the phone and the other from the computer.  I can switch the input signal by pushing a button.  When I activate the headset and select computer, the dial tone from Linc rings.  Even if you cancel the dial tone, once it completes trying to make a call, it switches the input to phone and cancels any computer generated sounds.
    • Edited by RobertFa Wednesday, June 6, 2012 2:49 PM
    Wednesday, June 6, 2012 2:42 PM
  • I have a similar problem; I run Lync concurrently with Skype and a softphone (Bria).  When any non-Lync program uses the headset, Lync pops in and starts playing dial tone.  If you go into Jabra Control Center -> Softphone and set it to "None" this problem goes away, at the expense of being able to answer calls via the headset button.
    Thursday, June 7, 2012 12:39 AM
  • I am having the exact same problem. I have a Sennheiser Head set. Both linked to the Phone and the Computer.  Before when not on the phone I could just click over to the Computer and listen to music. But now because of the new upgrade, I only recieve the dial tone, (over the music) and then once the call is not placed, the busy signal, then it cuts off my head set. Not allowing me to listen to my music at all.

    Friday, June 8, 2012 10:30 PM
  • We have also Lync and Jabra Wireless Headsets and problem with the RINGTONE from Secound Call in the Headset.

    We Disabled the Ringtone in Lync and uncheckt the Button "Enable ringtone in headset" in the Jabra Software. So only the Base from the Jabra rings.  This works fine for the first Call, but when we get a secound Call during a phone conversation  the Headset Rings also. This is for my user very irritation.

    Is it possible to disable the Ringtone in the HEadset of the new second Call also.

    Thanks


    _______________________________ Robert Schneeberger Infotech EDV Systeme GmbG. (MS Gold Partner)

    Tuesday, July 24, 2012 3:35 PM
  • We found the resolution to disable the the Secound Rington on the Headset in the Windows Sound Settings.

    In the Soundschema at Microsoft Lync disabled the Checkbox for Secound incomming Call.


    _______________________________ Robert Schneeberger Infotech EDV Systeme GmbG. (MS Gold Partner)

    Thursday, July 26, 2012 11:01 AM
  • Hi,

    The way to be able to use your headset withhout pop-up any aplications and generate dial tone, is to disable the HID-compatible device diver for your headset.

    disable HID driver

    1. Go to Computer/Properties Device Manager and set view to Devices by connection.
    2. Find the USB composit device which correnponds to your headset.
    3. Under the USB Input Device node disable the HID-compatible device.
    4. You may need to press a button on your headset to turn on the wireless channel to connect to the base station.

    But please note, if you use your wireless headset with other applications too, e.g. listening music, you might not have enough remaining battery power when you need to place a Lync call!

    I don't know why, but for me the disabled device gets enabled after a while. If you have the same probelm you might just use this tool with scheduling:

    http://dl.dropbox.com/u/5352623/devcon-7600.16385.win7_wdk.100208-1538-x64.zip

    Some samples for the Jabra GN9350e:
    devcon hwids *9350*
    devcon hwids "HID\VID_0B0E&PID_9350&REV_0201&MI_03"

    devcon status "HID\VID_0B0E&PID_9350&REV_0201&MI_03"
    devcon enable "HID\VID_0B0E&PID_9350&REV_0201&MI_03"
    devcon disable "HID\VID_0B0E&PID_9350&REV_0201&MI_03"



    • Edited by Attila_HUN Thursday, July 26, 2012 2:12 PM
    • Proposed as answer by JDContributor Wednesday, August 21, 2013 12:23 AM
    Thursday, July 26, 2012 11:25 AM
  • hoping that this will be picked up by the search engines, as i spent some hours on this topic now as well:

    With a Jambra Headset, the dialing tone also appears as overlay to other sounds (skype, OCS, etc.) when Lync is running. For Jambra (9450) it works to install the jambra suite, right click the tray icon and select "open communication link". Then you can use other 3rd party applications next to Lync without this annoying dial-tone / hang-up-after-30-sec scenario.

    Wednesday, August 21, 2013 12:49 PM
  • I received news from Sennheiser product support that there was a firmware upgrade to address this.  I have a DW Pro 2 and the latest firmware, 114, appears to have fixed a similar issue.  More information on a separate thread on the Sennheiser headset and Lync working together.
    Wednesday, March 12, 2014 9:35 PM
  • Yep, definitely work for me (Lync 2013 and Sennheiser HD Pro 2). Thank you!
    Friday, June 27, 2014 9:30 PM
  • THANK YOU!!! This solved my problem.  I appreciate your post so much.
    Friday, July 11, 2014 5:13 AM
  • And then I also set the sound "Howler" under Lync to "None" so the terrible phone off the hook sound doesn't blare either after a bit.
    Friday, July 11, 2014 5:45 AM
  • @ Attilla

    Excellent save.  As usual the community rises to the occasion where the developer offers no solution (off button in Lync anyone?). 

    Tuesday, February 17, 2015 6:47 PM
  • I have found a solution to this problem. This is a registry edit that disables audio / video telephony within the lync client regardless of your head set.  The result of this edit will remove any audio / video settings. Inbound audio / video call notifications will not be received. I use my desk phone for audio communication and this was a huge frustration when i wanted to use my head set for computer sound.

    To disable telephony the following registry key needs to be added:

    Open command promp and paste exactly what i have below:

    Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\15.0\Lync" /V "TelephonyMode" /D 5 /T REG_DWORD /F

    ----------------------------------------------------------

    (After, Also add to the HKEY_CURRENT_USER edit)

    ----------------------------------------------------------------------------------

    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\15.0\Lync" /V "TelephonyMode" /D 5 /T REG_DWORD /F

    After you enter both of the above keys into the command line you should see below "The operation completed successfully"

    Close lync, re launch and you will not hear a dial tone when switching head set to computer sounds.

    FYI this works with windows 7 - 64 bit running Microsoft Office 2013. Have not tested with previous versions.



    Tuesday, April 14, 2015 6:40 PM
  • Many thanks Attila, 3 years later this still seems to be plaguing people!<o:p></o:p>

    You solution worked for me on Win 7 64bit to sort an issue where Lync kept butting in uninvited with its annoying dial tone and then even more annoying howler. <o:p></o:p>

    In my case it took a bit of digging to work out where the HID-Compliant device was. Can't seem to post a screen shot but I found it under "Human Interface Devices". I only disabled HID-compliant device, I did not touch the one called "HID-compliant consumer control device"<o:p></o:p>

    Tuesday, November 24, 2015 12:21 PM
  • Had the same issue with Skype for Business and a Jambra headset. Uninstalled Lync 2013 (not sure why it was still there) and problem went away.
    Wednesday, January 27, 2016 2:40 PM
  • Hey, thank you very much. This solution just work fine for me
    Wednesday, March 9, 2016 11:42 AM
  • setting the dial tone sound to none in windows control panel solved the issue for me in win10, office2016 skype for business with a plantronics savi 740 wireless headset - the base connects to devices via bluetooth, usb and also a conventional telephone, and i can switch between the 3 using buttons on the base.  when i would press the button to activate the usb/pc interface, i would get a dialtone, which is especially annoying when trying to answer a phone call coming in via avaya onex communicator.  yes, we do lync/s4b calls now and then, but the majority come thru the avaya switchboard so it needs priority over lync.  i have the plantronics device set up as the default communications device in win10 itself, and the laptop headphone jack set up as the default audio device.  then i also set the plantronics as the default device in avaya onexc and lync/s4b since those are the only 2 apps that i want to use the headset with.  everything else should go through my desktop speakers, plugged into the laptop headphone jack.

    why the hell does lync/s4b insist on making a dialtone anyway?  when i click the USB/computer button on the base, s4b doesn't show any popups like a dialpad or anything, so until i found this thread, i had no idea at all that the sound was being generated by lync.  i was about ready to throw the headset out the window when it turns out the headset was working exactly as designed, but lync/s4b was being stupid.  god forbid anyone ever use any other communications apps that weren't made by microsoft... or *GASP* use MORE THAN ONE communication app!  

    on a lighter note, several weeks ago my wife and i were joking that our kids would never know what a dialtone or a busy signal are because nobody ever hears them anymore.  there's no dialtone on a cell phone, and everyone has voice mail now, so you never get a busy signal either.  we haven't had a land line since before we were married, and don't plan to get one either.  


    • Edited by Gibson99 Thursday, July 28, 2016 9:42 PM
    Thursday, July 28, 2016 9:41 PM
  • Having the same problem with Plantronics Savi W440.  We don't use Lync for outbound/inbound calling (we have Jabber for that), yet S4B insists on playing a dial tone when the headset starts up.

    I've tried shutting down the Skype for Business client which shuts off the dial tone but keeps the connection to the headset open.  

    Have given some of the config options a go here, hope they fix this, so irritating.

    Monday, November 14, 2016 1:16 PM
  • Hi Elii,

    We have Jabra Evolve 30 II with Jabra Xpress installed. Correntlywe have Cisco IP Communicator and the Lync working side by side.

    My user's are also facing this same problem. Can you advice. Please.

    Tuesday, February 20, 2018 6:05 AM
  • 7 years on and this is still an issue with no fix. The only thing that I have found to work when I connect my Plantronics Savi 7xx is to start some other audio application and play audio, like spotify, then connecting the headset. Then I can close the audio application and everything works the way it should. If I don't have any audio already playing Skype for Business gives me a dialtone. 
    Wednesday, May 30, 2018 9:39 PM
  • I have a Plantronics, not a Jabra, but just switched to a new laptop with Windows 10, and had this problem.  None of the suggestions here made worked.  Skype for Business just refused to cooperate.

    Finally I installed Plantronics Hub software, which I hadn't done on this laptop yet, and the option was there in the software, and in fact defaulted the Dial Tone setting to "Off".  As soon as the software was installed it corrected the issue.


    Thursday, October 25, 2018 6:26 PM
  • Correct , I upgrade the firmware on my Sennheiser product to version 155 and corrected the problem,
    Friday, December 7, 2018 3:12 PM
  • I have found a solution to this problem. This is a registry edit that disables audio / video telephony within the lync client regardless of your head set.  The result of this edit will remove any audio / video settings. Inbound audio / video call notifications will not be received. I use my desk phone for audio communication and this was a huge frustration when i wanted to use my head set for computer sound.

    To disable telephony the following registry key needs to be added:

    Open command promp and paste exactly what i have below:

    Reg Add "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\15.0\Lync" /V "TelephonyMode" /D 5 /T REG_DWORD /F

    ----------------------------------------------------------

    (After, Also add to the HKEY_CURRENT_USER edit)

    ----------------------------------------------------------------------------------

    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\15.0\Lync" /V "TelephonyMode" /D 5 /T REG_DWORD /F

    After you enter both of the above keys into the command line you should see below "The operation completed successfully"

    Close lync, re launch and you will not hear a dial tone when switching head set to computer sounds.

    FYI this works with windows 7 - 64 bit running Microsoft Office 2013. Have not tested with previous versions.



    Uh, this will also disable voice and video calls.  TelephonyMode settings:

    0: PC to PC Calls only (default)
    1: Enterprise Voice
    2: Remote Call Control
    3: Enterprise Voice with PBX Integration
    4: RCC but PC to PC disabled
    5: IM & Presence Only

    Friday, January 4, 2019 2:14 PM