locked
DisableServerCheck for Mac Lync Client RRS feed

  • Question

  • Hi!

    Is it possible to disable the server check feature on Mac Lync? I would like to use the Lync Client with a OCS 2007 R2 server.

    I know this is not supported by Microsoft, intended as temporary solution :)

    Friday, December 9, 2011 10:36 AM

Answers

  • Hi,

    it cannot be disabled. you have to use the Communicator for MAC if you need to work with the COS 2007 R2.


    Thamara. MCTS, MCITP Ent Admin, Specialized in U.C Voice OCS 2007 R2
    Saturday, December 10, 2011 3:51 AM

All replies

  • Hi,

    it cannot be disabled. you have to use the Communicator for MAC if you need to work with the COS 2007 R2.


    Thamara. MCTS, MCITP Ent Admin, Specialized in U.C Voice OCS 2007 R2
    Saturday, December 10, 2011 3:51 AM
  • Hi Christian,

    Yes, it is. I got it to work after some trial and error.

     

    Basically, the equivalent to the registry keys for windows needs to be entered in the Lync config plist file on the mac, a file named MicrosoftLyncRegistrationDB.xxx.plist that you can find in ~/Library/Preferences/ByHost.

    In it, you will need to create an entry for each segment of the reg key path for the DisableServerCheck flag (all lower case). It should look like this:

    hkey_current_user\

    hkey_current_user\software\

    hkey_current_user\software\policies\

    hkey_current_user\software\policies\microsoft\

    hkey_current_user\software\policies\microsoft\communicator\

    hkey_current_user\software\policies\microsoft\communicator\disableservercheck

     

    The value for each of the path segments is "<<MacRegNoValue>>" and type string. For the disableservercheck flag, the type is "Number" and the value is 1.

     

    You can use a plist editor (there's a few free ones for the mac, or you can also use Xcode) to edit the plist file. The screenshot below shows you how it should look like.

     

    Good luck!

     

     



    Wednesday, January 25, 2012 7:08 AM
  • As Eurico Costa describes it is also possible to use the disableservercheck setting in Lync 2011.
    Thursday, January 26, 2012 10:57 AM
  • Eurico awesome stuff thanks.

    For me it worked great for about 90 seconds and then kicked me out and now it says its unable to log me in and to verify my credentials BUT if I close Lync and run up Communicator its fine first time.

    Any thoughts would be much appreciated.


    Friday, September 7, 2012 10:32 PM
  • Hi Jamesbeck,

    That's really odd. I haven't seen that behavior at all in normal circumstances. Do you have both communicator and Lync 2011 installed in the same mac? I'm working if both at doing anything to this file or locking it. 

    I have had issues before up to SP2 for Office and Lync where the behavior you described was occurring when I was connected to the VPN. Outside of the VPN, I was able to connect without any issues. Try to update your office and lync installation with the latest SPs and MS updates, make sure only one of the clients is running at any given time, and let me know if that helps.

    Sorry I can't be more help on this one.

    Regards,

    Eurico

    Saturday, December 22, 2012 12:59 AM
  • I had a behaviour similar with the one described by Eurico, in my case, after running the plist file, I was able to login, once, for less then 10 seconds.

    https://gist.github.com/ssbarnea/56af4dd2df45e5617a8c

    Lync version I used is 14.0.5 (even if you see the logs with 14.0.1…)

    Did anyone had any success?

    Tuesday, August 27, 2013 3:36 PM
  • I now have this very same problem. it worked for about 35 seconds and I wan able to chat with work team members and now it wont sign in telling me to check my login credentials
    Tuesday, September 17, 2013 4:19 PM