none
Decipher DPM Crash Files RRS feed

  • Question

  • I'm regularly getting Crash files in the temp directory of my DPM 2012 SP1 installation, however I'm not sure why or how I can understand what they are saying.

    I open them in Notepad and everything is confusing to me.  Could anyone help?  Is this a major problem?  It sounds and looks pretty terrible.

    ProcessId ThreadId Date Time ComponentCode FileName(FileLine) This TaskId Level TraceMessage
    11A8 2198 12/01 10:34:57.711 09 Catalog.cs(1765)   WARNING Attempt 7 failed with exception System.InvalidOperationException: Timeout expired.  The timeout period elapsed prior to obtaining a connection from the pool.  This may have occurred because all pooled connections were in use and max pool size was reached.
    11A8 2198 12/01 10:34:57.711 09 Catalog.cs(1765)   WARNING    at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
    11A8 2198 12/01 10:34:57.711 09 Catalog.cs(1765)   WARNING    at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
    11A8 2198 12/01 10:34:57.711 09 Catalog.cs(1765)   WARNING    at System.Data.SqlClient.SqlConnection.Open()
    11A8 2198 12/01 10:34:57.711 09 Catalog.cs(1765)   WARNING    at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlContext.Open()

    Monday, December 2, 2013 7:01 PM

Answers

  • Hi,

    This is a known issue in DPM 2012 Sp1 - use the below workaround until a formal fix is released.

    Update the following registry keys @ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\DB

    ConnectionString
    GlobalDbConnectionString

    SAMPLE Original Value:

    Integrated Security=SSPI;Initial Catalog=DPMDB;Application name=MSDPM;server=DPM_SERVER\MSDPM2012;Connect Timeout=90

    Changed to:

    Integrated Security=SSPI;Initial Catalog=DPMDB;Application Name=MSDPM;server=DPM_SERVER\MSDPM2012;Connect Timeout=90;Max Pool Size=400

    Reboot the DPM Server. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, December 3, 2013 12:57 AM
    Moderator

All replies

  • Hi,

    This is a known issue in DPM 2012 Sp1 - use the below workaround until a formal fix is released.

    Update the following registry keys @ HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\DB

    ConnectionString
    GlobalDbConnectionString

    SAMPLE Original Value:

    Integrated Security=SSPI;Initial Catalog=DPMDB;Application name=MSDPM;server=DPM_SERVER\MSDPM2012;Connect Timeout=90

    Changed to:

    Integrated Security=SSPI;Initial Catalog=DPMDB;Application Name=MSDPM;server=DPM_SERVER\MSDPM2012;Connect Timeout=90;Max Pool Size=400

    Reboot the DPM Server. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, December 3, 2013 12:57 AM
    Moderator
  • Excellent!  We'll pursue implementing this.  Thank you.
    Tuesday, December 3, 2013 8:02 PM
  • Another question, would you know if this issue has been resolved in DPM 2012 R2?
    Wednesday, December 4, 2013 1:55 PM
  • Hi,

    Yes, DPM 2012 R2 has the same issue due to the timing of the discovery of the problem in SP1.  Both are scheduled to be fixed in their next respective rollup fixes.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Wednesday, December 4, 2013 3:45 PM
    Moderator