none
Stop Lynx from autostart on reboot RRS feed

  • Question

  • msconfig -> Startup always has a new entry for "Microsoft Lync 2010". I uncheck it. Reboot. A new one appears again with a checkmark (along with the old one I unchecked earlier). How can I stop it from adding itself?

    msconfig says it adds itself to

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

    but deleting the registry entry is the same as unchecking it in msconfig and won't prevent it from adding itself back.

    I already checked (thanks to http://social.msdn.microsoft.com/Forums/en-US/ucmanagedsdk/thread/4c903d83-0271-4907-8099-0660d0f40dc2/):

    HKCU\Software\Microsoft\Communicator\AutoRunWhenLogonToWindows

    which is 0. And AutoRunWhenLogonToWindows is 0. Thanks.
    Sunday, October 30, 2011 8:52 PM

All replies

  • Hi,

    In communicator, options, have you uncheck "Automatically start Lync when i log in to windows" option?

    Thamara.

    Monday, October 31, 2011 2:05 AM
  • I should have said that. Yes, I unchecked it. It was the first thing I tried.

    I'm losing the battle against it. The annoyance is that if I uncheck Microsoft Lync in msconfig -> Startup, then I re-launch Lync, I'll get a popup "Please wait while Windows configures Microsoft Lync 2010". After it's done, a new entry is added to msconfig -> Startup with a checkmark. To avoid this silly configure step, I have to leave Lync checked in msconfig.


    • Edited by yong321 Monday, October 31, 2011 3:48 PM
    Monday, October 31, 2011 3:09 PM
  • may i ask is there ay perticular reason that you won't want to run the Lync Client on startup? is it that you do not wish to automatically sign in to the client or you want to remove it to improve startup performence?

    Thamara.

    Monday, October 31, 2011 3:25 PM
  • I just don't want to automatically start it. It's used to communicate with my company coworkers only. When I bootup my laptop at home, I may only browse the Internet for personal fun. Generally, I don't want to see any non-essential programs listed in msconfig -> Startup.
    Monday, October 31, 2011 3:53 PM
  • check below link. there are some tips that you can get the thing done

    http://tomtomic.wordpress.com/2011/05/10/lync-2010-communicator-exe-fromrunkey/

    Thamara.

    Monday, October 31, 2011 4:16 PM
  • Hi,yong321,

    Please try the solutions in the link Thamara post above.

    Also please check if there is any GPO setting or other administrative tool in your orgnization to control Lync autostart just in case even if I don't think it can be controlled by group policy without customizing.

    Regards,

    Sharon

    Tuesday, November 1, 2011 9:03 AM
    Moderator
  • Thank you. I don't have Webex installed. Searched everywhere in Program Files and registry and Control Panel and services.msc. I don't have Communicator under HKLM\Software\Microsoft\Windows\CurrentVersion\Run. But adding PreventRun with value 1 to HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator indeed prevents it from running. The problem is that when I do want to run it, it won't launch. So the requirement it not *auto* run when bootup or user logon is still not met.

    But thanks to every one. I can live with auto-start. On this Windows 7 laptop, I'm prompted Do you want to allow such and such program to make changes?, and I just need to say No. Later when I want to run Communicator, I'm prompted again and I say Yes.

    Now I remember something. Since I don't like it to minimize to the taskbar, I followed somebody's suggestion to run it in Windows XP compatibility mode. Now even if MinimizeWindowToNotificationArea (under HKCU\Software\Microsoft\Communicator\) is still default 0, it minimizes to a tiny icon at the lower right corner. My version is Lync 2010 Version 4.0.7577.314. It doesn't have the checkbox to control this behavior as seen at http://blogs.technet.com/b/csps/archive/2011/06/15/regminimizetonotificationarea.aspx

    Wednesday, November 2, 2011 3:20 PM
  • Found this old thread I started more than a year ago. Something I want to add:

    The best way I find to deal with this rogue behavior of Lync is to only change the program path in msconfig. Under Startup - Communicator, the Command is .../communicator.exe" /fromrunkey. I change the executable to something non-existing (specifically "communicatorq.exe" just because "q" is the easiest to access key on my keyboard). What a rogue solution you may say!

    Monday, February 25, 2013 4:14 AM
  • We've found that the RTM version of the Lync 2010 client does not exhibit this behavior.  It starts to happen when you apply updates to the Lync client.
    Thursday, May 16, 2013 5:55 PM