locked
RemoteApp Notification Area Icons not visable RRS feed

  • Question

  • Hi all

     

    Quick question, we are using RDS to deliver some remoteapps to our customers. However the application uses the Notification Area Icon  as a shortcut to important commands and is needed for the user to navigate different modules of the application.

     

    The notification icon works in a normal deskotp install but fails to pass through via remoteapp.

    under Control Panel\All Control Panel Items\Notification Area Icons the app icon is showing up  <app name >(remote) and is set to always show  icon / notification

     

    any ideas ?

     

     

    Monday, November 14, 2011 10:39 PM

Answers

  • Hi,

     

    According to your description, I understand that you are using RDS to deliver some RemoteApps to your customers , and one if its features includes displaying a notification in the Taskbar’s notification area.  This worked well for you in general(normal desktop), but when publishing this applications as a Remote App on Windows Server 2008 the notification icon would not show up.

     

    This is because the icon was set from a COM object and not directly from the published application.  Notification icons in general are implemented by and depend on Explorer running.  In the Remote App case, Explorer doesn’t run; however, the Remote App system provides a replacement shell (“rdpshell”) which can handle Explorer’s side of the notification icon conversation and proxy the communication to the client system.  Rdpshell does not in general show all notification icons, but only the icons created either by the published application or by other processes launched by the published app.

     

    Since your application sets its notification icon from an out of proc COM server.  Since the COM server isn’t launched from the published app rdpshell does not publish the icon to the client system.

     

    The reason that rdpshell only pushes icons set by the published app and its descendants is that in many cases other applications (for example several anti-virus programs) run automatically in the published app’s session, even if they aren’t themselves published.  Depending on how the session is set up, standard Windows icons may also be shown.  Displaying notification icons created by these automatic applications in the remote session would cause undesired confusion.

     

    It is possible to turn off this behavior and tell rdpshell to reflect all notification icons.  This is not supported and will likely change in the future as a better way to allow specific processes to be published however they are launched is created.

     

    For now though, the administrator can set the following registry key to cause all icons to reflect:

    Key = (HKLM/HKCU) SYSTEM\\CurrentControlSet\\Control\\Terminal Server; ValueName = RailShowAllNotifyIcons; type reg_dword; value = 1

     

    Applications should never set this key, as it will affect other applications as well.  It should only be used by the system administrator after determining that the specific system isn’t running any applications that this will cause problems with.  Since you are running your own servers to host your app, you can set this in the role as the server administrator.

     

    Hope this helps.

     


    Technology changes life……
    Wednesday, November 16, 2011 9:55 AM
  • Hi

     

    i have made the change on my test RDS Host and indeed it did publish all the icons .... but still not the applacation icon !  i have spoken to the software developers and they know it is a bug in there software when used with RemoteApp.

     

    May look at useing App-v :)

     

    Thanks

     

     

     

    Thursday, November 24, 2011 6:06 PM

All replies

  • Hi,

     

    According to your description, I understand that you are using RDS to deliver some RemoteApps to your customers , and one if its features includes displaying a notification in the Taskbar’s notification area.  This worked well for you in general(normal desktop), but when publishing this applications as a Remote App on Windows Server 2008 the notification icon would not show up.

     

    This is because the icon was set from a COM object and not directly from the published application.  Notification icons in general are implemented by and depend on Explorer running.  In the Remote App case, Explorer doesn’t run; however, the Remote App system provides a replacement shell (“rdpshell”) which can handle Explorer’s side of the notification icon conversation and proxy the communication to the client system.  Rdpshell does not in general show all notification icons, but only the icons created either by the published application or by other processes launched by the published app.

     

    Since your application sets its notification icon from an out of proc COM server.  Since the COM server isn’t launched from the published app rdpshell does not publish the icon to the client system.

     

    The reason that rdpshell only pushes icons set by the published app and its descendants is that in many cases other applications (for example several anti-virus programs) run automatically in the published app’s session, even if they aren’t themselves published.  Depending on how the session is set up, standard Windows icons may also be shown.  Displaying notification icons created by these automatic applications in the remote session would cause undesired confusion.

     

    It is possible to turn off this behavior and tell rdpshell to reflect all notification icons.  This is not supported and will likely change in the future as a better way to allow specific processes to be published however they are launched is created.

     

    For now though, the administrator can set the following registry key to cause all icons to reflect:

    Key = (HKLM/HKCU) SYSTEM\\CurrentControlSet\\Control\\Terminal Server; ValueName = RailShowAllNotifyIcons; type reg_dword; value = 1

     

    Applications should never set this key, as it will affect other applications as well.  It should only be used by the system administrator after determining that the specific system isn’t running any applications that this will cause problems with.  Since you are running your own servers to host your app, you can set this in the role as the server administrator.

     

    Hope this helps.

     


    Technology changes life……
    Wednesday, November 16, 2011 9:55 AM
  • Hi there

     

    Thanks for your reply. I will do some testing on our non production RDS hosts to see how changing the reg key will effect the system and application. I will post back tommorow with some feedback.

     

    thanks :)   

    Wednesday, November 16, 2011 7:28 PM
  • Hi

     

    i have made the change on my test RDS Host and indeed it did publish all the icons .... but still not the applacation icon !  i have spoken to the software developers and they know it is a bug in there software when used with RemoteApp.

     

    May look at useing App-v :)

     

    Thanks

     

     

     

    Thursday, November 24, 2011 6:06 PM
  • Hi, 

    I'm using Windows Server 2016 and facing the same issue. By adding the registry key it did fix the issue but it shows icons for all unwanted applications as well. Are there any ways that we can only show the icon of a particular application?

    Is there any c# code source where could programmatically dictate "<g class="gr_ gr_555 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="555" id="555">rdpshell</g>" to show our application's icon?

    Sunday, June 18, 2017 11:16 AM