none
LYNC 2013 generating Full Address book files but not the delta ones

    Question

  • Dear Experts,

    I have noticed after I installed a new LYNC 2013 pool that the SQL share for address book is only showing F-xxxx for full downloads of address book but I am not seeing the D-xxx delta files which is causing my client not to receive the GALContactDelta file.

    This new pool is an enterprise LYNC 2013 and I am currently testing to move from LYNC 2010. I have only one Address Book configuration policy and I did not create any new policy for the new pool/site. Any suggestions where to check the cause is appreciated.

    Regards,

    A. Zaher


    A. Zaher

    Sunday, May 26, 2013 2:52 AM

All replies

  • Hi,

    If the address book contains over 50K entries, the client maintains a separate delta database GalContactsDelta.db and index GalContactsDelta.db.idx for GAL contacts, and periodically merges updates into its main database GalContacts.db.

    http://technet.microsoft.com/en-us/library/ee323492(v=office.13).aspx

    Thanks,


    Simon Wu
    TechNet Community Support

    Monday, May 27, 2013 6:04 AM
    Moderator
  • Hi Simon,

    Thanks for reply. I have more than 120K users. What I am missing is from server side and it's the Delta for the Full files. If you go back to the link you sent, I am not seeing Delta of F1, delta of F2,... I am looking for a configuration which I may be missing to tell the server (abserver) to generate delta files for the full address book as you know changes keep happening in the AD.

    Regards,

    A. Zaher


    A. Zaher

    Monday, May 27, 2013 9:57 PM
  • I have this same problem right now with no delta updates being created causing 404 errors on the client. Did you get to the bottom of it?

    Thanks...

    Matt

    Tuesday, November 12, 2013 9:54 AM
  • Update for those who care:

    I have set the MaxDeltaFileSizePercentage to 100 using Set-CsAddressBookConfiguration. When I next ran Update-CsAddressBook it created the delta files. The delta files as you'd expect are the same size as a full .lsabs file. It still doesn't seem to be creating delta .dabs files but this isn't a massive issue for me as we don't use LPE.

    I am awaiting word from Premier Support is this is something fixed in a future update or not. 

    Matt

    • Proposed as answer by ellismessaging Thursday, December 12, 2013 3:08 PM
    Monday, November 25, 2013 4:17 PM
  • Premier Support have confirmed this is a known issue and is being investigated by the Lync PG. No word on an ETA yet though.

    Matt

    • Proposed as answer by ellismessaging Thursday, December 12, 2013 3:08 PM
    Thursday, December 12, 2013 3:08 PM
  • Any new here? We have the same issue.
    Monday, March 3, 2014 7:27 AM
  • Hello Matt,

    We had the same problem and applied the same solution (threshold at 100%).

    Now, did you try to reduce the threshold back to 20% to see if deltas continue to be created ?

    Thanks,

    Luca

    Tuesday, April 8, 2014 6:33 AM
  • Good news! We have the same issue in our large environment, and Microsoft Support has, after weeks of testing, told us that it is an issue that should be solved in the next Cumulative Update, this month or the next (June/July 2014)

    All the stuff we tried, and the results we got, in case you're tempted to try various workarounds: http://insideactiveroles.com/2014/06/04/lync-server-2013-address-book-deltas-not-being-produced-but-a-fix-is-coming/

    Main warning: if you still have people on OCS clients or have not set AddressBookAvailability in all your ClientPolicys to WebSearchOnly, do NOT raise the MaxDeltaFileSizePercentage unless you're ready for all your users' clients to download a file twice the size of the F-xxxx.lsabs files the next time they log in!

    Wednesday, June 4, 2014 11:59 AM
  • Yep apply the August 2014 updates and this sorts out this problem for large address books...

    Cheers

    Darren

    Thursday, August 7, 2014 7:22 AM
  • The August 2014 Cumulative Update fixes this, but it will take the full cycle (30 days) before all deltas exist. This is because any full address books generated before the update is applied are still flawed, and the delta between one of them and a new, "good" full address book have the same problems as before.

    More detailed explanation: http://insideactiveroles.com/2014/09/05/august-2014-lync-server-2013-cu-address-book-delta/

    Friday, September 12, 2014 7:55 AM