none
No ringtone for incoming calls RRS feed

  • Question

  • Hi! I have a problem similar to others in here, but not exactly the same.

    The setup is as follows:

    PSTN SIP TRUNK --> Cisco Call Manager Express 8 --> Lync Mediation

    Everything works perfectly except for incoming calls, which get no "ring tone". When i answer the call its perfect, and outgoing calls have "ring tone".

    When talking to the PSTN they say that we are sending 183 Progress with SDP before 180 Ringing. They are expecting sound (ring tone) from us, but don't recieve any.

    Anything i could do on the Lync side?

    Users that are pure Cisco have "ring tone" when people are calling them, but not users on Lync.

    Thanks in advance

    BR Henrik


    Microsoft Certified Master | Exchange Server 2010
    Wednesday, August 17, 2011 8:15 AM

Answers

  • Maybe something wrong with Cisco CallManager. This article gives some solution about the question, hoping it can help you.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 18, 2011 1:46 AM
    Moderator
  • I solved it now with: voice-class sip block 183 sdp present on the dial-peer. Found that info on cisco.com. It was alot easier to search around when i understood it was called "Ringback" :-)

    Thanks all of you for the help.


    Microsoft Certified Master | Exchange Server 2010
    Friday, August 19, 2011 7:44 PM

All replies

  • Do you mean that lync client and Cisco Phone donot give ringtone when a incoming call from PSTN, but you can see the incoming call prompt?

    Can you hear the ringtone in the internal calls?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 17, 2011 9:38 AM
    Moderator
  • Sorry for the confusion. What i mean with "ring tone" is for the person who is calling from outside. For example, if you call me on my Lync phone, you wouldnt hear the "ring tone" in your phone. But if you call one of the Cisco users you will hear a "ring tone" in your phone.

    Thanks for your answer.


    Microsoft Certified Master | Exchange Server 2010
    Wednesday, August 17, 2011 11:29 AM
  • Maybe something wrong with Cisco CallManager. This article gives some solution about the question, hoping it can help you.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 18, 2011 1:46 AM
    Moderator
  • You need to enable early media in your cisco call manager.  From sip-ua configuration mode run no disable-early-media 180.  This will allow the cisco system to play the ring tone to the incoming caller.

    Friday, August 19, 2011 7:07 PM
  • Thank you "jyoungjr", but that was a little confusing. If i look at my running config, there is no "disable-early-media 180" so a "no disable-early-media 180" wouldnt do any effect? I tried anyway, and also tried "disable-early-media 180" and then "no disable-early-media 180", but no change at all.

    This is my dial peer:

    dial-peer voice 750 voip
     tone ringback alert-no-PI
     description ** LYNC **
     translation-profile incoming SE-PSTN-Inbound
     destination-pattern 8..
     session protocol sipv2
     session target ipv4:X.X.X.X:5060
     session transport tcp
     dtmf-relay rtp-nte
     codec g711alaw
     fax-relay ecm disable
     fax protocol none
     no vad


    Microsoft Certified Master | Exchange Server 2010
    Friday, August 19, 2011 7:38 PM
  • I solved it now with: voice-class sip block 183 sdp present on the dial-peer. Found that info on cisco.com. It was alot easier to search around when i understood it was called "Ringback" :-)

    Thanks all of you for the help.


    Microsoft Certified Master | Exchange Server 2010
    Friday, August 19, 2011 7:44 PM
  • You can find and install many quality mobile ringtones here: https://ringtonesmobile.net/


    • Edited by juilia Tuesday, June 12, 2018 7:29 AM https://ringtonesmobile.net/
    Sunday, June 10, 2018 7:54 PM