RDWEB IE11 Browser not supported RRS feed

  • Question

  • I have 2008R2 with RDS. I have a couple Apps on it, and almost everything is fine, except that IE11 users are getting this error:

    Browser Not Supported

                This Web browser is not supported by RD Web Access. RD Web Access requires Internet "Explorer 6.0 or later.           

                You can download the latest version of Internet Explorer from the Windows Update Web site. "

    IE 11 is certainly later than 6.0.

    I am not seeing anything in the forums, is there a work-around on either the server or client side?



    Monday, August 19, 2013 7:18 PM


All replies

  • hit f12 and select ie9 or lower to run. You can force the browser to run in compatibility mode


    Monday, August 19, 2013 7:20 PM
  • Thanks Darren.

    Its funny, I had already put the site in the 'Compatibility view settings' and it locked up IE.

    But, adding it while the dev tools is open, works great, no lockup. I did have to change it to IE9 to see the ICON's of the applications though.

    Thank you


    Monday, August 19, 2013 7:28 PM
  • Or you can put a workaround in at the server level. http://www.blackforce.co.uk/2013/10/24/rds-2008-browser-not-supported-ie10-ie11 This will make it work for all users with no manual comparability mode required.
    • Proposed as answer by Citizen 1982 Tuesday, November 19, 2013 3:08 PM
    Thursday, October 24, 2013 9:28 PM
  • Thanks Dale, your solution worked immediately and for everyone accessing the site.
    Tuesday, November 19, 2013 3:15 PM
  • Sir, you are a genius.  Thank you so much for providing this informative fix for MS Intentional Crippled RDWeb Gateway Server 2008"

    It is pathetic that MS does not fix their own stuff to work with IE10 and IE11. Using the F12 Option is nutso, because it does not remember the setting and you have to hit it every time. 

    • Edited by RickkeeC Monday, March 24, 2014 9:19 PM edit
    Tuesday, January 7, 2014 7:42 PM
  • I don't think M$ intentionally crippled RDWeb, I think it's just a dumb programming bug. In the javascript code for the rdweb pages (renderscripts.js) the onPageload function is parsing the useragent string and only looking for 1 character. IE 10 and 11 come back as "1", so when they check if its <=6 it returns true and errors out.

    Its an easy fix with changing the string function. When this was written I dont think anyone thought IE would be > then 10 any time soon.

    Wednesday, January 22, 2014 9:34 PM
  • Thanks.  This worked for me as well.
    Monday, March 24, 2014 8:32 PM
  • Well, I think around Y2K, this would have been at the top of everyone's mind.  Because now, in 2014 this is essentially the same kind of problem.  Gollygosh, we never thought IE would go past 9.....
    (I am kind of surprised it did too... however fairly certain V.11 will be the death of IE.  Unfortunately, most users want to be the race car driver, not the mechanic so fussing with the 'strings' ain't gonna happen, the will just load Chrome or Firefox and it will just work.

    "Its an easy fix with changing the string function. When this was written I dont think anyone thought IE would be > then 10 any time soon."

    Monday, March 24, 2014 9:39 PM
  • Add your Rd web site to Intranet zone in Security of Options of IE11. For me, it works fine.
    • Edited by oliver1 Tuesday, April 1, 2014 12:35 AM
    • Proposed as answer by Ronald Hine Tuesday, November 10, 2015 2:43 AM
    Tuesday, April 1, 2014 12:34 AM
  • This is still an issue. Teh blackforce.co.uk link solved it also on my RDWeb Servers!
    Wednesday, August 20, 2014 1:59 PM
  • Was trying to access it using Edge, got that error, then tried IE11 got the same error. Moving it into the Intranet Zone worked.

    Tuesday, November 10, 2015 2:43 AM