HyperV or backup Daemons on CentOS 7 RRS feed

  • Question

  • Hi All,

    I have a CentOS 7 (Core) VM running on a Windows 2016 HyperV cluster.

    We have a daily full VM backup at the hyperV cluster level scheduled for this VM which works ok most of the time.

    Every now and then it VM level backup fails with a snapshot error. The workaround at the moment is to restart the CentOS VM .

    After the restart the backup will work for sometime and then fail again. The failure interval is not fixed.

    As we have to restart the VM everytime to resolve the backup failure, this causes an application outage.

    I want to check if its possible to avoid the VM reboot in anyway.

    Is there a way to reboot the hyperV or backup Daemons within the CentOS VM with actually rebooting the server?

    For example the SSH daemon can be restarted by systemctl stop/start sshd

    The version details of the VM are listed below, any help in this matter would be greatly appreciated!

    Virtualization: microsoft
      Operating System: CentOS Linux 7 (Core)
           CPE OS Name: cpe:/o:centos:centos:7
                Kernel: Linux 3.10.0-327.28.3.el7.x86_64
          Architecture: x86-64

    Tuesday, June 16, 2020 11:18 AM

All replies

  • The LIS daemon name for handling backups/snapshots has the name hypervvssd or hv_vss_daemon.

    I would also recommend you to install the latest LIS version, which will give you also the latest VSS daemon.

    When the backup fails, you should check the messages log for any entries from the vss daemon with the above names.

    • Proposed as answer by Chris Valean Thursday, June 18, 2020 8:11 AM
    Tuesday, June 16, 2020 1:08 PM
  • Hi Chris!

    Thanks for your response.

    I see 3 hyperv processes running which i have grep below.

    [admin@centos ~]$ ps -ef | grep hyper
    root       611     1  0 Jun17 ?        00:00:00 /usr/sbin/hypervfcopyd -n
    root       626     1  0 Jun17 ?        00:00:00 /usr/sbin/hypervkvpd -n
    root       629     1  0 Jun17 ?        00:00:00 /usr/sbin/hypervvssd -n

    I restarted all 3 of these , however this did not resolve my issue of the VM backup failure.

    The var messages log also does not have anything relevant to vss or backup. In my case it only had the entries related to the restart of the hyperV daemons. I attempted a backup of the VM but there was absolutely nothing in the var related to a backup.

    I also tried live migrating the VM to antoher node in the cluster, but that did not help. 

    I then rebooted the VM which resolved the issue, but the reboot is something i dont want to do.

    With regards to installing the LIS Daemon, this VM is a customised lockdown build of centos. The vendor of the VM does not allow any updates to be installed which I am unable to install the latest lis version.

    Is there any way to check the current version of LIS on CentOS?

    Also, is there any other log file on the VM which could point me in the direction as to why the backup is failing?

    many thanks!

    Thursday, June 18, 2020 8:35 AM
  • If you haven't installed LIS from Microsoft, then you are using what redhat backported, so the version is not that important in your case.

    the messages log would include any errors from the hypervvssd daemon.

    have you tried to disable/enable the backup integration service for the vm and see if that helps?

    also, what is the exact error you get when it fails to backup the vm?

    Thursday, June 18, 2020 8:48 AM