locked
Microsoft edge is blocking Google RRS feed

  • Question

  • Hello Microsoft,

    today i got a new laptop and i was busy setting everything up until i encountered a problem.

    i wanted to install google chrome (no offense) and for some reason i keep getting errors wich says that google cant be trusted and sort of thing. i tried it on Internet Explorer but it has the same problem. has this something to do with mcafee wich was already installed or is this something else. i would like to know real quick because tommorrow i am going to my new school and i need my laptop.

    also i like google more then bing but google is totally blocked. i cant even see my mail.

    HELP!!!!

    Wednesday, January 20, 2016 4:32 PM

Answers

  • This sounds like either McAfee is causing the issue or you may have something malicious on your machine causing this. I have seen behavior similar to this with malware / spyware on the machine. Edge is definitely not the cause of this.

    I would try a 3rd party virus removal tool such as Malwarebytes Anti-Malware. The free version will let you do a scan on demand. You can download it from here: https://www.malwarebytes.org/products/

    Check the logs of McAfee and make sure that isn't the culprit.

    Side note, you can choose your default search engine in Edge. Browse to www.google.com. Click the  ... button on the top of Edge -> Settings -> Scroll down to and click View advanced settings -> 1/2 way down find where it says "Search in the address bar with" click Change and you should now see "Google Search (discovered) listed. Click Set as default.

    • Proposed as answer by Onatam Wednesday, January 20, 2016 8:11 PM
    • Marked as answer by Karen Hu Tuesday, February 2, 2016 9:29 AM
    Wednesday, January 20, 2016 8:11 PM

All replies

  • MM

    Probably McAfee, as edge does not block anything.  It may also relate to a new feature in win 10 called signed driver enforcement which is a security feature that prevent you from downloading unsigned (and possibly dangerous) software.

    If you downloaded it directly from Google that should not happen except if McAfee blocked it


    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Wednesday, January 20, 2016 5:32 PM
  • This sounds like either McAfee is causing the issue or you may have something malicious on your machine causing this. I have seen behavior similar to this with malware / spyware on the machine. Edge is definitely not the cause of this.

    I would try a 3rd party virus removal tool such as Malwarebytes Anti-Malware. The free version will let you do a scan on demand. You can download it from here: https://www.malwarebytes.org/products/

    Check the logs of McAfee and make sure that isn't the culprit.

    Side note, you can choose your default search engine in Edge. Browse to www.google.com. Click the  ... button on the top of Edge -> Settings -> Scroll down to and click View advanced settings -> 1/2 way down find where it says "Search in the address bar with" click Change and you should now see "Google Search (discovered) listed. Click Set as default.

    • Proposed as answer by Onatam Wednesday, January 20, 2016 8:11 PM
    • Marked as answer by Karen Hu Tuesday, February 2, 2016 9:29 AM
    Wednesday, January 20, 2016 8:11 PM
  • Hi MennoM,

    How about the issue, is there anything to update?

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, February 1, 2016 1:17 AM
  • Are you a Microsoft fanboy?

    The only antivirus on my machine is Defender, which comes with Windows 10. I cannot get to any Google site regardless of the top level domain I try it on.

    I have over 30 years in Information Technology so I am pretty darn sure I don't have malware. Besides no othr browser on this computer is blocking those sites.

    Tuesday, February 7, 2017 4:25 AM
  • I am having the same issue here. All Google URL's are not resolving in Edge but work in all other browsers.

    Wednesday, February 8, 2017 8:38 PM
  • This is really strange, because I have the same issue. And even stranger, when I was at work today, where we also use Windows 10, it worked fine...
    Monday, February 13, 2017 11:25 AM
  • All Google URL's are not resolving in Edge

    Try it in  InPrivate Browsing mode?  Also, you could experiment with  SSL 3.0 instead of TLS 1.2. 


    Robert Aldwinckle
    ---

    Tuesday, February 14, 2017 1:07 AM
  • All Google URL's are not resolving in Edge

    Try it in  InPrivate Browsing mode?  Also, you could experiment with  SSL 3.0 instead of TLS 1.2. 


    Robert Aldwinckle
    ---

    InPrivate works. But SSL 3.0 made no difference.
    Tuesday, February 14, 2017 7:06 AM
  • InPrivate works. But SSL 3.0 made no difference.

    In fact, apparently SSL 3.0 may be going the wrong direction.  I found a video which explains some of the vulnerabilities associated with it, and mentioned an exploit called FireSheep which targets other users' Cookies.

    Here's some more

    https://jimshaver.net/2015/01/10/4-years-later-what-did-we-learn-from-firesheep-and-sslstrip/
    (BING search for
        ssl cookies firesheep
    )

    So, are you starting your requests with HTTP or HTTPS?  Maybe that explains why the Incognito approach is working?  Note that in Edge in order to see what you have you need to press Alt-d.

    Elsewhere another thing I have pointed out is that all nslookup that I have seen for Google are IPv6 preferred.  Are you getting IPv6 and does it work?  FWIW on my system that would have to mean that Teredo was working but it doesn't.  In fact, I don't think even ISATAP is working locally on my system which is why I had to switch to a more modern router last year after W10 kept getting worse and worse for local IPv6 support.  In any case, if I was getting the IPv6 lookup I am sure I would see exactly the same symptom that you show above.  Who knows, maybe it is enough of a delay for people who do try to use the IPv6 address that the whole initial request is deemed to have taken too long and then you get a (sufficiently vague) message which indicates that too.  Related to this I have long wondered if the other browsers actually use the same DNS client that IE does.

    So, I think people need to diagnose whatever is happening to them.  Edge's symptom just means "something's wrong" and provides absolutely no clues about what that is.



    Robert Aldwinckle
    ---

    Tuesday, February 14, 2017 6:28 PM
  • Thank you for the reply.

    I have tried it with http:// but it redirects to https:// directly and fails to load.

    But on a different note - I've tried Internet Explorer, and it doesn't work as well.

    The thing is, I haven't changed my router or network settings, and it worked perfectly until last week.

    I don't have IPv6 connectivity (neither at home or at work), according to the connection details.

    Wednesday, February 15, 2017 9:01 AM
  • I have the same issue. Firefox works fine but nothing Google on Edge. Just have Defender antivirus. About to ditch Edge which I have liked up till now.
    Friday, February 17, 2017 11:26 PM
  • Yes, I am having the same issue, after have just done a pc reset, so I know for a fact that there is no malware and have no antivirus running right now. I also work in the IT industry, so again, know what I am doing. MS are frankly rather rubbish right now.
    Friday, March 10, 2017 9:06 PM