none
Cloud Connector Edition - PSTN to Skype for Business Online RRS feed

  • Question

  • I'm working on setting up CCE with our SBC and I can now place calls from Skype for Business online, but when I try and place calls to skype for business online it fails.

    I'm seeing this invite sent and I don't know what I'm missing.  The Mediation server doesn't pick up and I feel like I must be missing something basic.  I have modified numbers and domains with *'s

    >>> Info: sipfw:  recv from 127.0.0.1:5060 via 127.0.0.1:5060 UDP connection 285:
       
      INVITE sip:7202@192.168.140.2 SIP/2.0
      Via: SIP/2.0/UDP 127.0.0.1:5060;branch=z9hG4bKf38de029ef5bff34feab485b03046550
     10 DIGIT To: <sip:+*******7202@192.168.141.11;transport=tcp>
      From: "WIRELESS CALLER" <sip:******0726@PROVIDER.com>;tag=0b7e7e5e
      Call-ID: 706d031c9ac4ed6fc07fddea7d369119@sipgt-04443a26
      CSeq: 1 INVITE
     
      Route: <sip:127.0.0.1:5060;lr;incoming;b2bua-aid=trunk2.0>
      Contact: <sip:trunk2.0@127.0.0.1>
      Supported: timer, replaces, path, histinfo, 100rel
      Allow: ACK, CANCEL, BYE, INFO, INVITE, NOTIFY, OPTIONS, PRACK, REFER, UPDATE
      Max-Forwards: 16
      X-Nt-Corr-Id: bba7c1f3-226d-486a-8946-6a20d11027bb
      X-Nt-Location: -1
      P-Charging-Vector: icid-value=bba7c1f3-226d-486a-8946-6a20d11027bb;icid-generated-at=10.99.8.221
      Content-Type: application/sdp
      Content-Length: 379
       
      v=0
      o=trunk2.0 102 944834880 IN IP4 192.168.140.1
      s=sip call
      c=IN IP4 192.168.140.1
      t=0 0
      m=audio 59472 RTP/SAVP 0 101
      a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:f10wIaxRfEzoVAcWbzJBMPsicDAU04hLKmNGBGjh
      a=crypto:2 AES_CM_128_HMAC_SHA1_32 inline:NseV6Ttiphj3DJH/UY2QVelWn1cmZCnXHrSEJpdc
      a=rtpmap:0 PCMU/8000
      a=rtpmap:101 telephone-event/8000
      a=fmtp:101 0-15
      a=ptime:20

    Thursday, August 10, 2017 7:29 PM

Answers

  • Hi boosd87, the called number is same as the tel uri assigned to the user ?

    Set-CsUser -Identity "<User name>" -EnterpriseVoiceEnabled $true -HostedVoiceMail $true -OnPremLineURI <tel:+phonenumber>

    • Marked as answer by boosd87 Monday, August 14, 2017 9:25 PM
    Saturday, August 12, 2017 9:46 PM

All replies

  • 192.168.141.11 is the mediation server. 192.168.140.1 is the provider, 192.168.140.2 is the SBC provider side of the provider connection, 172.30.16.33 is the LAN side of the SBC, with network connectivity to 192.168.141.11 confirmed.
    Thursday, August 10, 2017 7:48 PM
  • Thursday, August 10, 2017 7:51 PM
  • I have an allow Any Any in both directions rule from my SBC to the mediation server.
    Thursday, August 10, 2017 8:02 PM
  • Is there anywhere that I can see why the mediation server is rejecting the connection? Is there a log somewhere? I've logged into the SBC server and there are errors when I disconnect the SBC, they disappear when it's reconnected, but that seems to be mediation > SBC, nothing about SBC > mediation as far as logs are concerned.
    Thursday, August 10, 2017 9:38 PM
  • Hi boosd87,

    According your description, do you see any Event log errors in the mediation server?

    Also do you deploy “media bypass in Cloud Connector Edition”?

    I suggest that you could review the prerequisites, you could refer to the following link:

    Plan for Skype for Business Cloud Connector Edition:

    https://technet.microsoft.com/en-us/library/mt605227.aspx?f=255&MSPPError=-2147217396

     

    Thanks for your understanding and patience!


    Shaw Lu
    TechNet Community Support


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 11, 2017 10:23 AM
  • I've made more progress, but now the mediation server is saying the phone profile was not found.  I updated to 2.0.1 and at the end it said this 

    "WARNING: Network configuration has not been set for this tenant." I'm not sure if the two are related.

    I have been through the prepare guide multiple times, verified ports are open correctly, verified the machines are up, the SBC says it is connected to the mediation server, no errors in the log files or edge or mediation server VMs.

    In the section below - should it be @domain.com instead of medserver.cce1.local? I'm not sure how the to: is supposed to look when going from cloud connector to CloudPBX.

    To: <sip:***********@MedServer.CCE1.local:5068;transport=tcp;user=phone>;tag=25e0ebf585;epid=3F97FE22BD

    SIP/2.0 400 The specified phone profile was not found. 
    Call-Id: 0dbb7384-d0d4-4de7-b455-2e238eb35284
    Content-Length: 0
    Cseq: 28450414 INVITE
    From: "WIRELESS CALLER"<sip:*********@DOMAIN.COM>;tag=a25e3208-e1b2-4406-bd97-4a985b510fe3
    Server: RTCC/6.0.0.0 CCE-MediationServer
    To: <sip:***********@MedServer.CCE1.local:5068;transport=tcp;user=phone>;tag=25e0ebf585;epid=3F97FE22BD
    Via: SIP/2.0/TCP 192.168.141.2:49872;branch=z9hG4bK6d3be4d4-d06f-41d4-a3fd-e8f083b9a2a5

    Saturday, August 12, 2017 1:27 PM
  • Hi boosd87, the called number is same as the tel uri assigned to the user ?

    Set-CsUser -Identity "<User name>" -EnterpriseVoiceEnabled $true -HostedVoiceMail $true -OnPremLineURI <tel:+phonenumber>

    • Marked as answer by boosd87 Monday, August 14, 2017 9:25 PM
    Saturday, August 12, 2017 9:46 PM
  • It's working now, I was missing a + in front of the number in the set-csuser command, it's working properly now.
    Monday, August 14, 2017 9:25 PM
  • Hi

    I am installing SfB Cloud Connector and I observed that Mediation is not listed as Next Hop for the Edge Server in the Topology builder. Please let me know if this is an issue as I am able to place calls to and from SfB.

    Friday, September 22, 2017 3:26 PM