none
No audio in calls with specific audio device

    Question

  • I recently bought a Razer Kraken 7.1 headset which has a USB connector.
    It works with all other programs such as Skype, to make phone calls. I can hear people and they can hear me, no problems.

    But when I call anyone in Lync 2013, they can hear me, but I can't hear them.

    I made sure my headset is set as default, and that Lync actually finds my Audio device, which it does.
    When I try to play sound in Audio Device options on the Lync client, it plays them and I can hear them without problem.

    But in calls, they can hear me, but I can't hear them.

    Now, if I change the device settings to use customized settings, everything stops working, meaning I can't hear them, they can't hear me.

    I've tried this on a PC at work which has Lync 2013 on Windows 7 (32bit), and on a PC at home which is running on Windows 8 (64bit), same problem percists.

    Please help me :)

    Wednesday, October 09, 2013 6:39 PM

Answers

  • Thanks but nothing works.

    I contacted Razer Support (Headset manufacturer) they advised me to send back my headset as they think it's broken. 

    They say that there shouldn't be any problems with using their products with Lync.

    Thanks for your help guys, I hope this replacement will do the trick :)
    • Marked as answer by Kent-Huang Monday, October 21, 2013 12:29 PM
    Sunday, October 13, 2013 8:25 AM

All replies

  • Hello,

     Please take Client UCCAPI log file and provide me your email address I will connect back with you to collect the logs and see whats going on.

    We will have to connect the Headset and re-pro issue before Collecting logs

    Wednesday, October 09, 2013 7:14 PM
  • Keep in mind it is not a supported Headset for Lync.

    If you put the speaker on you're PC speakers in the settings of the lync client can you then hear people. are the settings correct in the lync client.

    Wednesday, October 09, 2013 7:29 PM
  • Hi Joost.
    Right so if I enable the speakers on my laptop, and make a call. It works fine. It's still using the Mic on my headset since it's still enabled, and the person on the other side of the call hears me fine.

    But when I turn on the headset and set it as default, the sound from the caller disappears (note: only from the caller, other windows sounds/music works fine).

    Works:
    prntscr,com/1wamr0 (, = .)

    All Audio works, except from people in lync calls:

    prntscr,com/1wan1z (, = .)

    Lync settings: (Note that it finds the audio device, and I can test the sound with the play sound button, I can not hear anything when doing a test call though)

    prntscr,com/1wan8t (, = .)

    (Sorry for the non-linkable, my account has to be verified.)

    Wednesday, October 09, 2013 7:50 PM
  • Hi,

    It is highly recommended to use certified audio and video devices that that are optimized for Microsoft Lync:

    http://technet.microsoft.com/en-us/lync/gg278173

    You can also try to run Clean Boot to disable all non-Microsoft services for testing.

    How to Clean Boot:

    http://support.microsoft.com/kb/929135


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Thursday, October 10, 2013 3:24 AM
  • Thanks but nothing works.

    I contacted Razer Support (Headset manufacturer) they advised me to send back my headset as they think it's broken. 

    They say that there shouldn't be any problems with using their products with Lync.

    Thanks for your help guys, I hope this replacement will do the trick :)
    • Marked as answer by Kent-Huang Monday, October 21, 2013 12:29 PM
    Sunday, October 13, 2013 8:25 AM
  • I also had the exact same problem. Windows 8.1. I tried various things but nothing seemed to work. I finally stumbled onto a solution. In Sound, I made sure the my Kraken 7.1 was set as the default communications device, and the default microphone. Under the speaker icon in Lync made sure the sound was turned up and that the sound was turned up on the speaker icon in windows. Also, if your using Razer Synapse, make sure you headset isn't muted in that app and that the sound is turned on. Then i rebooted. Lync now works fine. 
    Thursday, June 05, 2014 9:50 PM
  • Wow so happy to see this post.

    I thought i was going crazy. I have the exact same issue as you describe with my Razer Kraken 7.1 headset for Lync 2013. I have been using this headset successfully for months on both my Win7 and Win8.1 laptops and it was only until recently that Lync stopped working for receiving audio on calls (they can hear me and mic works fine. I can even hear tones and rings np).

    It was working fine just a few weeks ago. i have scoured every setting trying to find the Lync specific issue. Every test i have run on the headset shows its working fine. All drivers are up-to-date. Headset has been uninstalled and re-installed with the same results. All Kraken calibration tests show its working properly. Skype does not have any issue either. I do not believe that both of our headsets are damaged since they are not working properly for only Lync 2013. 

    Were there any recent Lync updates released within the last 45 days?

    Thursday, July 10, 2014 10:42 PM
  • Same issue here. It was working fine until 2 days ago now nothing. I don't understand why Lync would need specific hardware.
    Thursday, September 25, 2014 1:34 PM
  • This is unresolved still or did the replacement work? This issue was left hanging.
    Monday, October 20, 2014 1:01 PM
  • Same issue here. MS does not specifically list USB headsets that are "certified" so there is no way of knowing what works and doesn't. Every headset I've used however works except this one. Why would Lync need specific CONSUMER USB headsets in order to work?

    Monday, October 20, 2014 1:11 PM
  • This did not work for me.
    Tuesday, November 11, 2014 5:05 PM
  • This appears to be one of those problems which neither Microsoft Nor Razer gives a Rat's behind. I've written Razer and they just claim to not know anything about it, even though they have received probably hundreds of complaints. Microsoft will NEVER care about it if it involves someone elses hardware.

    Today I'm going to return my Razer headsets and try to find one that will work. I notice most of the headsets in microsofts list of acceptable ones kind of SUCK. Anyway I'm giving up hope with these two companies resolving the issue. I don't think the issue is big enough for them, they just figure, screw the Gamer who wants to use Lync.

    Who knows what drives their decision to ignore a problem.

    Tuesday, November 11, 2014 5:08 PM
  • EDIT

    Posted a workaround earlier today but just found the root cause which I would imagine all of you are experiencing. I found that I had Office 2013 32 bit installed on my Windows 8.1 64 bit OS. Apparently the Lync 32 bit software will not see 64 bit registered USB audio devices (theorizing) however as soon as I uninstalled the software and installed the 64 bit version amazing magic happened and all is well! Hope this little bit of sunshine helps you all!!

    -Jexel


    • Edited by Jexel' Wednesday, January 21, 2015 8:56 AM
    • Proposed as answer by Jexel' Wednesday, January 21, 2015 8:57 AM
    Monday, January 19, 2015 4:17 PM
  • Confirmed this worked for me:

    I uninstalled Office 2010 32 bit, Uninstalled Lync 2013 32 bit, Installed Lync 2013 64 bit, tested it was working and it was then reinstalled office 2010 32 bit (my work does not allow 64 bit office) and now all working.

    You can't just install 64 bit Lync if you have office 2010 32bit installed. Defo an issue with 32 bit lync.

    Monday, February 09, 2015 10:22 AM