Lync 2010 Installation fails at create central management store


  • Hi

    I am trying to install Lync 2010 on a Server 2008R2 machine for testing before we deploy it in anger. 

    I have a small issue which seems to be holding the install up when publishing the topology. The error is "Creating Central management store failure"

    SQL has been installed, by the installer, and the instance rtc exists. I have uninstalled the instance and got the installer to recreate it to no avail.

    I get the errors from the log DBExixts-Central management store server.domain ..... log

    Running script: C:\Windows\system32\cscript.exe //Nologo "C:\Program Files\Common Files\Microsoft Lync Server 2010\DbSetup\xdssetup.wsf" /dbexists /sqlserver:dss.local\rtc /publisheracct:DSS\RTCUniversalServerAdmins /replicatoracct:DSS\RTCUniversalConfigReplicator /consumeracct:DSS\RTCUniversalReadOnlyAdmins /role:master /verbose


    Installed SQL Server 2005 Backward Compatibility version is 8.05.2312

    Connecting to SQL Server on dss.local\rtc

    Error connecting (

      name:        Error


      number:      -2147221504



    Attempting to start SQL Server and connect...

    Error starting SQL Server on dss.local\rtc

    Error (

      name:        Error


      number:      -2147023836



    Ensure that dss.local\rtc is a valid SQL instance.


    Exit code: ERROR_START_SQLSERVICE (-1)

    When running /dbexists, non-zero exit codes are not necessarily errors

    The SQL server is running I have checked the database size and all seems OK

    What next

    Many Thanks Mike v
    Tuesday, November 15, 2011 12:25 AM


All replies

  • Hi,

    is this the same Server that you install test system before? have you completely clean the server before installing the Lync server again. it's better that you can start form the OS it self.


    Tuesday, November 15, 2011 1:31 AM
  • Hi This is a clean virtual server built just for this test.

    The Lync server has been deployed to sit on a single standalone server attached to our domain.

    We have Exchange 2010 SP1 on the domain.

    Many Thanks Mike v
    Tuesday, November 15, 2011 2:50 AM
  • can you please post more information about how the DBA is creating the databases  ? what are the previliges given on the sql server instance for the account  that is running the toplogy builder and trying to publish the topology.



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    Tuesday, November 15, 2011 8:45 AM
  • Hi,Mikeyvl,

    I supposed you are deploying Lync enterprise edition server since you have installed SQL server for the backend database, please make sure your front-end server and the backend server are in the same subnet.Here are some suggestions:

    1)Please check your service account have the required permission to publish the topology.You must be as a member of the RTCUniversalServerAdmins and Domain Admins groups,also please make sure you have the DB admin permission to publish the topology.And you can add the account as a member of CSAdministrator group in case there still some other permission issue.

    2)Please make sure you have created the file share and the account have the permission to access it.

    3)Please check the KB 2422384 to see if it applys to your issue

    4)If still failed please run Get-CsConfigurationStoreLocation and Remove-CsConfigurationStoreLocation then try to follow the Enterprise Edition deployment guide to publish the topology again.(Here is another step-by-step guide for your reference)

    5)Here are some other more information for your reference.

    Publish Topology Requirements

    Hope these useful!



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 16, 2011 10:32 AM
  • Hi,Mikeyvl,

    Any updates?

    If you have fixed the issue please kindly share us the solution.Thanks!



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, November 23, 2011 2:52 AM
  • Hi Sharon and others


    Thanks for your help so far. I am sorry for going AWOL for a few days. I was involved in earthquake recovery in our city which has taken precedence oven my time for the past 3 weeks. Now I am back on this job and will hopefully be able to see it through to deployment at a client site once I get the bugs ironed out. Will be back to you either way soon.


    Many thanks

    Many Thanks Mike v
    Friday, December 09, 2011 11:02 PM
  • Having the same issue as Mike.  When I try to do the steps you suggest I run into several issues.

    1.  I don't recall entering any information for a service account.  I assume it is using the standard network service account.  How exactly do I add that service account to the groups you mention (and the installation program mentions)?

    2. When I try to run  Get-CsConfigurationStoreLocation I get program not found.

    3. What is the difference when installing Lync on a standard vs. enterprise server?  I have gotten this problem attempting to install on both types.

    4. Is there going to be a simpler installation process anytime soon? This one seems byzantine and not what I expect from a Microsoft product.

    Friday, February 03, 2012 5:56 PM
  • Hi Sharon and others, I have already tried all the above steps which you mentioned and I'm still facing the same issue at creating central management store.

    I get the below error message at Microsoft Lync Server 2010 Deployment Log, any further ideas are much appreciated:

    Script result: ERROR_START_SQLSERVICE   3/29/2012 1:29:55 PM     
    Error: Error connecting to "SERVERNAME.FQDN\SQLINSTANCE" while installing "CentralMgmtStore". Verify that the SQL instance is running, connections are not being blocked by a firewall, and that you have SQL administrator permissions. For details, see the following log file: "C:\Users\USER_NAME\AppData\Local\Temp\Create-CentralMgmtStore-SERVERNAME.FQDN_SQLINSTANCE-[2012_03_29][13_28_51].log"   3/29/2012 1:29:55 PM   Error 

    Error: An error occurred: "Microsoft.Rtc.Common.Data.SqlConnectionException" "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 25 - Connection string is not valid)" 

    Prem - Unified Communication

    • Edited by Prem Kiran Thursday, March 29, 2012 12:46 PM
    • Proposed as answer by Prem Kiran Thursday, March 29, 2012 12:50 PM
    • Unproposed as answer by Prem Kiran Thursday, March 29, 2012 12:50 PM
    Thursday, March 29, 2012 12:43 PM
  • Thanks for the response Sharon.  My problem seems to be related to the certificates.  The portion of the LYNC installation that handled that had multiple failures in the log and those appear to be what my problem is.  If I still have issues after I get the certificates straightened out I will post again.
    Thursday, March 29, 2012 5:50 PM
  • many thakns for your help  Sharon :), your answer was for me a very big help !
    Wednesday, April 11, 2012 9:53 AM
  • Hi Sharon,

    We have a tight security policy in place, and we cannot use service accounts in the Domain Admins group.  Why would this be a requirement, and is it just a temporary account permission that can be withdrawn once setup is complete?



    • Proposed as answer by carmeloice Saturday, August 25, 2012 9:21 AM
    Tuesday, April 17, 2012 3:54 PM
  • Hi Mike

    The problem is due to disabled/stopped SQL services. The Publsih Topology will fail to connect to SQL instance (i.e. rtc) if SQL services are stopped or disabled.




    Friday, October 19, 2012 3:39 PM
  • Hi Mikeyvl,

    All the below answers  are not exactly right and this does not match the scenario Explained. In your scenario the Topology builder is unable to find the SQL instance to Create the CMS database. (We already know that SQL is running fine, issue is some were in finding where it is running)

    I hope you are creating Standard Edition Server, In topology builder when you create a New topology you would have choosed the New Front End Server creation at the end of the Wizard.  When Creating the Front End Server you would have Choosed "Standard Edition Server" , for Standard edition server you should provide the FQDN of the Machine name where Lync is going to be installed, do not give Pool name because pool name is accepted only in Enterprise Edition. (Attaching Screenshot for reference)

    • Proposed as answer by Krish Mural Thursday, July 03, 2014 6:49 AM
    Thursday, July 03, 2014 6:49 AM