none
WebDav using https fails with network name cannot be found. RRS feed

  • Question

  • When I attempt to connect to a Webdav server from a Windows 8.1 box it fails with
    System Error 67 has occurred.
    The network name cannot be found.

    I am using the net.exe USE command with the following syntax:
    net.exe use Z: https://dav.DomainYaya.com/  <PASSWORD> /user:USERNAME

    This exact syntax works for Windows 7.
    I have more than one Windows 8.1 box where this fails.

    There are various suggestions found all over the internet for various other situations. They do not apply or do not work.
    For example, you will find an issue involving sending Basic authentication over http where there are suggestions about changing HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WebClient\Parameters

    That does not work. There is also discussion about the Webclient service. (it is running). One can find discussion of the redirector. (The SYS file is present and is installed with Windows 8+ anyway.)

    Using HTTP only fails similarly but with error 53 (but I only did that as a test.) The issue is the HTTPS version.

    I have BTW tried this with two different webdav servers.

    Any help is appreciated.

    Joe

    Wednesday, January 14, 2015 6:18 PM

Answers

  • Hi Joe,

    Based on our research, the error 67 have the following several possable causes:

    •IIS is not installed or is not running on the server that you are attempting to connect to.
    •You have not installed the WebDAV Redirector on your client system.
    •The WebClient service is not running on your client system.
    •You have not enabled WebDAV on your web site.
    •You are using Basic Authentication and connecting to your web site using HTTP instead of HTTPS.
    •You are connecting to a web site on your local network that is using Fully-Qualified Domain Names (FQDNs) for name resolution, your web site uses Windows Authentication, and you have not added the web site's FQDN to the proxy server bypass list on your client.

    For more information, please refer to the article as below:
    Using the WebDAV Redirector
    http://www.iis.net/learn/publish/using-webdav/using-the-webdav-redirector  

    According to the test, I am able to reproduce this issue in my lab. By default, the Webclient service is not running on windows 8.1 client. But for windows 7 client this service is running by default.

    So please try to start the WebClient service on windows 8.1 client to check if it helps.

    If you have any question, please don't hesitate to let us know.


    Karen Hu
    TechNet Community Support

    Monday, January 26, 2015 1:49 AM
    Moderator

All replies

  • As best I can tell when looking at a packet trace, the handshakes and certificate exchange works correctly. In fact, application data is sent.

    This means there is most likely something on the client side that is mucking it up. What in Windows would be mucking it up?
    Wednesday, January 14, 2015 10:19 PM
  • Hi Joe,

    Make sure your address is correct and then please use Windows Explorer to map this connection to see if it could successfully:

    Right-click on This PC and select Map network drive.... Choose a local network drive to map ownCloud to. Finally, enter the address to your ownCloud instance. Mapping WebDAV on Windows Explorer After pressing Finish, Windows Explorer will map the network drive and your ownCloud instance should be available.

    For more information, please refer to this article(For Windows section):

    http://doc.owncloud.org/server/6.0/user_manual/files/files.html

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Karen Hu
    TechNet Community Support

    Friday, January 16, 2015 3:06 AM
    Moderator
  • Thanks for your reply.

    Yep. I've done all that.

    In fact, that page recommends "For Windows a seperate WebDAV client is recommended to access the files from your server. Choose one from the WebDav Project page Should you have to use the native implementation..."

    The address is correct. Otherwise I could  not have said it works under Windows 7 and that the packet trace and handshakes work correctly.

    No solution yet.

    Joe

    Friday, January 16, 2015 4:17 PM
  • Hi,

    Did you mean it cannot works under Windows Explorer like this?

    Check this thread and article:

    https://social.technet.microsoft.com/Forums/windows/en-US/4c8cc733-2a54-400e-a53a-e3f22614de9f/unable-to-map-webdav-over-ssl

    You cannot access a WebDAV Web folder from a Windows-based client computer http://support.microsoft.com/kb/912152


    Karen Hu
    TechNet Community Support

    Monday, January 19, 2015 9:27 AM
    Moderator
  • Yep.

    I've seen all of that before. It hasn't helped.

    Recall the original post:

    System Error 67 has occurred.
    The network name cannot be found.

    One of those links involved using NON https connections. I am attempting an https connection so the registry issue does not apply (although I tried it of course.)

    The other link mentioned an entirely different error. It involves SSLv2 which is disabled on the server. Unlike the screenshot in that link the TLS handshake occurs correctly so this is not a security failure at the basic level.


    • Edited by JoeYaya Tuesday, January 20, 2015 3:49 PM
    Tuesday, January 20, 2015 3:46 PM
  • Hi,

    I will involve someone who is familiar this kind of issue to help you analyze and resolve this issue.

    Please give us more patience.


    Karen Hu
    TechNet Community Support

    Thursday, January 22, 2015 10:10 AM
    Moderator
  • Hi Joe,

    Based on our research, the error 67 have the following several possable causes:

    •IIS is not installed or is not running on the server that you are attempting to connect to.
    •You have not installed the WebDAV Redirector on your client system.
    •The WebClient service is not running on your client system.
    •You have not enabled WebDAV on your web site.
    •You are using Basic Authentication and connecting to your web site using HTTP instead of HTTPS.
    •You are connecting to a web site on your local network that is using Fully-Qualified Domain Names (FQDNs) for name resolution, your web site uses Windows Authentication, and you have not added the web site's FQDN to the proxy server bypass list on your client.

    For more information, please refer to the article as below:
    Using the WebDAV Redirector
    http://www.iis.net/learn/publish/using-webdav/using-the-webdav-redirector  

    According to the test, I am able to reproduce this issue in my lab. By default, the Webclient service is not running on windows 8.1 client. But for windows 7 client this service is running by default.

    So please try to start the WebClient service on windows 8.1 client to check if it helps.

    If you have any question, please don't hesitate to let us know.


    Karen Hu
    TechNet Community Support

    Monday, January 26, 2015 1:49 AM
    Moderator
  • Hi,

    I'm just got hit by exact the same probem. Still no solution, but a hint!

    Could it be possible, that your OwnCloud-Server runs with SNI? According to the results of "webdav sni windows 8.1" with my friend Google, this might be the Problem.

    Unfortunately the System Error 67 doesn's say something about "Cannot handle SNI". And so the "Experts" are pointing the Problem between your (and my) ears, even if you repeat "I DID ALL THAT!". It's depressing.

    Reconfiguring the effected domain to another, exclusive IP is a pain, but I'll do that after the weekend and give a feedback, if a native webdav-mapping will work then.

    Friday, February 13, 2015 10:17 PM
  • I can confirm, it's related to SNI! (and some kind of strange "slashing")

    I could not wait!

    I have changed the Domain of my OwnCloud Installation to an exclusive IP, not shared, not SNI!

    Using this net use with this backslashed syntax maps the webdav folder perfectly:

    net use W: \\https:\\the.domain.name\remote.php\webdav\ /user:myusername myassword /persistent:yes

    Then I configured it back to the shared, SNI-IP. Used the same command (of course, after disconnected the mapped drive) and got:

    System error 1244 has occurred.
    
    The operation being requested was not performed because the user has not been authenticated.

    If I try the net use with forwarded slashes, I got the System Error 67, too - with or without SNI on Server-Side.

    I can confirm, it worked like charme in Windows 7 with SNI on Server-Side! So I think, Joe (and many other Users) are right! Something changed in Windows 8, which was working before!

    Have a nice Weekend!





    • Edited by WebOscar.net Friday, February 13, 2015 11:48 PM
    • Proposed as answer by WebOscar.net Saturday, February 14, 2015 1:03 AM
    Friday, February 13, 2015 11:42 PM
  • same issue here, did you ever find a solution to this?
    Saturday, July 25, 2015 8:29 AM
  • NON SSL:

    net use z: \\<domainname>@<portNumber>\DavWWWRoot\<pathToShare> <password> /user:<userName>

    SSL:

    net use z: \\<domainname>@SSL\DavWWWRoot\<pathToShare> <password> /user:<userName>

    Saturday, February 13, 2016 1:48 AM
  • Hi Joe

    I have come a cross the same issue but to me it's not a big issue at least for now the client PCs are running on Windows7.

    I am using Win10 and the mapping WebDAV drive errors out. Have you received/worked out a resolution.

    Cheers

    Siraj

    • Proposed as answer by Atento Monday, May 7, 2018 12:14 PM
    Monday, June 6, 2016 6:28 PM