locked
Word 2010 suddenly becomes Read-Only RRS feed

Answers

  • Hi,

    I met this issue before. And for me, this issue wouldn't happen to all my documents, but once it did happen to a particular document, it would keep happening to that document no matter what I did.

    The only way I was able to get around the problem was to turn off the automatic backup file feature in Word 2010 while working in that document.

    1. Click the File tab of the ribbon and then click Options.
    2. Click Advanced at the left side of the dialog box.
    3. Scroll down to the Save section and make sure the Always Create Backup Copy check box is NOT selected.
    4. Optionally, also NOT select the Allow Background Saves check box.
    5. Click on OK.

    In addition, sometimes when you open a word file, a temporary copy is created.

    Closing the document should also close the temp file.

    Sometimes this does not happen and the temp file remains behind. If so, it also may cause this issue.

    Try to reboot or end process by clicking Alt+Ctrl+Delete to open task manager so that clear the temp file.

    Hope that helps.

    • Marked as answer by Jennifer Zhan Thursday, October 21, 2010 5:22 AM
    Friday, October 15, 2010 2:11 AM

All replies

  • Hi,

    I met this issue before. And for me, this issue wouldn't happen to all my documents, but once it did happen to a particular document, it would keep happening to that document no matter what I did.

    The only way I was able to get around the problem was to turn off the automatic backup file feature in Word 2010 while working in that document.

    1. Click the File tab of the ribbon and then click Options.
    2. Click Advanced at the left side of the dialog box.
    3. Scroll down to the Save section and make sure the Always Create Backup Copy check box is NOT selected.
    4. Optionally, also NOT select the Allow Background Saves check box.
    5. Click on OK.

    In addition, sometimes when you open a word file, a temporary copy is created.

    Closing the document should also close the temp file.

    Sometimes this does not happen and the temp file remains behind. If so, it also may cause this issue.

    Try to reboot or end process by clicking Alt+Ctrl+Delete to open task manager so that clear the temp file.

    Hope that helps.

    • Marked as answer by Jennifer Zhan Thursday, October 21, 2010 5:22 AM
    Friday, October 15, 2010 2:11 AM
  • I've seen this happen because the folder permissions for the folder the file is saved to are set to read-only. If a folder is set to be read-only, it allows you to save files into that location, but they become read-only once they have been created. If this is happeneing you can fix it by removing the read-only property from the folder (and then the file).
    Monday, March 14, 2011 10:54 AM
  • Hi Jennifer,

     

    It is now July 2011 and I wonder if the problem has been resolved?  Turning off automatic saves is a solution but a potentially a very expensive one!  The problem is recurring (apparently randomly but often) in pretty much any Word document that I work on for a while.  Nothing seem to cure it.  Once a file got this disease, it cannot be cured (that is every time you save it must be to a different name :( ).

     

    FYI, I open files on my harddrive, use Office 2010 professional, and use both doc and docx formats depending on the origin of the file.  It makes no difference.  All are susceptable and many fall ill ...

    Cheers,

    Giorgio

    Thursday, July 14, 2011 3:13 PM
  • I started to have this problem a few weeks ago and I could not remember what changes were made to my workstation.

    I am running Word 2010 Pro (product activated) on Windows 7.

    When a file was just opened, "Read Only" did not appear at the top of the Word window. After several minutes, when I clicked "Save" icon, the "Save As" dialog screen appeared and I had to save to the file with a different name. If I cancelled the dialog box, then the text "Read Only" appeared at the top of the window.

    I already disabled the auto-save but the problem perisisted.

    It happened to both doc and docx files.

     

    Seaport

    Thursday, July 21, 2011 5:25 PM
  • I have this exact same problem, after recently upgrading to Word 2010 on Windows 7. Because of the approching deadline for my document, I cannot find any other way but to save with a new name every time. Now I am already having a confusing amount of versions of the edited document.The file attribute is set to not-protected and the folder is so as well.

    regards,

    Huvitus

    Friday, September 30, 2011 6:37 AM
  • I solved this problem by running Word as Administrator. Go to the Properties of the Word shortcut, click the Compatibility tab, and check "Run this program as an administrator". You'll get the UAC prompt every time you open a Word doc, but at least you can edit!
    Friday, October 7, 2011 3:27 PM
  • I took the above advice but also changed the permissions under the security tab to include write and modify, as well as making sure that the compatibility mode was set to Windows 7.  Works fine now - no prompts or anything.  
    Saturday, November 19, 2011 6:40 PM
  • well it is April 2012 and i am having this problem. Very annoying - and since i recently lost a document I am not likely to turn off autosave.

    Don't know how to set permissions on a OneNote file - that is where the problem is happening.

    But it doesn't happen everytime i open a document - well once the disease comes...

    and bc it is in onenote - when the dialogue box pops up - i have to save the "new" file to desktop - then delete the original in Onenote 2010 - then copy the saved file back to onenote - then delete it from desktop - pretty annoying.

    btw - "read only" - what does that mean when applied to a folder - just for fun - i looked at the properties of a folder on desktop - it says "read Only" - but i am in fact able to make changes to the files in that folder at will - so what does all this mean?

    Wednesday, April 11, 2012 10:15 PM
  • Hi,

    I've the same problem : Word 2010 + W7 professional.

    I experience this issue only on certain documents.

    Tuesday, April 17, 2012 2:35 PM
  • Why doesn't Microsoft fix this problem? This is a Microsoft forum and you have lists of people experiencing the same problem. It is a glitch in the program,  it's extremely destructive, and people have been reporting it for a year and half! WTF? Where is the moderator of this forum? Why won't Microsoft address this?

    Wednesday, May 2, 2012 5:51 AM
  • We too have had this problem off and on.  With us it is not an Office 2010 problem but a Windows 7 issue.  This will sound stupid but try it and see if it corrects the problem.  Open Windows Explorer.  In the upper left is a pull down menu that is labeled Organize.  Click it and go down to Layout, select Details pane to turn it off.  Then, hopefully enjoy read-write paradise.
    • Proposed as answer by jtho Wednesday, May 2, 2012 6:58 PM
    Wednesday, May 2, 2012 6:58 PM
  • That works!!! Thanks a lot!! It's a simple issue of whether the preview pane is enabled or not when you open the file from the folder :))
    Saturday, May 5, 2012 11:24 PM
  • I found the fix to Word 2010 giving the error message "Read-Only" when saving a Word file.  For me, after I copied folders to an external hard drive (destination) that contained both Word 2010 and Word 1997-2003 documents, I opened some of the Word files from the destimation source.  The only files which I opened that gave me the read-only error when I tried to save the file were the Word 1997-2003 documents.  None of the Word 2010 files opened resulted in the Read-Only error message when I saved the files.

    So, a work around for the Read-Only error (but still wishing Microsoft would step up and just fix the problem):  Open the Word 1997-2003 file, and save it as a Word 2012 file with a new name.  Technically, you don't need to use a new file name, as the extension will be different, but it reduces confusion.

    Friday, May 11, 2012 8:58 PM
  • What if you open Word by dobule click in a word file?
    Wednesday, June 6, 2012 7:59 AM
  • I have the same probelm with Windows 7 and Word 2010. The option to hide the detail pane in layout of windows explorer didn't help. The option to run Word as administrator does not apply when you open the word files by double-click on them. Waiting for Microsoft to provide the solution.
    • Proposed as answer by eleibzon Friday, June 8, 2012 10:24 AM
    • Unproposed as answer by eleibzon Friday, June 8, 2012 10:24 AM
    Wednesday, June 6, 2012 8:03 AM
  • I have finally found a solution to this problem. I have disabled my AVG antivirus and everything went back to normal again.
    Friday, June 8, 2012 10:25 AM
  • I had thought this fixed the issue, but I guess it didn't.
    Monday, June 11, 2012 5:15 PM
  • We too have had this problem off and on.  With us it is not an Office 2010 problem but a Windows 7 issue.  This will sound stupid but try it and see if it corrects the problem.  Open Windows Explorer.  In the upper left is a pull down menu that is labeled Organize.  Click it and go down to Layout, select Details pane to turn it off.  Then, hopefully enjoy read-write paradise.

    This is the answer!

    It's not silly when you think about it. The folder preview pane is using the source code from Word to display a preview of the document in the preview window. So, technically, the document is already open in Word. It's definitely an oversight by Microsoft, but it makes logical sense.t

    THANKS!


    Wednesday, June 20, 2012 1:14 AM
  • I have tried all of the "fixes" suggested in this thread, to no avail. In fact, the problem keeps getting worse! This has been happening off and on for months, but I now have to rename the file I'm working on EVERY TIME I SAVE IT.

    This is a work PC, so turning off the antivirus (Trend Micro) is not an option.

    Has anyone had success with any other fixes?

    Thursday, June 21, 2012 4:06 PM
  • Dionisio Ambrona

    It is the preview pane that needs to be unchecked, not the details pane.

    • Edited by simonling Sunday, June 24, 2012 2:54 PM
    Sunday, June 24, 2012 2:49 PM
  • Well, I seem to have solved the problem, although it's a workaround that might not be viable for everyone. I saved the file as "Word 97-2003 Document (*.doc)" instead of .docx, and the problem disappeared. It's been at least a week since I've seen it happen.

    As long as you don't need to use features that are specific to the .docx file format (whatever they are), give this a try. As I mentioned before, none of the other workarounds solved the issue for me.

    • Proposed as answer by DJKuulA Friday, July 6, 2012 5:53 PM
    Friday, July 6, 2012 5:53 PM
  • From just reading the various symptoms it seems fairly obvious that the issue occurs as soon as any other process opens the file, causing word to get its knickers in a twist and go into read only mode. Disabling various other bits that may open your file will help, but I'm guessing none of these solutions is a guaranteed fix.

    I am dismayed that such an old body of code as MS Word still exhibits such bugs, this is file programming 101. You can tell how much testing they go through with these things. But hey that's MS for you.

    Wednesday, August 1, 2012 10:44 AM
  • FIXED - With thanks to JTHO.

    My problem was that some Word documents were opening as Read-Only, so you had to resave as a different name but you still couldn't delete the previous document.

    Go to Folder > Organize > Layout > Preview Pane and click it off.

    For some reason the computer was seeing the Preview as an already open document so if you tried opening it properly then it would become read only until you stopped viewing it in the Preview Pane!

    • Proposed as answer by GavRhodes Monday, August 13, 2012 10:14 AM
    Monday, August 13, 2012 10:14 AM
  • Um... doesn't work for me. My preview pane has been off all the time, and I still have this problem.
    Wednesday, August 15, 2012 4:48 PM
  • I have had this problem for some weeks, really a big problem, I suspected WinXP at first, I tried everything. Nothing helped.

    I then suspected Word 2010 Pro and followed lots of online Microsoft advice, nothing helped. I changed option after option and other than making a few new problems, I did not fix the old one!!

    As a last desperate move I got my MSOffice 2010 Pro CD and did a new install, over the old. It went quite quickly, though my laptop is 6 years old, it took less than 30 minutes.It retained all my personal infos, files and locations etc.. Very nice and quick.

    It fixed the problem completely.

    I am guessing, but I don't think it was a full install, if I remember correctly that took far longer.....a few years ago....2.4GB to fully copy would take longer I am sure.

    I did the full install even though I only had problems with Word and very occasionally Excel....

    Regards

    der_fisherman

    • Proposed as answer by der_fisherman Wednesday, September 12, 2012 5:02 PM
    Wednesday, September 12, 2012 5:02 PM
  • I have turned off preview pane, it did not fix the problem.  What does "fix" it is to have explorer not viewing the folder containing the doc file.

    Other doc files in the same folder (some created in Word 2010, some in 2007) do not have this problem.  I see the problem only on one file which was created in Word 2010 from a .dotx template which I think was create in Word 2007, and I then set the doc to "compatibility" mode.

    Thursday, October 18, 2012 6:56 PM
  • I found the solution !!!

    I faced the same problem for almost a month with one file. The file was 65 pages and contain a lot of images, out of sudden the file wasn't able to be saved in the Word 2010 file extension (.docx). I was only able to save the file in the "2003 compatible mode".

    After working on this problem for more than 3 hours i was able to identify the problem. the problem occurs when placing captions to the images and figures, or when placing an image and caption with no enough space.

    Now what I did to identify the "infected image" was by copying small portions of the file to a new file in sequence and saving the file after placing every new portion. in this way you'll be able to identify which image or caption is causing the problem.

    simply to solve it, reinsert the image and make another caption.

    Sunday, November 18, 2012 4:43 PM
  • MS Word (2003) spontaneous "read only"

    Whooppeeeeee! Am I imagining things or has the latest Microsoft Windows 7 service update finally fixed this most irritating problem ...

    Friday, February 15, 2013 10:52 PM
  • To those who have this problem in the future.

    I had done the latest Windows 7 service update but had the problem develope in the last 24 hours.

    Tried a number of things found elsewhere without any luck. Once I found this thread, started at the top with the ideas, checked each of the settings suggested and changed if needed. 3 suggestions not done were - run as administrator, disable AVG antivirus and reinstall progam.

    Not real sure what the magic thing was to work but my document is no longer 'read only'.

    As time allows may go back and re-set settings to see if there is any one thing to create problem.

    Thank you to all with your suggestions.


    • Edited by B-M Monday, April 29, 2013 1:09 AM
    Monday, April 29, 2013 1:03 AM
  • "you can fix it by removing the read-only property from the folder (and then the file)."

    This is the only solution that worked for me.

    Saturday, August 31, 2013 7:08 PM
  • I have struggled with this problem for about two months now and implemented all the suggestions in this thread to no avail. The only solution is to uninstall the MS Office from control panel, reboot your computer, and re-install MS Office. I did that and never had any problems again.
    Thursday, September 26, 2013 1:29 AM
  • This is the only solution. I agree.
    Thursday, September 26, 2013 1:31 AM
  • It works!! Thank you for saving my sanity.
    Wednesday, October 9, 2013 10:04 AM
  • A similar solution posted by jtho worked for me:

    Open Windows Explorer.  In the upper left is a pull down menu that is labeled Organize.  Click it and go down to Layout, select "Preview pane" to turn it off.

    It is really fault from MS side, because they should have implemented document preview feature in read-only mode!

    Preview of large documents causes file explorer to freeze for tens of seconds even on a multi-core cpu. Lame programming is very obvious for both MS Office 2010 and Windows 7; 8...

    Saturday, October 26, 2013 10:38 PM
  • Wow - Thanks! I didn't know about this. When I started checking some of my main folders, I found that all of them were set to Read Only. I checked my main Documents folder and it, too, was set to Read Only. When I deselected that box I got an option to apply it to every folder and file within the My Documents folder. Let's hope that solves it.
    Tuesday, March 4, 2014 7:00 PM
  • Found an easy fix here that's working so far: 

    1. Right click on the icon to start Microsoft Word 2010.

    2. Left click on "Properties".

    3. Left click "Security" tab.

    4. Select my user name.

    5. Click "Edit" to change permissions.

    6. Select my user name again.

    7. Check "Allow" box for "Full control".

    8. Apply, OK, and done.

     
    Monday, March 17, 2014 12:53 PM
  • Mine was off by default. 

    Tuesday, October 28, 2014 1:16 PM
  • Your "solution" is a work-around, not a resolution. 

    Wednesday, March 25, 2015 12:30 PM
  • My 'work-around' has been to simply close a file that comes up as 'Read Only' and reopen it. Saved me doing all those other options.  Fortunately it does not happen very often. 
    Friday, May 8, 2015 1:17 AM
  • Set your permission on the file tab / info.  Set so "Anyone can open, copy or change any part of this document".  Your security permission is set too high. 

    Thanks Seaport for the .doc / docx hint.  That started showing up when I did my last update.

    As my kids say, "Get a Mac Mom, they don't get viruses."  And yes Virginia, they have a Office for Mac, without bugs.  I just too old to change.

    Wednesday, May 20, 2015 2:40 PM
  • Details pane, not preview pane that person made a mistake
    Wednesday, June 24, 2015 5:33 PM
  • THANKS BRO YOUR THEORY ITS WORK 100%

    Saturday, January 14, 2017 7:09 AM
  • I just tried this and it worked perfectly! Then I reactivated AVG and the problem came back instantly. Did you switch to a different antivirus provider or were you able to work with AVG somehow? I'm not sure I want to just go ahead and switch to a different antivirus provider, in case that causes the same thing. In the meantime, thank you for providing the answer! (Not sure I want to be using my laptop without antivirus, though!)
    Thursday, January 4, 2018 4:58 AM
  • This is still happening in 2020. One of the solutions in this discussion does work, but there is a typo in the post.

    Here is the fix: Go to the Computer icon on the Desktop, click on this, Look for "Organize" in the second-from-the-top menu (top left of screen), click on that and observe the menu which appears. Click on "Layout", and if there is a check mark in the "Preview Pane" box (in the drop-down Layout menu), UNCHECK THIS BOX !! The other person who posted here accidentally typed "Details pane box" rather than "Preview Pane box". No, it is the "Preview Pane" box which is the danger. THIS MUST REMAIN UNCHECKED AS LONG AS YOU LIVE!!!! You will just have to live without the Preview Pane.

    This bug is decades old. It does not bode well for any vaććine Gątes might want to promote.



    Sunday, June 21, 2020 7:18 PM