Hyper-V host node bughceck on MsLbfoProvider.sys


  • Since I updated my servers, it appears that I am having bugchecks due to The debug shows MsLbfoProvider.sys as being the culprit, but the bugcheck is showing the error as DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1). All I can find on this file is bugchecks for security issues, not a driver issue. The file version shows as being updated with the associated update. I'm sure I could uninstall the update, but since it is a rollup, I'd hate to remove all the other patches that this installed. This has crashed all 3 nodes in the cluster. Anyone else seen this issue or have any ideas? It's in my DR site, so I'm ok for now, but I need to figure out if an uninstall is my only route, other than calling MS. Thanks!!
    Wednesday, July 10, 2013 9:52 PM


All replies

  • Are you using vlan tagging?

    Jose Vigenor Support Escalation Engineer SharePoint Technologies Support

    Thursday, July 11, 2013 3:34 AM
  • If you using vlan tagging. You will need to open a support case and request the following hotfix or you can uninstall July rollup

    Jose Vigenor Support Escalation Engineer SharePoint Technologies Support

    Thursday, July 11, 2013 5:27 AM
  • Same Problem here. Where can i get the hotfix? 
    Thursday, July 11, 2013 9:08 AM
  • Same problem here, on DELL R720 / HP DL380 fails with this bluescreen and mslbfoprovider.sys.
    We are using Teaming and VLAN also.

    Please make this hotfix public.

    Thursday, July 11, 2013 9:38 AM
  • I'm also facing the same issue, the debug pointed to MsLbfoProvider.sys, which was actually updated by the July windows update

    I couldn't find any hotfix or patches related to this, so what I did is the uninstall of the update KB2855336 and everything's back to normal. So I guess that's the solution for now until any hotfix is released.

    After uninstallation my Mslbfoprovider.sys version changed to 6.2.9200.16451.

    So far I have tried this with 2 nodes and looks good, will try on the remaining nodes and see how it goes.

    Hope this will help someone :)

    • Proposed as answer by NRasheed Thursday, July 11, 2013 9:40 AM
    Thursday, July 11, 2013 9:40 AM
  • Yeah, we are using VLANs and teaming. I'll check into that hotfix and let y'all know what I find out. Thanks for the help!!

    Thursday, July 11, 2013 3:59 PM
  • Yes we're seeing this with customers and in our own lab too. We use NIC teaming with vlans.

    Principal Consultant and Hyper-V MVP at

    Thursday, July 11, 2013 5:54 PM
  • Sounds like the hotfix is still private and not fully tested. I've only patched our DR site. I have a tech checking on timing for the testing to be complete. I'm gonna wait on the rest of our servers until this hotfix has been tested.
    Thursday, July 11, 2013 7:54 PM
    • Marked as answer by iclay Saturday, July 13, 2013 2:05 AM
    Friday, July 12, 2013 12:07 PM
  • Yup. Installed it earlier and we're all good now.
    Saturday, July 13, 2013 2:04 AM
  • I also had the same issue, and I update the driver, it's worked.
    Monday, September 16, 2013 3:09 AM
  • I have this issue on my Hyperv 2012 R2 installation, but there is no patch for R2, what to do?
    Monday, December 02, 2013 3:25 PM
  • Same issue on Hyper-v 2012 R2

    I uninstall last updates 2862152, 2868626, 2876331, 2887595, 2898514, 2901101, 2908174

    mslbfoprovider.sys version goes from 6.3.9600.16423 to 6.3.9600.16384

    Now live migration apparently working correctly

    Tuesday, December 17, 2013 7:07 PM
  • Similar issue here with 2012 R2 cluster on a brand new Dell VRTX with two M620 blades, however we were getting more general kernel crashes on live migrations.  I've probably put two full days running in circles and troubleshooting with Dell as we were initially convinced it was a hardware issue, then a driver issue with our Intel x540 NICS.  I saw jsepulve's post this morning, removed those 7 updates and the problem appears to be fixed.  So thank you very much for posting that!  How frustrating, Microsoft!
    Friday, December 20, 2013 8:01 PM
  • You' re wellcome Christopher

    The concrete update appears to be KB2887595

    Thursday, January 02, 2014 9:30 AM