none
macro settings greyed out

    Question

  • Hello Experts,

    I need your help!

    I am using the excel 2010 on Win 7. I found I cannot change the macro security settings, all of them are greyed out.

    Interesting thing is I can record the macro and run it, but I cannot run any macro when I import it from outside. Currently the system setting for macro is "Disable all macros with notification"

    Please help me out.

    Edward

    Friday, September 30, 2011 6:46 PM

Answers

  • Hi Edward,

    I'd like to know whether you are now alone in your home using the Excel 2010 or you are working in your company in an Enterprise environment?

    Generally, these options could be disabled by group policy settings controlled by your domain admins, if so, you could hardly to make a change without permission from them.

    If you are now home alone, try to check your group policy settings.

    Typing GPEDIT.MSC in the Run box. Navigate to

    User Configuration/Administrative Templates/Microsoft Excel 2010/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled

    Disable this setting if it is enabled.

    You may need to use the gpupdate /force command to have this change to take effect.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by edward.HD Thursday, October 6, 2011 1:35 AM
    Tuesday, October 4, 2011 4:52 AM
    Moderator

All replies

  • Hi Edward,

    I'd like to know whether you are now alone in your home using the Excel 2010 or you are working in your company in an Enterprise environment?

    Generally, these options could be disabled by group policy settings controlled by your domain admins, if so, you could hardly to make a change without permission from them.

    If you are now home alone, try to check your group policy settings.

    Typing GPEDIT.MSC in the Run box. Navigate to

    User Configuration/Administrative Templates/Microsoft Excel 2010/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled

    Disable this setting if it is enabled.

    You may need to use the gpupdate /force command to have this change to take effect.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by edward.HD Thursday, October 6, 2011 1:35 AM
    Tuesday, October 4, 2011 4:52 AM
    Moderator
  • To enable all macros :

    File tab => Excel Options => Trust Center => Trust Center Setting => Macro Settings to enable all macros.

    For checking your macros :

    Alt+F11


    Best Regards Jun LOU
    • Proposed as answer by Lazarus2Long Tuesday, January 31, 2017 4:26 PM
    • Unproposed as answer by Lazarus2Long Tuesday, January 31, 2017 4:26 PM
    Wednesday, October 5, 2011 2:23 PM
  • Hi Edward,

    I'd like to know whether you are now alone in your home using the Excel 2010 or you are working in your company in an Enterprise environment?

    Generally, these options could be disabled by group policy settings controlled by your domain admins, if so, you could hardly to make a change without permission from them.

    If you are now home alone, try to check your group policy settings.

    Typing GPEDIT.MSC in the Run box. Navigate to

    User Configuration/Administrative Templates/Microsoft Excel 2010/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled

    Disable this setting if it is enabled.

    You may need to use the gpupdate /force command to have this change to take effect.


    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.


    Hi Max,

    You are right it is blocked by group policy. Funny thing is I could still run macro even though it is set as "Disable all macros with noitification.

    Thank you!

    BR,

    Edward

    Thursday, October 6, 2011 1:37 AM
  • Hi Max,

    I just stumbled upon the same issue as Ed last year.  Though I'm on the Enterprise network, I did check on the settings that you suggested above but could not notice such enforcement/s.  Moreover, the macro settings was accessible to me few days ago, before I encountered with this issue.  Can you please advise next course of action to rectify the situation?

    Thanking you,

    Naresh

    Wednesday, March 28, 2012 6:29 AM
  • try with another user login if it works then rename user profile i tried for one user and it works.

    Friday, July 20, 2012 2:24 PM
  • Dear Edward

           I have the same issue with you, can not enable office macro on Win 7, I created some macro but can't working, if you have do some setup can run macro pls share to me. thank you.

      

     Sincerely,

      Cody

    Tuesday, January 15, 2013 7:53 AM
  • Hi Max,

    I tried but I cannot found Microsoft Excel 2010 in Administrative Templates.

    Could you please another way to fix the problem ? or have you solution for this?

    Thank you.

    Regards,

    Beatrix

    Friday, June 21, 2013 2:43 AM
  • If you not have installed the Office ADM policy pack, you can't find the mentioned setting in the GP editor. But policies are handled through registry.

    Try delete HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\excel\security\VBAwarnings

    If its an active policy, it will reappear at next policy refresh

    Wednesday, August 28, 2013 9:12 AM
  • Hi Max,

    I had the same issue as Edward that the Macro option is grey out. But my Excel version is 2013 and I can not find the group policy at location of 'User Configuration/Administrative Templates/Microsoft Excel 2010/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled'.

    Is there any advice for my problem?

    Wednesday, August 19, 2015 8:24 AM
  • I searched (Ctrl+F) for "VBAwarnings", which was found under

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel\Security\VBAwarning

    Since the location was different, I opened it and changed the value from 1 to 0 (zero), and it worked.  Even if your location is a little different, you might try the search as well and just change the value.

    Whether it works or not, you may want to change the value back to 1 once you are finished deleting the macro.

    Monday, November 2, 2015 4:38 PM
  • In the installation of Excel (& the entire office suite for that matter), the office tools need to be installed (which include vba). They are tools shared by all the office programs (excel, word, outlook, ppt, etc). I went into add/remove programs, selected Excel (or it might be office), then went into the add/remove features, or customize installation area. In this, make sure that office tools, or whatever it's called, is fully installed. You might need the office disk so that it can be installed.
    Wednesday, May 11, 2016 3:54 PM
  • I also searched for "VBAwarnings" and it was under a different location (something about policies, this was a colleagues computer), set to 2.  I changed it to 1 and it now works!
    Thursday, January 19, 2017 11:40 AM