locked
the property sessiondirectorylocation is configured by using group policy settings RRS feed

  • Question

  • Hello,

    I am attempting to setup an RDS farm with 2 servers:

    2 Server 2012 R2 RDS servers hosting Broker services in HA mode (setup and seemingly working)

    both servers should act as session hosts as well, but 1 fails to become part of the group.1 server generates the following error when I attempt to add it as a session host in the collection:

    the property sessiondirectorylocation is configured by using group policy settings

    I can add and remove the session host role at will, no issues.  and the second server can become a session host without issue in the collection.  They are identical otherwise.  I have tried unconfiguring all group policy objects and then configuring various objects to no avail.  Any help would be appreciated.

    Tuesday, September 22, 2015 12:01 AM

Answers

  • TP,

    I mentioned that I went into group policy already.  The option is not there.  But I did sort this out myself:

    So, seeing as nobody has come up with an answer, I think I sorted this one out:

    So there's no group policy object that manages this in server 2012R2.  What did seem to appear in the node that would not join the collection was these legacy Terminal services keys in the registry:

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!SessionDirectoryLocation

    I removed the 4 "SessionDirectory*" keys, rebooted the server, and it is now poart of the RDS farm session host collection.

    • Proposed as answer by Amy Wang_ Monday, October 5, 2015 10:43 AM
    • Marked as answer by Amy Wang_ Wednesday, October 7, 2015 4:04 AM
    Wednesday, September 23, 2015 3:13 PM
  • Hi,

    Yes, I know you said you went into group policy already, but I didn't know whether or not you verified on the host itself which GPOs and their settings were being applied to it.  The reason I asked you is that people ask questions very frequently and mention they checked/changed/etc. group policy, however, they either didn't troubleshoot the effective group policy settings being applied or don't know how to (usually).

    There is a group policy setting (the one I referenced above) that manages the SessionDirectoryLocation property for 2012 R2, however, it should not normally be used for Server 2012/2012 R2 deployment.  The reason they normally are not used for 2012 R2 is because the broker will configure the properties when the server is added to a collection and a group policy setting will conflict with that.

    Now, in your specific case I'm guessing you have or had a group policy object that had the connection broker settings configured and for some reason these settings didn't get removed from this particular server's registry.

    The registry values you deleted only appear there because of a) group policy settings configured or b) someone manually put them there via editing or other registry change technique.

    -TP

    • Proposed as answer by Amy Wang_ Monday, October 5, 2015 10:43 AM
    • Marked as answer by Amy Wang_ Wednesday, October 7, 2015 4:04 AM
    Wednesday, September 23, 2015 3:59 PM

All replies

  • Hi,

    On the problem server, please log on as a domain admin, open an administrator command prompt, and run the following commands:

    gpresult /z>gpresult.txt

    notepad gpresult.txt

    Please examine the gpresult.txt and make sure that there are no session directory-related group policy settings listed, for example:

    SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\SessionDirectoryLocation

    If you do find any please edit the appropriate GPOs and set all settings related to RD Connection Broker to Not Configured, and then run gpupdate /force on the servers.  When editing your GPOs, broker settings (as they relate to RDSH) are under a path similar to below:

    Computer Configuration\ Policies\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ RD Connection Broker

    Thanks.

    -TP

    Wednesday, September 23, 2015 11:03 AM
  • TP,

    I mentioned that I went into group policy already.  The option is not there.  But I did sort this out myself:

    So, seeing as nobody has come up with an answer, I think I sorted this one out:

    So there's no group policy object that manages this in server 2012R2.  What did seem to appear in the node that would not join the collection was these legacy Terminal services keys in the registry:

    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!SessionDirectoryLocation

    I removed the 4 "SessionDirectory*" keys, rebooted the server, and it is now poart of the RDS farm session host collection.

    • Proposed as answer by Amy Wang_ Monday, October 5, 2015 10:43 AM
    • Marked as answer by Amy Wang_ Wednesday, October 7, 2015 4:04 AM
    Wednesday, September 23, 2015 3:13 PM
  • Hi,

    Yes, I know you said you went into group policy already, but I didn't know whether or not you verified on the host itself which GPOs and their settings were being applied to it.  The reason I asked you is that people ask questions very frequently and mention they checked/changed/etc. group policy, however, they either didn't troubleshoot the effective group policy settings being applied or don't know how to (usually).

    There is a group policy setting (the one I referenced above) that manages the SessionDirectoryLocation property for 2012 R2, however, it should not normally be used for Server 2012/2012 R2 deployment.  The reason they normally are not used for 2012 R2 is because the broker will configure the properties when the server is added to a collection and a group policy setting will conflict with that.

    Now, in your specific case I'm guessing you have or had a group policy object that had the connection broker settings configured and for some reason these settings didn't get removed from this particular server's registry.

    The registry values you deleted only appear there because of a) group policy settings configured or b) someone manually put them there via editing or other registry change technique.

    -TP

    • Proposed as answer by Amy Wang_ Monday, October 5, 2015 10:43 AM
    • Marked as answer by Amy Wang_ Wednesday, October 7, 2015 4:04 AM
    Wednesday, September 23, 2015 3:59 PM
  • I am having the same issue when I try adding host Server i gt the same error .. no matter i updated the OU GPO and still having the issue . 

    ANy idea?

    WJB Man 

    Thursday, December 8, 2016 7:37 PM
  • I know this is an old thread but I came across it when I was having the same issue on a 2019 RDS Farm. The issues seems to be you can either join the Farm from the session host server (via GPO) or join the session host servers from the farm (add session host servers) but not both. If you have any GPOs set in Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\RD Connection Broker\ and try to add the session host from the broker you will get this error. Remove these GPOs from your session host server and try again!
    Friday, September 13, 2019 7:40 PM