none
Forest Preparation Failed Lync 2013 STD (Object reference not set to an instance of an object)

    Question

  • Lync Server 2013 STD on Windows 2012 STD

    Forest Preparation Failed

    Run under root domain (dom1.ab.com) administrator account member of Enterprise admins

    PLEASE HELP

    The error follows

    Process permissions on  "CN=CsPersistentChatAdministrator,CN=Users,DC=dom1,DC=ab,DC=com".   11/19/2012 11:41:20 PM    
         Create permissions for CN=RTC Service,CN=Services,CN=Configuration,DC=dom1,DC=ab,DC=com   11/19/2012 11:41:20 PM    
         Create permissions for ConfigurationContainer   11/19/2012 11:41:25 PM    
         Create permissions for RootDomainSystemContainer   11/19/2012 11:41:25 PM    
         Result: Create permissions for Configuration deleted objects container   11/19/2012 11:41:25 PM    
         TaskFailed: Task execution failed.

    Error: Object reference not set to an instance of an object.
     Details
     Type: NullReferenceException
      Stack Trace
           at
    Microsoft.Rtc.Management.Deployment.LcForest.SetupGroupKey(SharedSecretKey
    groupKey, String ownerGroup, IEnumerable`1 readerGroups, String preferredDC)

    at Microsoft.Rtc.Management.Deployment.LcForest.PrepareForest()

    Monday, November 19, 2012 9:55 PM

Answers

  • I've had the same issue. KB at http://support.microsoft.com/kb/2549544 (specifying -GroupDomain parameter) hasn't solved my problem, but there I've saw that I can try with specifying other parameters. I've tried few times with adding more and more parameters, and finally I've succeeded with:

    Enable-CsAdForest -GroupDomain domain.local -GlobalSettingsDomainController dc.domain.local -GroupDomainController dc.domain.local -GlobalCatalog dc.domain.local

    The last parameter I've added was -GlobalCatalog, and after that the command succeeded. So maybe other parameters are not necessary, but specifying them won't hurt also...

    I hope that it'll resolve your issue also.

    B cool


    Aleksandar


    Monday, November 26, 2012 11:36 PM
  • Running the command Enable-CsAdForest without any switches worked for me. Simply refresh the wizard in the top right corner and you're good to go.


    Steve

    Wednesday, November 28, 2012 10:38 AM
  • Have you manually verified the schema replication?

    Check the prerequisites for Front End server are installed.

    Check you deployment step by step by the following blog.

    http://windowspbx.blogspot.com/2012/07/step-by-step-installing-lync-server.html


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 20, 2012 9:39 AM
    Moderator

All replies

  • Have you manually verified the schema replication?

    Check the prerequisites for Front End server are installed.

    Check you deployment step by step by the following blog.

    http://windowspbx.blogspot.com/2012/07/step-by-step-installing-lync-server.html


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 20, 2012 9:39 AM
    Moderator
  • +1, will let you know when I get it resolved.

    Steve

    Tuesday, November 20, 2012 5:35 PM
  • I've had the same issue. KB at http://support.microsoft.com/kb/2549544 (specifying -GroupDomain parameter) hasn't solved my problem, but there I've saw that I can try with specifying other parameters. I've tried few times with adding more and more parameters, and finally I've succeeded with:

    Enable-CsAdForest -GroupDomain domain.local -GlobalSettingsDomainController dc.domain.local -GroupDomainController dc.domain.local -GlobalCatalog dc.domain.local

    The last parameter I've added was -GlobalCatalog, and after that the command succeeded. So maybe other parameters are not necessary, but specifying them won't hurt also...

    I hope that it'll resolve your issue also.

    B cool


    Aleksandar


    Monday, November 26, 2012 11:36 PM
  • Running the command Enable-CsAdForest without any switches worked for me. Simply refresh the wizard in the top right corner and you're good to go.


    Steve

    Wednesday, November 28, 2012 10:38 AM
  • Just ran into the same issue.  Forest prep seems to barf on the

    "Create permissions for Configuration deleted objects container" step.  Seems like something in their AD had a null setting that shouldn't.  In the case of this client, has 2003 and 2008R2 domain controllers, and they hadn't run the adprep /rodcprep

    Thursday, December 13, 2012 11:50 PM
  • Oh, and I ended up having to run the same command at Fat Dragon, I had already tried with just the -GlobalCatalog and that was insufficient.  Seem to need all the same switches, didn't even work till I added -GlobalSettingsDomainController

    I had also verified Schema replication was successful across the board.

    Thursday, December 13, 2012 11:53 PM
  • This solved it for us as well. We tried multiple permutations, what finally worked was:

    Enable-CsAdForest -GroupDomain domain.local  -GroupDomainController dc.domain.local -GlobalCatalog dc.domain.local

    Fresh install of Lync 2013, no prior versions, GroupDomain used was forest root, run from member server joined to forest root with account from root domain that had EA/DA.

    It failed every time till we saw this post and tried supplying the last 2 options. Went down a lot of rabbit holes about permissions etc but in the end, supplying the 2 options did it. PSS is doing a Post-Mortem. I'll try to remember to update with root cause if we get one.

    Thank you Aleksandar :-)


    • Edited by Bob Free Friday, December 14, 2012 2:00 AM typo
    • Proposed as answer by Gabrielson Eapen Friday, January 04, 2013 4:10 PM
    Friday, December 14, 2012 1:57 AM
  • Worked like a charm.  Recreated my entire CN=RTC Service properly in ADSIEdit.  Great information.

    Thursday, January 17, 2013 2:50 AM
  • I see the same error today, it should be related to AD replication for me.

    I just force demote one of my DC, which has been put offline for a long time and run into the 8614 error and exceed tombstone lifetime issue.

    After force demotion and re-promote to DC again. I finished the Prepare Schema section for Lync, but failed at prepare forest.

    I just fixed this by force replicate for my DCs, and restart the newly promoted DC. Re-run the prepare forest wizard succeeded.


    Sunday, June 09, 2013 8:24 AM
  • Thanks Fat Dragon that worked perfectly! I was about to give up and call M$.
    Tuesday, October 29, 2013 2:54 AM
  • Thanks, this did the trick for me!
    Wednesday, December 25, 2013 5:52 PM
  • I forgot about thus issue, and workarounds are great, but to get to the root of the issue, basically the AD isn't in a healthy state.

    the client site I was working on has 13 GC's reporting in DNS, but only 5 still existed, the others were improperly decommissioned. Other problems with DNS replication, ad replication, the AD site name was the same as the domain netbios name. There were also issues with networking.

    Basically, the environment needed an AD health check and network assessment. Lync is a top of the pyramid application, which means its dependant on many things below. If your running into troubles off the bat like this, assess the health of the whole environment.

    • Proposed as answer by corinaegs Wednesday, January 08, 2014 1:16 AM
    • Unproposed as answer by corinaegs Wednesday, January 08, 2014 1:16 AM
    Wednesday, December 25, 2013 7:18 PM
  • I had the same issue, its solved after manually create the "container" Microsoft, under "container" Program Data from ADSIEdit and rerun the Enable-CsAdForest cmdlet. The complete path is CN=Microsoft,CN=Program Data,DC=domain,DC=local.
    • Proposed as answer by corinaegs Wednesday, January 08, 2014 1:22 AM
    Wednesday, January 08, 2014 1:22 AM
  • Thank You, it worked for me as well!

    Regards,

    Jorge

    Tuesday, April 08, 2014 6:55 AM