none
Windows Server 2012 R2 Datacenter network stuck in Public Mode

    Question

  • I can not get the servers network setting to get out of public mode. I have tried adding sharing to the network and it does not work. I want to change the networks setting into Home mode so that I can remote desktop into the server.
    Wednesday, October 02, 2013 9:39 PM

Answers

  • Hi,

    In order to solve the problem more efficiently I need to clarify some information.

    Firstly, is the server domain-joined?

    If the server is domain-joined, when it starts to detect the network location, once this detection is successful, it will get the domain profile, and we cannot change it.

    Secondly, you mentioned that you have tried the link which provided by Trana, it didn’t work. Would you please tell us how many steps have you completed, and where went wrong?

    Thirdly, is the Public Network clickable at Network and Sharing Center?

    Here are some steps below which I suggest you try:

    1. Hit Winkey + R to open Run prompt and type gpedit.msc.
    2. Navigate to: Computer Configuration /Windows Settings / Security Setting /Network List Manager Policies.
    3. Choose your Network name from the right pane.
    4. Go to Network Location tab and change the Location type from Public to Private.
    5. Close Local Policy Editor.

    Here are some related links below that could be useful to you:

    How do you change network location type on Server 2012?

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/8d0bdf78-1cfb-440c-926e-8998cdba342c/how-do-you-change-network-location-type-on-server-2012?forum=winserver8gen

    15 Windows 8 Tips and Tricks

    http://www.tomsguide.com/us/win8-tips-tricks,review-1778-15.html

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Please feel free to let us know if this method couldn’t solve the problem.

    Best Regards,

    Amy Wang




    Friday, October 04, 2013 9:12 AM
    Moderator

All replies

    • Proposed as answer by Damo_S Tuesday, June 14, 2016 12:07 PM
    Wednesday, October 02, 2013 11:02 PM
  • Tried that and still no luck.
    Thursday, October 03, 2013 12:30 AM
  • Hi,

    In order to solve the problem more efficiently I need to clarify some information.

    Firstly, is the server domain-joined?

    If the server is domain-joined, when it starts to detect the network location, once this detection is successful, it will get the domain profile, and we cannot change it.

    Secondly, you mentioned that you have tried the link which provided by Trana, it didn’t work. Would you please tell us how many steps have you completed, and where went wrong?

    Thirdly, is the Public Network clickable at Network and Sharing Center?

    Here are some steps below which I suggest you try:

    1. Hit Winkey + R to open Run prompt and type gpedit.msc.
    2. Navigate to: Computer Configuration /Windows Settings / Security Setting /Network List Manager Policies.
    3. Choose your Network name from the right pane.
    4. Go to Network Location tab and change the Location type from Public to Private.
    5. Close Local Policy Editor.

    Here are some related links below that could be useful to you:

    How do you change network location type on Server 2012?

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/8d0bdf78-1cfb-440c-926e-8998cdba342c/how-do-you-change-network-location-type-on-server-2012?forum=winserver8gen

    15 Windows 8 Tips and Tricks

    http://www.tomsguide.com/us/win8-tips-tricks,review-1778-15.html

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Please feel free to let us know if this method couldn’t solve the problem.

    Best Regards,

    Amy Wang




    Friday, October 04, 2013 9:12 AM
    Moderator
  • Hi,

    Since we have not heard from you for a while, I assume that this issue is solved.

    I will mark a reply as an answer, please feel free to unmark it if the reply is not helpful.

    We are looking forward to hearing from you.

    Best Regards,

    Amy Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, October 09, 2013 1:23 AM
    Moderator
  • I just wanted to say this did the trick for me.  Thanks!

    Saturday, August 30, 2014 6:03 PM
  • worked good, thank
    Sunday, October 12, 2014 9:28 PM
  • I tried to fix it with the proposed solution with no success.

    This worked for me:

    http://blogs.msmvps.com/russel/2013/12/29/set-network-location-to-private-in-windows-8-1server-2012-r2/

    Tuesday, August 18, 2015 1:54 AM
  • I have the same issue, mine is the primary domain controller for my network, but when I go in to the network settings area, it says public instead of domain network. When I used gpedit.msc, I can only set to private instead of domain network. THIS IS KILLING MY OCD! 
    Sunday, December 13, 2015 12:09 AM
  • I am having the same issues.  Windows Server 2012 Standard.  After rebooting, random domain-joined servers will come up on the "Public" network, rather than the "Domain" network.  Sometimes re-starting the  NLA service will fix the issue, sometimes have to reboot the server again. sometimes both.  Happens on both physical servers as well as VM servers.  Can see no pattern to the issue.

    Found a hotfix for this issue on Windows Server 2008 R2 but not 2012.

    Need a fix for this issue badly!!!!!

    Monday, February 01, 2016 1:18 PM
  • I must say that this NLA feature is pure shit ( sorry about the bad language) but this is what I can feel about this. I have no use of it, I can't even think any use for it. Now I have one 2012 R2 server that won't recognize any networks and say that "You are currently not connected to any networks." But I'm still writing this post just fine! This is MAJOR bug in server 2012 R2. Microsoft should remove this badly designed feature totally - this kill's our servers!

    I just want to see who's the idiot behind of this feature?

    Summa summarum: ANY OF THOSE "SOLUTIONS" DO NOT WORK!

    Q2: Is there any method to totally disable or remove this useless feature? Any hot fix to remove this?
    • Edited by JM68 Tuesday, March 01, 2016 1:12 PM
    Tuesday, March 01, 2016 12:24 PM
  • Morning

    I also Encounter this problem the 1st or 2nd week my deployment server is joined in my domain also my Firewall settings is in DOMAIN. But on the 3rd week (Monday) when I power on the I was shock that my server (windows server 2012 R2) is joined in the domain. BUT MY FIREWALL is in PRIVATE.

    I'll Tried restarting the NLA Service

    I'll Tried restarting the server

    I'll Tried in Powershell applied Set-NetCommunicationProfile -InterfaceIndex XX -NetworkCategory DomainAuthenticated

    Also in Local Security Policies but it can only configured ( PRIVATE AND PUBLIC also Not Configured )

    Still No luck T_T

    Solution: Leave the Domain Group then Re-Join the (Server / Desktop) to Domain Group again

    This worked from me :)

    Hope it helps you guys.


    Monday, October 10, 2016 2:09 AM
  • restarting the NLA service worked for me.
    Tuesday, October 24, 2017 9:27 PM
  • Or just set the Network Location Awareness service to delayed start. Works for Domain controllers  

    • Edited by ScottdKelso Wednesday, January 24, 2018 9:09 PM
    Wednesday, January 24, 2018 8:57 PM
  • We are experiencing this issue randomly (1 person every few months) in Windows 10.  So this is still an issue even today.

    Monday, June 11, 2018 6:18 PM