One Way Audio on Polycom phones after putting someone on hold RRS feed

  • Question

  • We have had an intermittent ongoing issue (the best kind). A user will get an incoming call (on a CX600 or CX300) that will work just fine. Then, they'll put them on hold for a bit and when they take them off hold (using the physical hold button on the phones) there is only one way audio (outbound audio always works). With further testing we found that if the user always uses the "Resume" button in the Lync window for the call on their computer then the problem never arises. It is only when you take them off hold with the actual button on the Polycom phone. So, it seems to be clearly a device issue but I haven't found anyone else mentioning this problem (we use a few Snom 821 UC edition phones and have never had the issue). Anyone else experiencing this at all?

    Also...Our CX600 phones have the latest firmware pushed out to them.

    thanks in advance


    Wednesday, December 19, 2012 8:47 PM

All replies

  • Steve,

    Is there a common call flow scenario where this is seen?  For example only Lync to PSTN callers through a gateway or does this happen even with Lync to Lync peer calls?  Is there any pattern related to the length of the hold, or call direction?  Has this issue appeared recently?

    Jeff Schertz | Microsoft Solutions Architect - Polycom | Lync MVP

    Wednesday, December 19, 2012 9:55 PM
  • the only commonality that I know of is that it is always with incoming calls. It happens on PSTN calls and internal Lync only calls. This isn't a recent thing, it just took me a long long time to narrow down (I could never reproduce it as I never use the buttons on the phone, only the buttons on the computer Lync client) because it is so intermittent (1-2 a week for moderate\heavy users). When I look at diagnostics in Lync or on our gateway, etc, everything looks great. No errors anywhere. I have a few users waiting to trap the issue again and see if putting them back on hold and then resuming from the computer changes anything so I'll let you know when I know anything but it is very odd indeed


    Wednesday, December 19, 2012 9:59 PM
  • If this problem happened randomly, that may not be the phone’s problem, it may be the data lost in date transport. Try to install the latest update for Lync server 2010.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, December 21, 2012 9:22 AM
  • we are on the latest version of Lync at the moment and we still get the problem here and there but never when using the Lync client for resuming a call so I find it hard to believe it is the data transport but I am certainly open to any theories that could lead to resolving this issue


    Friday, December 21, 2012 5:31 PM
  • Use the Lync Logging Tool to collect the log file.

    You can select S4, SIPStack and mediation server for logging option.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, December 26, 2012 7:47 AM
  • I have done that already and never found anything showing an issue. All looks good in any of the logs. That is why I feel it has something to do with the endpoint device
    Wednesday, January 2, 2013 5:30 PM
  • May I add a "me too"?

    We have exactly this issue in our enviroment.  We use mostly Polycom CX600 and CX300, but in our reception area our operator uses a USB-connected Jabra headsets.  She also has a CX600 on her desk, but it is not connected to her computer in any way - it's just a fallback in case the headset fails.  It's just sitting alone as a network device and it stays signed in with her credentials.

    Some of the Polycom CX600 users report the one-way-audio-after-retrieving-from-hold-issue, but so does the Jabra operator - in fact she experiences it more often, but then she uses the phone continuously so that's not really a surprise.

    Monday, January 21, 2013 11:46 PM
  • Me Too:


    We have a single-site, single Pool, Lync Standard with Enterprise Voice deployment and a separate (not co-located) Mediation server with a direct SIP trunk. The endpoints are Polycom CX600 phones with a mix of the December 2012 and January 2013 updats.

    We've recently started having issues with severe audio distortion for the Lync user when a PSTN call is resumed from hold. The External person hears the audio fine but the Lync user hears highly distorted audio.

    Working with our SIP trunk provider and looking at our monitoring server, we can see that the the media quality becomes severely degraded for the Mediation Server  --> Polycom Phone leg. I'm attaching a screen shot of an affected call.

    This only appears to happen with Polycom CX600 phones with external calls. Lync calls and calls made with the Lync client do not seem to to affected.

    These issues suddenly started on 31st Jan 2013. Before there were no isues and suddenly we're experiencing them. I don't know anough about what all the various metric in the call logs mean. Can someone tell me in lay terms what is happening to the call and why the audio is distorted? The phones share the same gigabit network as other Lync clients and the audio distortion only happens when a call is resumed from hold, there is no issue with the audio for normal calls.



    Friday, February 1, 2013 4:55 PM
  • that sounds like a different issue but one I experienced before also and was able to fix. Are you using a Dialogic gateway? If so, you probably need to adjust the "Packet Time (ms) for Inbound VoIP" under the VOIP Media area to be 20 instead of the default of 30. It might be that your IP provider changed what options they published or something so the packet time used to be set by them and no longer is so your gateway is now falling back to its default.

    If you aren't using a gateway but connecting directly to your SIP trunks you should mention this setting to them so they can see if something changed on their end


    Friday, February 1, 2013 9:06 PM
  • Hi Scarr4,

    We have direct SIP to a provider from our Mediation server.

    Looking through the comprehensive Lync reporting, all things point to the leg between the mediation server and the end point. The affected endpoints seem to be the PolyCom CX600 and CX3000, the CX700 are unaffected by this hold-resume issue.

    The Lync reporting for call quality splits out the various legs of the call (e.g. SIP to Mediation, Mediation to endpoint) and the quality is fine until it reaches the Mediation Server to phone leg. We've updated the phone firmware to latest but this has made no change.

    At the moment, I'm still trying to decipher what all the verious metric in the reporting mean.



    Monday, February 4, 2013 10:16 AM
  • Hello Sunil,

    I am experiencing also the same problem. At random, some calls get the audio quality deteriorated when resuming a call placed on hold (CX600). Our environment is Lync2010 Ent, CXs on the latest update.

    Did you have any new developments dealing w/ this issue?

    Wednesday, June 12, 2013 7:04 PM
  • sorry, no new developments. We turned off SRTP between our Dialogic gateway and Lync to temporarily get more logging data and the problem went away. So, we wonder if the added encryption layer was messing things up somehow. We are still logging as much as we can in the event that we get another one-way call but haven't for a few months now.
    Wednesday, June 12, 2013 11:18 PM
  • Hello Crico,

    Unfortunately, there haven't been any updates or developments to this. We've had a couple of rounds of firmware updates to the Polycom phones since this all started and I believe the issue still exists (it was still there on the last firmware version). I've essentially given up, small consolation for me that I know I'm not the only person having this problem, unfortunately for you, we're in the same boat.

    I have no confidence this will be "discovered" and addressed by Polycom or Microsoft and I don't know the conditions required that would reproduce this issue, I can reproduce it easily in our environment though.

    For the moment the options are:

    1. Tolerate the problem and use workarounds if possible (e.g mute and call park)

    2. Terminate the problem by replacing the Polycom units with those of another vendor (expensive)

    3. Treat the problem by re-implementing the entire Lync environment and hope the issue does not reoccur (now and when subesequent firmware updates are installed)

    4. Transfer the problem by purchasing consulting or leveraging existing Support contracts to have a third party or Polycom directly deal with the issue.


    Thursday, June 13, 2013 8:57 AM
  • I am having the distortion after hold issue at many sites that have a Sonus SBA. The end points are Aastra 6725IP phones, so it is not strictly a Polycom thing or Dialogic. The ender users have nicknamed it the "Demon Voice" issue. I don't believe we have seen it at the corporate site, which doesn't have an SBA and mostly CX300 phones. I have done very little troubleshooting, as it is highly intermittent.
    Thursday, July 11, 2013 2:53 PM
  • Hi,

    That's interesting because our SIP trunk provider uses a Sonus/NetUX SBC at their end.

    "Demon Voice" is a very good name for it. We can pretty much always reproduce the issue with it with external calls (e.g. calls through the SBC).


    Thursday, July 11, 2013 2:58 PM
  • Yes, Demon Voice is actually the phrase used by one of our users. Our first report of this issue was on 07/12 and again today.

    We use a mix of CX600's, CX300's and Lync 2010 clients with headsets. Our first reports of the issue were with users that only use headsets and the Lync client. Our gateway is an Audiocodes Mediant 1000 and we have encryption disabled due to an issue with Lync in the past.

    About 2-4 weeks ago, we rolled out the most recent firmware updates to the phones and about a week later we updated Lync 2010 to CU8. I can't help but think there is a connection. All calls appear to be inbound PSTN calls that were placed on hold.

    Friday, July 19, 2013 4:31 PM
  • I'd like to add that I am also experiencing this issue.  Funny that our users reported it as a "Demon/Devil Voice" as well.  Our first reports started about 1.5 weeks ago.  Occurs with only PSTN calls that are resumed after being on hold.  Here are the details:

    - Issue occurs on PSTN call resumed after being on hold

    - Users reporting are using CX600 & CX500 phones

    - Phones recently upgraded to firmware 4372

    - Calls come from SIP trunk to AudioCodes Mediant 1000 SBA

    - Highly Intermittent 

    I've brought this to the attention of a Polycom Senior Engineering we have working with for another project and he is currently looking it and will work with me to try to troubleshoot the issue.


    Wednesday, July 24, 2013 11:19 PM
  • Hello Jamie,

    I hope the Polycom Senior Engineering team will look into this and at least be able to replicate the issue in their environment. Please keep us up to date with how you and the Polycom team get on.



    Friday, July 26, 2013 10:46 AM
  • I'm not sure this would be a solution or help others but when I changed our gateway (a Dialogic box) to not use TCP instead TLS (so we could do some better logging to try and find the issue) the problems went away. So, I'm guessing there is an encryption\decryption problem somewhere along the line. We did this about 4 months ago and haven't had one report of the issue since (I was logging everything I could for a while to trap the issue but I've shut all that down as the problem hasn't returned). Anyway, not sure this will help others pinpoint the issue but I figured I'd put it out there.


    Thursday, October 17, 2013 7:32 PM
  • I too have this issue with one of my client's Lync deployments.  AudioCodes gateway, Polycom CX600 phones, Lync 2010.  Lync and Polycom are up to date.  I will try the TCP instead of TLS and see what happens.
    Thursday, November 21, 2013 12:47 AM
  • I too have this issue with one of my client's Lync deployments.  AudioCodes gateway, Polycom CX600 phones, Lync 2010.  Lync and Polycom are up to date.  I will try the TCP instead of TLS and see what happens.

    Tuesday, November 26, 2013 2:24 PM
  • Hi we are doing a poc for Exterprise voice intigration between Lync server 2010 and Avaya G650 Gateway.

    We have completed the intigration and can do the calls from both end mean from Lync client to Avaya phone and from Avaya phone to Lync client. But issue is when we are doing call from Avaya phone to Lync client there is no audio and when doing call from lync client to Avaya phone it works greatly.

    Audio issue when doing call from Avaya phone to Lync client 2010.

    Please help to troubleshoot this issue.

    Vinesh Kumar

    Thanks Vinesh Rathi

    Tuesday, November 26, 2013 2:25 PM
  • I'm experiencing this same issue. The issue is on inbound calls that SIP trunk to a Mediant 1000, Lync 2010, on CX600 phones. My users are equating it to the sound of a tape being played back in slow motion.

    Anyone tried opening up a ticket with AudioCodes?

    Tuesday, November 26, 2013 8:17 PM
  • We opened a case with AudioCodes.  We captured some traffic with WireShark and they analyzed it and were able to recombine the packets and play back the audio, which sounded fine.  We also tested with a Polycom VVX500 phone, which does not experience the issue.  So it doesn't appear to be an AudioCodes issue to me at this point.  I have an open case with Microsoft support, I'm waiting for feedback.  Seems to be an issue with the CX600 phones.

    Our environment is similar; Lync 2010, Mediant 1000, CX600 phones.

    Tuesday, November 26, 2013 8:50 PM
  • Keen to find out if there has been any fix or conclusion to this problem, we are using the Polycom CX600 with Lync and experiencing the same. Users report when retrieving a call back from hold using the handsets, the caller then sounds like Darth Vader. It is a frustrating problem and trailing through forums looks to be a common problem with no real fix.

    Its seems highly unlikely to be a configuration problem given the no of different environments experiencing the same.

    Thursday, January 2, 2014 3:02 AM
  • sorry to say that nothing has ever been resolved w.r.t to this issue. I've just trained our staff to calmly tell the person on the other end to hang on one second, place them on hold again, and then release them again as that usually fixes the issue. I've tried every version of "firmware" for those phones and tested with Lync 2010 and Lync 2013 and with an AudioCodes gateway and a Dialogic gateway and nothing seems to matter. Fortunately I'd guess it happens 1 out of 100 times so we've decided to move on at this point. Sad that Polycom doesn't seem interested but I guess that is the way it goes


    Friday, January 3, 2014 5:44 PM
  • At this point, we are just going to purchase different phones.  We just don't have that many phones that are affected by this and doesn't make financial sense to continue spending time on the issue.  I can't recommend these phones to any of my other clients in the future.
    Tuesday, January 7, 2014 3:43 PM
  • Microsoft just released an update for Lync Phone Edition.  Looks to address the issue, but I have not tried the fix yet.  Will be doing so soon.

    http://support.microsoft.com/kb/2918039 and http://support.microsoft.com/kb/2918038/en-us

    • Proposed as answer by Simone_Bennett Wednesday, October 28, 2015 1:10 AM
    Monday, January 20, 2014 7:29 PM
  • I tested the fix all last week with our users and they are happy to report this issue is gone.
    Monday, January 20, 2014 7:32 PM
  • Did you have to disable 'music on hold'?  And if so, how do you do that?
    Monday, January 20, 2014 7:34 PM
  • That was originally a suggestion during troubleshooting with Microsoft.  This is not needed.  Just update the FW on the phones.
    Monday, January 20, 2014 7:54 PM
  • Hi all,

    We have Lync 2010, Sonus gateways, dell hardware and polycom devices. Everything gets patched every few months.

    In the past few months i've done bothing but chase down a few similar issues so i thought it might help someone if i updated the forum posts that i had searched for in my quest for answers :)

    1. One way audio when a call is transferred

    When issues were initially reported for some users we discovered that if a user had an out of date NIC card driver and called a Lync user that then transferred them in a specific way they had one way audio.
    For example:

    • I call you, I have an old NIC card driver
    • You consult transfer me to someone using the 2nd call window/active transfer button (the person you just called to check their availability)
    • When the call is transferred I can hear audio but the final recipient of the call can't hear me
    • The fix was to update the NIC card driver and re-recreate the profile

    2. Bad call quality and random call disconnections

    We logged tickets with our telco and WAN provider and found that they were ropping the QoS tags for voice traffic and didn't realise.

    We also had random issues where telstra changed the wideband codec on SOME towers so calls that originated from those towers had no audio in both directions.

    2. Random call disconnections or one way audio when a caller is placed on hold

    We were not able to re-create this issue on demand but opened a ticket with Microsoft, Telstra and Sonus. To collect logs we:

        Mirrored the port on the sonus and pointed it to wireshark
        Installed wireshark on a user's PC that reported the issue regularily
        Used LX to capture logs from the sonus/sbc
        Used the lync logging tool to capture logs from the front end

    When we had the logs we found that there was a race condition in the PCAP file from wireshark. We were also able to confirm that it wasn't the users device becuase we could see in wireshark that audio was only one way. The support techs from sonus advised:

    "I think I see the cause of the "race" condition: there is a Message Translation Table to translate SIP 183 to SIP 180.  What is happening is Lync is sending numerous SIP 183 messages and each time the SBC translates it to SIP 180 with Require: 100rel; which causes Telstra to send a PRACK.  This happens so many times that Telstra declares a "race" condition and I suspect that is why audio is not passed from them

    I suggest that you make this change to the Message Translation Table "183 to 180" -> Send Message to "No on Subsequent".  What this means is the SBC will translate the first SIP 183 to SIP 180 and then will not translate any other SIP 183 messages for the current call.  This should eliminate the "race" condition."

    Making this change appeared to have resolved the issue for us. I hope that helps someone :)

    ----- More info -----

    Following is a list of things we tried to re-create the one way audio issue:

        Patched Lync server, handsets, gateways and SBA’s
        Resolve any small client side issue like – group policy being incorrect for that machines, firewalls being on, updates not applying, bad cables etc
        Turn off local machine firewalls
        Install all the latest windows and office updates
        Disable team calls
        Replace the wireless and Bluetooth headset with a wired USB headset
        Try transferring the call to see if audio is restored
        Try putting the call on and off hold a few times to see if audio is restored
        Try answering the call on the computer and not the headset/ try answering only on the headset
        Update NIC and PC BIOS firmware
        Tested calls inbound from Telstra, Virgin, Vodafone and Optus mobiles
        Stacked up many calls at a time, generated load, tested when the network and gateway were busy
        Changed the trunk configuration per this blog http://memphistech.net/?p=169

    Some other posts that might help if you're desperate:

    *People with similar issues where encryption was the culprit:

    *People with similar issues where ethe firewall was the culprit:

    *People with similar issues where software updates were the culprit:

    *Where the issue was resolved by removing USB hubs & booting the machine with no USB devices plugged in:

    *People who had the same issue in 2013:
    One way audio: https://social.technet.microsoft.com/Forums/en-US/40f97aa2-ada1-4e45-ba0c-8cf9c7951209/lync-2013-one-way-audio?forum=lyncvoice

    Comment saying one way audio was resolved by disabling SIP UPDATE method between the SBC and Lync http://unifiedme.co.uk/2013/10/troubleshooting-one-way-audio-ringback-issues-lync-2013/

    • Proposed as answer by BigChaps Wednesday, October 28, 2015 4:59 AM
    Wednesday, October 28, 2015 1:08 AM